Ethernet Switches Community

Expand all | Collapse all

SGMII + SFP fiber module on BCM53134

  • 1.  SGMII + SFP fiber module on BCM53134

    Posted 08-10-2017 10:24 PM

    Hi!

    I'm trying to configure port5 on BCM53134P (BCM953134 eval board) as SGMII to use SFP module AFBR-5710AP. But I can't establish a connection via fiber optics interface. My scheme:

    scheme.jpg

    I'm currently using this article:

    Please, answer a few questions:

    1) I can't find SPI page 0x14 description (mentioned in the article) in my register programming guide "53134-PR203-RDS, 53134-PR103-RDS". Do I have a proper documentation? Maybe there is another appnote concerning my problem?

    2) SPI page 0xe6 offset 0x40 always return 0x00000000, it's OK?

    3) In "53134P-DS101-R" is mentioned that port5 has a built-in SerDes ("SGMII/SERDES"). But I can't find detailed descriptions of SGMII configuration for SFP module usage. Can I connect SFP modules to my BCM53134P directly? Or do I have to use SGMII-SFP modules with build-in PHY only?

    UPDATE:

    My chip revision is B1


    #sgmii
    #bcm53134
    #EthernetSwitchesCommunity
    #fiber100base-fx1000base-xsfp


  • 2.  Re: SGMII + SFP fiber module on BCM53134

    Posted 08-17-2017 04:14 AM

    Hi,

    Could you help to double check your 53134P strap pin state "LED6_SGMII_P8_SEL" and clock source if to use Port5 in SGMII interface?

    - The strap LED6_SGMII_P8_SEL = 0 for Port5 SGMII interface.

    - it requires to use 50MHz crystal for SGMII interface operation.

    Please find the below comment per your questions:

    1. I am double checking it.

    2. it seems your SGMII port is not link up yet. Please double check to make sure to complete the SGMII registers configure.

    3. The 53134 SGMII port interface can direct connect to the SFP module. We have verified 53134 SGMII port in lab, it does not need to use SFP with embedded PHY. Can you share your SFP module AFBR-5710AP spec?

    Thanks,

    Ryan


    #EthernetSwitchesCommunity


  • 3.  Re: SGMII + SFP fiber module on BCM53134

    Posted 08-18-2017 12:15 AM

    >> The strap LED6_SGMII_P8_SEL = 0 for Port5 SGMII interface

    I've just checked the state of pin "LED6_SGMII_P8_SEL". This pin has low value (0).

    >> It requires to use 50MHz crystal for SGMII interface operation

    My BCM953134 eval board has 50 MHz crystal installed and LED5 pin is strapped to 1. Am I doing this right?

    Or there is another way to choose some kind of "clock source" in BCM53134P?

    >> Please double check to make sure to complete the SGMII registers configure

    Could you please check my registers configuration (below)?

         b53_read8(dev, 0x00, 0x5d, read);

         read |= 0x4b;

         b53_write8(dev, 0x00, 0x5d, read);

         b53_write8(dev, 0xe6, 0x00, 0x01);

         b53_write16(dev, 0x14, 0x3e, 0x8000);

         b53_write16(dev, 0x14, 0x20, 0x0c2f);

         b53_write16(dev, 0x14, 0x3e, 0x8300);

         b53_write16(dev, 0x14, 0x20, 0x010d);

         b53_write16(dev, 0x14, 0x3e, 0x8470);

         b53_write16(dev, 0x14, 0x26, 0x1251);

         b53_write16(dev, 0x14, 0x3e, 0x8340);

         b53_write16(dev, 0x14, 0x34, 0x0003);

         b53_write16(dev, 0x14, 0x3e, 0x8000);

         b53_write16(dev, 0x14, 0x00, 0x0140);

         b53_write16(dev, 0x14, 0x20, 0x2c2f);

    >>  Can you share your SFP module AFBR-5710AP spec?

    1. Sure. It's  AFBR-5710APZ actually (my mistake, sry). Here it is - http://www.fit-foxconn.com/Images/Products/Spec/AFBR-5710PZ_20160510175033177.pdf

    >>  We have verified 53134 SGMII port in lab, it does not need to use SFP with embedded PHY

    Could you please tell me what SFP module was used for the verification?


    #EthernetSwitchesCommunity


  • 4.  Re: SGMII + SFP fiber module on BCM53134

    Posted 08-24-2017 02:49 AM

    Hi,

    I did not see the abnormal strap pin setting in your replied.

    Can I double check with you for your 53134 LED[0] pin? Does your 53134 LED[0] be set to 1 during power on?

    The LED[0] pin is with our internal test function and it needs to default pull down to select the crystal clock source.

    For your SGMII register configure, looks follow our doc. May I double check are you using SPI interface or MDC/MDIO interface to access BCM53134?

    We have verified BCM53134 SGMII port on our SVK board by the attached cable as attached for your reference.

    Do you have similar attached cable to verify again?

    We are double checking the SFP module link you provided.

    Thanks,

    Ryan


    #EthernetSwitchesCommunity


  • 5.  Re: SGMII + SFP fiber module on BCM53134

    Posted 08-24-2017 03:01 AM

    SFP+ 74752 Datasheet Passive 10G DAC.png

    Could you double check molex web site for the detail spec of "SFP+ 74752 Datasheet Passive 10G DAC"?

    Thanks,

    Ryan


    #EthernetSwitchesCommunity


  • 6.  Re: SGMII + SFP fiber module on BCM53134

    Posted 08-24-2017 09:47 PM

    Hi! Thanks for your answer.

    >>> Do you have similar attached cable to verify again?

    I do not have such cable, but I'll try to find it

    >>> May I double check are you using SPI interface or MDC/MDIO interface to access BCM53134?

    SPI interface are using to access BCM53134.

    >>> Can I double check with you for your 53134 LED[0] pin? Does your 53134 LED[0] be set to 1 during power on?

    LED0 is strapped to 0 on my eval board(SW2102 link pin 2-3 & 5-6). I made some screenshots during 53134 init process(1st channel):

    1) LED0 power on

    TEK0000.BMP

    2) abous 3s LED0 cyclically switch from 1 to 0 and from 0 to 1

    TEK0001.BMP

    3) then this pict abous 1-2s

    TEK0002.BMP

    4) and finaly this sequence continues indefinitely

    TEK0003.BMP

    Looks OK?


    #EthernetSwitchesCommunity