Brocade SAN Health Community

Expand all | Collapse all

Error when scheduling SAN health using windows task scheduler

Jump to Best Answer
  • 1.  Error when scheduling SAN health using windows task scheduler

    Posted 03-19-2014 06:45 AM

    Hello,

     

    We are trying to automate running of SAN health using windows task scheduler and communication between the windows machine and our SMTP server such that SAN health should run on a particular date and time and using 'auto upload' option of SAN health tool, the generated file should be sent automatically to Brocade for report generation. 

     

    The SAN health runs perfectly fine when run manually.

     

    We have done the following in the windows task scheduler:

     

    Program to run on scheduled time: "C:\Program Files\Brocade\SAN Health\SANHealth.exe" (with the " ")

    optional arguments: /autostart C:\SAN Health Audits\Pureflex\PUREFLEX

    To be run only when user is logged on

     

    We are receiving the below error irrespective of the windows OS type (windows serve 2008 / windows 7).

     

    An error has occurred.
    1)Check LAN connectivity and for information entered incorrectly into SAN health
    2)Ensure you are using the latest version of SAN health
    3)Reinstall SAN health and reboot Windows to ensure all libraries are correctly installed
    4)If this error continues to occur please send the following information to SHAdmin@brocade.com
    a) This error message which has been saved to WorkingDir\Audit Logs\
    b) The .SET file used
    c) The Windows version and patch level
    d) Screenshots of any relevant windows
    Error Number: 52 Bad file name or number
    Module: SANHealthV4
    Additional Info: Interpretting the command String
    Version: 4.0.0c
    Build Number: DC03032014
    -14:30:21 New SAN Audit Set Started Using SAN Health Version 4.0.0c
    -14:30:21> Initializing Log

     

     

    We are running latest SAN health tool and even rebooted the windows machines after installation.

     

    Best Regards

    HKV


    #BrocadeSANHealthCommunity


  • 2.  Re: Error when scheduling SAN health using windows task scheduler

    Posted 03-19-2014 09:23 AM

    Couple off things that grab my attention.

     

    1> your optional arguments contains the path to a *.set file, but no file is specified.

    resulting in the -14:30:21 New SAN Audit Set Started Using SAN Health Version 4.0.0c message

     

    2>you are not using a .bat file to call sanhealth as sanhealth itself instructs you to do, maybe not needed but I didn't test that

     

    3> the switch is not needed is placed wrong.
     Syntax should be command pathtofile+filename /autostart

     

    If placed correct on the CLI it works for me.

    To be fair I didn't test it as scheduled job nor as bat file, so the above might be redundant.


    #BrocadeSANHealthCommunity


  • 3.  Re: Error when scheduling SAN health using windows task scheduler

    Posted 03-20-2014 02:53 AM
      |   view attached

    Hello,

     

    Yes, you are right. We were not specifying the extension of the file which we corrected and made to <abc>.SET. After this the scheduling works - SAN health tool is launched and the .SET file is loaded automatically BUT it stops at the screen of 'pre-flight check' / 'start audit' for manual intervention. 

     

    Our aim is to have the SAN health start automatically on a schedule and launch the data / performance capture automatically. We used the '/autostart' in the arguments section before specifying the complete path to the file but it throws the same error as in my original post :(

     

    From what we understand, do you mean to put the '/autostart' option at the end in the arguments? The attached screenshot shows the current way we are giving the path to file and arguments but it is giving error.


    #BrocadeSANHealthCommunity


  • 4.  Re: Error when scheduling SAN health using windows task scheduler
    Best Answer

    Posted 03-20-2014 05:18 AM

    Yeag sorry, I was not entirely clear, the /autostart switch should be and the end


    #BrocadeSANHealthCommunity