Brocade Management Software Community

Expand all | Collapse all

BNA 12.4.2 element manager wont launch

Jump to Best Answer
  • 1.  BNA 12.4.2 element manager wont launch

    Posted 12-02-2015 12:04 PM

     

    Windows 2012R2

    BNA 12.4.2

    New install

     

    BNA starts and displays home screen.

    when selecting Configure -> hardware the element manager doesnt display

    same for ports and admin

     

    I can launch webtools directly and it works to look at ports, admin, nameserver.

     

    looked through the log files but nothing of interest as to what is happening.

     

    Suggestions on what needs to be configured or how to troubleshoot are appreciated.


    #element
    #ElementManager
    #manger
    #BrocadeManagementSoftwareCommunity


  • 2.  Re: BNA 12.4.2 element manager wont launch

    Posted 12-02-2015 04:23 PM

    What sort of device are you trying to manage?

     

    Do you see any Java popup at all? You may need to enable the Java console & look for error messages there.


    #BrocadeManagementSoftwareCommunity


  • 3.  Re: BNA 12.4.2 element manager wont launch

    Posted 12-06-2015 05:22 PM

    I am managing a Brocade 6510.

    no java popup at all.

    I enabled the console in control panel/ java/advanced.

    but still no popup. that was for 1.8 but BNA runs an embedded java of 1.7.

     

    is there something else I have to change to enable the console in the embedded jre?


    #BrocadeManagementSoftwareCommunity


  • 4.  Re: BNA 12.4.2 element manager wont launch
    Best Answer

    Posted 12-06-2015 05:37 PM

    found the answer here:

    http://community.brocade.com/t5/Management-Software/HP-B-series-SAN-Network-Advisor-12-1-5-Element-Manager-not/td-p/57980

     

     

    Insofar as opening WT, try this on the BNA server: 1) Uninstall all other JREs(except BNA bundled JRE). 2) Close all the BNA clients 3) Open command prompt(Run as Administrator) and navigate to “\jre64\bin” (Ex: C:\Program Files\Network Advisor 12.0.3\jre64\bin) 4) Execute the command “javaws –viewer” 5) This will launch the Java Control Panel 6) Navigate to “Security” tab 7) Now Enable the “Enable Java content in the browser” check box and click “Apply” and then “Ok” I got this from Brocade support today for what appears to be the same problem. I had to "Disable Java Content" apply and then re-enable it to make this work.


    #BrocadeManagementSoftwareCommunity