Brocade Fibre Channel Networking Community

Expand all | Collapse all

Newline character after alias in brocade switch configuration

  • 1.  Newline character after alias in brocade switch configuration

    Posted 03-20-2013 07:07 PM

    Hi,

    I am running the following Fabric OS version:

    Kernel: 2.6.14.2  

    Fabric OS:  v6.3.0c

    Made on:Fri Dec 18 06:03:21 2009
    Flash:  Sun Feb 28 15:33:20 2010

    BootProm:   1.0.9

    I am writing some Perl scripts to automate some zoning tasks.

    When I do an 'aliShow', some of the aliases put the alias name and wwn on seperate lines, and some of them have the alias and wwn on the same line.

    eg. (server 3 below is on the same line)

    alias: server1

                    10:00:00:00:c9:57:09:9f

    alias: server2

                    10:00:00:00:c9:71:4c:94

    alias: server3  10:00:00:00:c9:95:e8:7f

    alias: server4

                    10:00:00:00:c9:79:e2:ee

    alias: server5

                    10:00:00:00:c9:79:e2:8f

    Any idea why this happens or how I can force the wwn to always be on a seperate line?

    Thanks in advance


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: Newline character after alias in brocade switch configuration

    Posted 03-21-2013 01:40 AM

    Hi,

    I have created those very same alias in my switch and they all are printed in the same line.

    I recommend you to choose alias names with one extra character so that all the alias, without exception, are printed with the name and the WWN in separate lines.

    rgds,


    #BrocadeFibreChannelNetworkingCommunity