Brocade Fibre Channel Networking Community

Expand all | Collapse all

san switch fabric port configuration

Jump to Best Answer
  • 1.  san switch fabric port configuration

    Posted 06-29-2015 04:54 AM

    Hi,

    I think I have a small issue with a FC fabric between my two datacenters. The distance is about 40 km. I have in place right GBICs (they can manage up to 80 km). I have the extended fabric license in place on san switches and I did manage to create the fabric between the datacenters.

     

    I have changed the Buffer Credits on these ports to 120, as I understood that it would be ok to have it like this due to long distance.

     

    But i experience some performance issues. As i understood, the ports used for creating the fabric between the two datacenters should be configured as LONG DISTANCE, not as NORMAL. The thing for me is that I cannot change this configuration. Whe I do this I get the error:

    ''Error: failed to configure port x. Operation requested with EstimatedDistance 50 Operation failed - port is already configured as F_Port buffers enabled port x.''

     

    What does this means exactly?

    Thank you!

     


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: san switch fabric port configuration

    Posted 06-29-2015 09:28 AM

    You used portcfgfportbuffers to give the port more buffers, but as the name suggests this is solely for F-ports - in terms of "ports with an end-device attached". Not for E-ports.

    You need to disable these F-port buffers again and then choose the proper long distance mode by using portcfglongdistance. The best would be to use LS mode and a proper factor for the length as described here:

    https://www.ibm.com/developerworks/community/blogs/sanblog/entry/san_myths_uncovered_2_the_ld_mode_brocade3?lang=en

     

    You can check with portbuffershow how many buffers you have left in the ASIC.

    Depending which switch model and FOS version you use, you can even measure the average frame size and use it as a parameter for the long distance port. The admin guide is you friend :)


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: san switch fabric port configuration

    Posted 08-05-2015 01:22 AM

    Hello Sebastian,

    Thank you for your answer. It does not seems to be working. the command

    poartcfglongdistance 0/0 LS 1 -distance 70

    generates error

    invalid number of parameters (-33)

     

    This is the command in the guide

    portcfglongdistance 12/6 LS 1 -distance 100

     

    So it should work, I guess. But there seems to be some issues in my case.

    Any tips appreciated.

    Thank you!


    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: san switch fabric port configuration

    Posted 08-05-2015 01:51 AM

    I think this might have something to do with ISL mode or something like this.


    #BrocadeFibreChannelNetworkingCommunity


  • 5.  Re: san switch fabric port configuration

    Posted 08-06-2015 12:04 AM

    I just tried it and it worked for me. Which FabricOS do you have installed?


    #BrocadeFibreChannelNetworkingCommunity


  • 6.  Re: san switch fabric port configuration
    Best Answer

    Posted 08-06-2015 02:46 AM

    Hi,

    I have managed to make it work. First of all I had to remove the cable from the port. Then i had to restore the configuration of the port to default using portcfgdefault. Then I have managed to configure the port for long distance.

    Thank you for your help!

     


    #BrocadeFibreChannelNetworkingCommunity


  • 7.  Re: san switch fabric port configuration

    Posted 12-16-2015 07:07 PM

    I know this was from a long time ago, but when you finally got it set for long distance did it solve your original performance issue?


    #BrocadeFibreChannelNetworkingCommunity


  • 8.  Re: san switch fabric port configuration

    Posted 12-17-2015 12:17 AM


  • 9.  Re: san switch fabric port configuration

    Posted 08-05-2015 01:54 AM

    No, the configuration of the ports is identical.


    #BrocadeFibreChannelNetworkingCommunity