Brocade Fibre Channel Networking Community

Expand all | Collapse all

configupload fails

Jump to Best Answer
  • 1.  configupload fails

    Posted 12-03-2013 02:32 AM

    Brocade Silkworm 200E

    Kernel:     2.4.19
    Fabric OS:  v5.2.1b
    switchType:     34.0


    I'm trying to perform "configupload' interactively to a local FTP Server that's on the same network, using the IP address of the FTP. The ftp account has full rights. However the "configupload" fails stating that "configUpload not permitted (ftp failed). Could not connect to remote host". I tried this on a similar switch (not an ISL in between), same result - failed.


    I'm able to manually connect to the FTP server from a PC, using the same credential and perform upload/download successfully.


    Does anyone have any idea?


  • 2.  Re: configupload fails

    Posted 12-03-2013 02:59 AM

    What do the logs on the FTP server show when the upload fails?

    Does it wotk with SCP and if not what do those logs show?



  • 3.  Re: configupload fails

    Posted 12-03-2013 04:37 AM

    Here's what've done so far:


    1. Connected to the switch via SSH and did "configupload"




    Note: I did enter the IP address of the FTP Server. I've intentionaly hidden it for security reasons.


    Result: failed


    2. Connected to the same switch via HTTPS




    Though it says "completed successfully", I don't see "config.txt" on the FTP Server.



    Both attemtps have been done by using "anonymous/anonymous". Moreover, when I manually connect to the FTP Server (vsftpd), I see my session being logged in /var/log/vsftpd.log, but when I try the same on the switch (SSH & HTTPS), I don't see the switch is being connected at all.


    3. Connected to the switch and performed "configupload" via SCP




  • 4.  Re: configupload fails

    Posted 12-03-2013 07:47 AM

    Instead of the default value for the file, specify full path and name. Does it work now?

    Again scp/ftp


  • 5.  Re: configupload fails

    Posted 12-04-2013 02:56 AM

    Did not make a difference at all.I tried "configupload" on Brocade Silkworm 3850 and had the same behavior.


    I don't know if it is me who's doing things incorrectly. This switch and a couple of other switches need to be shutdown and migrated to another datacenter and we really want to ensure the configs are saved somewhere before we migrate them.


    1. SCP Enabled and tried with different file name.







    2. FTP with different file name





    3. SCP with different name and full path





    4. FTP with different name and full path





    5. FTP with non-interactive




  • 6.  Re: configupload fails

    Posted 12-04-2013 04:18 AM

    Not really a solution, but perhaps enough for you to go forward on the DC move.


    Have putty logging enabled to a file (append or overwrite at your descretion).

    Log into the switch.

    configshow (perhaps parameters are needed to show everything you need)



    Alternatively you can use BNA if you have it, or SAN health to assist if recontructing the zone db.



  • 7.  Re: configupload fails
    Best Answer

    Posted 12-04-2013 08:57 AM

    It finally turned out to be a firewall rule issue. Once that was corrected, I was able to do it flawlessly.


    I thank you for all your suggestions, though.


  • 8.  Re: configupload fails

    Posted 12-04-2013 07:38 AM

    There may be a firewall in between that prevents the switch from accessing that FTP. You could try a different one (on your PC for example), or it feasible you could try to connect directly to one of the switchs and see if it still fails...