Brocade Fibre Channel Networking Community

Expand all | Collapse all

I Can't get a 5300 to Connect to a 48000 via ISL. Please Help !

  • 1.  I Can't get a 5300 to Connect to a 48000 via ISL. Please Help !

    Posted 03-03-2014 08:34 AM
    I'm having difficulty connecting a Brocade Model 5300 switch ( with no active config) to a model 48000 Switch via an ISL with dark fiber and Ciena DWDM's on either end. Both switches are running V6.4.3 and the distance between the switches is roughly 8km. Both switches have extended fabric licenses Usually, the link won't come up the first time, but if I disable & e-enable the port a few times, un-plug and re-plug the cable a few times, I can get the link to come up and the 5300 will merge with the fabric. Once the ISL is up, it stays up, but if un-plug and re-plug the cable , it won't re-merge and I'm back to where I started (disable & e-enable the port a few times, un-plug and re-plug the cable a few times to get the link re-established. I suspect that my issue is the settings on the ISL ports
    . I'm using Brocade model 57-1000015-01 4GB LW 10KM SFPs.
    The 48K is a 4Gb switch and the 5300 is an 8GB switch, but the Ciena DWDMs only have 2GB cards, so I have the SFP's "hard set" to 2GB on each end.
    Is it even possible to get this scenario to work correctly, and if so, how should I configure the ISL ports ?
    Below are the ISL port configs from my last UN-successful attempt:

    Because the 5300 is an 8GB switch, so it wants to use a different fill word. Does this matter ? It wasn't happy when I tried to change it to Idle-Idle
    Anyway - I'm a novice at ISL configuration and have made 6 or 8 attempts to get this ISL configuration to work - all with the same results.
    Can someone help me with the correct settings for this to work ( assuming that it's possible).

    I'd REALLY appreciate it.

    48000 :

    admin> portcfgshow 9/31
    Area Number: 239
    Speed Level: 2G
    Fill Word: 0(Idle-Idle)
    AL_PA Offset 13: OFF
    Trunk Port OFF
    Long Distance LE
    VC Link Init ON
    Locked L_Port OFF
    Locked G_Port OFF
    Disabled E_Port OFF
    Locked E_Port OFF
    ISL R_RDY Mode OFF
    RSCN Suppressed OFF
    Persistent Disable OFF
    LOS TOV enable OFFv NPIV capability ON
    QOS E_Port OFF
    Port Auto Disable: OFF
    Mirror Port OFF
    F_Port Buffers OFF
    Fault Delay: 0(R_A_TOV)
    NPIV PP Limit: 126


    5300:


    admin> portcfgshow 19
    Area Number: 33
    Speed Level: 2G
    Fill Word: 1(Arbff-Arbff)
    AL_PA Offset 13: OFF
    Trunk Port ON
    Long Distance LE
    VC Link Init ON
    Locked L_Port OFF
    Locked G_Port OFF
    Disabled E_Port OFF
    Locked E_Port OFF
    ISL R_RDY Mode OFF
    RSCN Suppressed OFF
    Persistent Disable OFF
    LOS TOV enable OFF
    NPIV capability ON
    QOS E_Port OFF
    Port Auto Disable: OFF
    Rate Limit OFF
    EX Port OFF
    Mirror Port OFF
    Credit Recovery ON
    F_Port Buffers OFF
    Fault Delay: 0(R_A_TOV)
    NPIV PP Limit: 126
    CSCTL mode: OFF

    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: I Can't get a 5300 to Connect to a 48000 via ISL. Please Help !

    Posted 03-03-2014 11:31 AM

    Your fill words are different... One switch is set to 0 and the other is set to 1.

     

    I'd set them both to 0.


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: I Can't get a 5300 to Connect to a 48000 via ISL. Please Help !

    Posted 03-03-2014 11:33 AM

    Not a switch setting (to be clear). Fill Word is a port setting.

     


    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: I Can't get a 5300 to Connect to a 48000 via ISL. Please Help !

    Posted 03-04-2014 10:59 AM

    Hi,

     

    Richkell is right, fillword in both ends should be the same. But in this case, if working at 2G, the fillword settings configured at port level will not be taken into account.

     

    Many times, the restrictions are stablished by 4he dwdm array. In order to see what config is best for the isl stability try to lock the ports as E-port, disable vc link init and/or enable r_rdy mode.

     

    Rgds


    #BrocadeFibreChannelNetworkingCommunity