Brocade Fibre Channel Networking Community

Expand all | Collapse all

Unable to detect fiber devices on boot

  • 1.  Unable to detect fiber devices on boot

    Posted 01-31-2016 01:10 PM

    Hi, I've just bought a brocade 5000, and I am trying to test booting from a lun I set up on a freenas server.

     

    Everything seems to be ok when connecting two Qlogic qle2462 HBAs directly, I enabled the Host Adapter BIOS, Selected boot settings and set the Primary Boot Port Name / LUN from the Fibre Channel Device list. On bootup, the ROM BIOS shows as being installed, the iSCSI disk shows correctly, then boots as expected.

     

    However, when I plug both the HBA into the Brocade switch, in the QLogic Fast!UTIL I now get "No device present" showing in the "Select Fibre Channel Device" section.

     

    The brocade switch I assume is configured correctly, the lights are showing steady green and I did the following:

     

    • Added aliases for each of the ports
    • Added the aliases to a zone
    • Created a zone config
    • Added the zone to the zone config
    • Set the zone config as default

    One thing to note, if I enable the sata drive in the computer and boot into windows on it, windows can see the FreeNAS target through the brocade and connect to it successfully.

     

    Am I missing something in the configuration on the brocade why I can't detect fiber devices when connected through the brocade, yet can detect them when connected to them directly?

     


    #fibrechannel
    #BrocadeFibreChannelNetworkingCommunity
    #san
    #storagenetworking


  • 2.  Re: Unable to detect fiber devices on boot



  • 3.  Re: Unable to detect fiber devices on boot

    Posted 02-01-2016 01:45 AM

    Hi Antonio,

     

    Thanks, however that is what I did in the first place to be able to boot with a direct link from the pc to the freenas server, however, when I place the brocade switch inbetween them, it stops the freenas device from being detected.

     

    Any thoughts?


    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: Unable to detect fiber devices on boot

    Posted 02-01-2016 02:31 AM

    have you made all the settings listed in freenas forum ?

     

    --->>>Set the zone config as default

     

    is the config enable ?

     

    "cfgshow" command give output about active config.

     

    is the port connected ?

     

    what say "portshow" command ?

     

    check the SFP, or try another port.

     

    Is the FC cable OK ? what type of cable you use ? please take attention, some cable have the Plug-In TX-RX inverted.

     

     


    #BrocadeFibreChannelNetworkingCommunity


  • 5.  Re: Unable to detect fiber devices on boot

    Posted 02-01-2016 03:15 AM

    Hi Antonio,

     

    The cable is 50/125um OM3 LSZH Fiber, they're all configured as crossover (A-B, B-A) is that correct? or should they be A-A, B-B?

     

    The config is enabled with the following:

     


    Defined configuration:
    cfg: localzoneconfig
    local
    cfg: zc paul
    zone: local DellOptiplex; FreeNAS; MyPC
    alias: DellOptiplex
    1,2
    alias: FreeNAS 1,0
    alias: MyPC 1,1

    Effective configuration:
    cfg: localzoneconfig
    zone: local 1,2
    1,0
    1,1

     

     

    The portshow results for ports 0 through 2 are as follows:

     

    sw0:root> portshow 0
    portIndex: 0
    portName:
    portHealth: HEALTHY

    Authentication: None
    portDisableReason: None
    portCFlags: 0x1
    portFlags: 0x20b03 PRESENT ACTIVE F_PORT G_PORT U_PORT LOGICAL_ONLINE LOGIN NOELP ACCEPT FLOGI
    LocalSwcFlags: 0x0
    portType: 10.0
    POD Port: Port is licensed
    portState: 1 Online
    Protocol: FC
    portPhys: 6 In_Sync portScn: 32 F_Port
    port generation number: 0
    state transition count: 1

    portId: 010000
    portIfId: 43020001
    portWwn: 20:00:00:05:1e:90:78:b0
    portWwn of device(s) connected:
    21:01:00:e0:8b:b2:81:d1
    Distance: normal
    portSpeed: N4Gbps

    LE domain: 0
    FC Fastwrite: OFF
    Interrupts: 18 Link_failure: 0 Frjt: 0
    Unknown: 0 Loss_of_sync: 2 Fbsy: 0
    Lli: 12 Loss_of_sig: 4
    Proc_rqrd: 28 Protocol_err: 0
    Timed_out: 0 Invalid_word: 0
    Rx_flushed: 0 Invalid_crc: 0
    Tx_unavail: 0 Delim_err: 0
    Free_buffer: 0 Address_err: 0
    Overrun: 0 Lr_in: 2
    Suspended: 0 Lr_out: 0
    Parity_err: 0 Ols_in: 0
    2_parity_err: 0 Ols_out: 2
    CMI_bus_err: 0

    Port part of other ADs: No


    sw0:root> portshow 1
    portIndex: 1
    portName:
    portHealth: HEALTHY

    Authentication: None
    portDisableReason: None
    portCFlags: 0x1
    portFlags: 0x20b03 PRESENT ACTIVE F_PORT G_PORT U_PORT LOGICAL_ONLINE LOGIN NOELP ACCEPT FLOGI
    LocalSwcFlags: 0x0
    portType: 10.0
    POD Port: Port is licensed
    portState: 1 Online
    Protocol: FC
    portPhys: 6 In_Sync portScn: 32 F_Port
    port generation number: 0
    state transition count: 1

    portId: 010100
    portIfId: 43020002
    portWwn: 20:01:00:05:1e:90:78:b0
    portWwn of device(s) connected:
    50:01:43:80:06:35:db:76
    Distance: normal
    portSpeed: N4Gbps

    LE domain: 0
    FC Fastwrite: OFF
    Interrupts: 18 Link_failure: 0 Frjt: 0
    Unknown: 0 Loss_of_sync: 2 Fbsy: 0
    Lli: 12 Loss_of_sig: 4
    Proc_rqrd: 46 Protocol_err: 0
    Timed_out: 0 Invalid_word: 0
    Rx_flushed: 0 Invalid_crc: 0
    Tx_unavail: 0 Delim_err: 0
    Free_buffer: 0 Address_err: 0
    Overrun: 0 Lr_in: 2
    Suspended: 0 Lr_out: 0
    Parity_err: 0 Ols_in: 0
    2_parity_err: 0 Ols_out: 2
    CMI_bus_err: 0

    Port part of other ADs: No


    sw0:root> portshow 2
    portIndex: 2
    portName:
    portHealth: HEALTHY

    Authentication: None
    portDisableReason: None
    portCFlags: 0x1
    portFlags: 0x24b03 PRESENT ACTIVE F_PORT G_PORT U_PORT LOGICAL_ONLINE LOGIN NOELP LED ACCEPT FLOGI
    LocalSwcFlags: 0x0
    portType: 10.0
    POD Port: Port is licensed
    portState: 1 Online
    Protocol: FC
    portPhys: 6 In_Sync portScn: 32 F_Port
    port generation number: 8
    state transition count: 5

    portId: 010200
    portIfId: 43020005
    portWwn: 20:02:00:05:1e:90:78:b0
    portWwn of device(s) connected:
    50:01:43:80:06:30:cc:c0
    Distance: normal
    portSpeed: N4Gbps

    LE domain: 0
    FC Fastwrite: OFF
    Interrupts: 36 Link_failure: 0 Frjt: 0
    Unknown: 0 Loss_of_sync: 4 Fbsy: 0
    Lli: 24 Loss_of_sig: 6
    Proc_rqrd: 61 Protocol_err: 0
    Timed_out: 0 Invalid_word: 61199
    Rx_flushed: 0 Invalid_crc: 0
    Tx_unavail: 0 Delim_err: 0
    Free_buffer: 0 Address_err: 0
    Overrun: 0 Lr_in: 4
    Suspended: 0 Lr_out: 0
    Parity_err: 0 Ols_in: 0
    2_parity_err: 0 Ols_out: 4
    CMI_bus_err: 0

    Port part of other ADs: No

     

     

     

     


    #BrocadeFibreChannelNetworkingCommunity


  • 6.  Re: Unable to detect fiber devices on boot

    Posted 02-01-2016 07:00 AM

    the cable show OK.

     

    I think you have to made other setting in order to get the connectivity to FreeNas ( im not familiarly with )

     

    I.E. the Fillword, with "portcfgfillword" command, you set another value, for details refer CLI Manuals.

     

    from the "cfgshow" output, I don't see if the config is set to enable, additional:

     

    --->>cfg: zc paul

     

    I assume this is the config name ?

     

    you should rename the configname like "zc_paul" without blank space characters.

     

     


    #BrocadeFibreChannelNetworkingCommunity


  • 7.  Re: Unable to detect fiber devices on boot

    Posted 02-01-2016 08:01 AM

    Hi,

     

    I've gone through the configuration and reset it with the following results for clarity on cfgshow :

     

    Defined configuration:

    cfg: localzoneconfig
    localzone
    zone: localzone
    DellOptiplex; FreeNAS; MyPC
    alias: DellOptiplex
    1,2
    alias: FreeNAS 1,0
    alias: MyPC 1,1

    Effective configuration:
    cfg: localzoneconfig
    zone: localzone
    1,2
    1,0
    1,1

     

    I've tried using portcfgfillword with options 0, 1, 2 and 3 all resulting in the following message:

     

    sw0:root> portcfgfillword 0 0
    Not supported.

     

    It still has the result of 'no device present' when choosing a fiber channel device.  I had assumed it's not a freenas issue because if I connect the server to the computer with fiber it works perfectly and shows the device, it's just when i plug them both into the brocade it doesn't. 

     

    I've also tried plugging the cables into different SFPs on the brocade, I still cant find any devices.

     

     


    #BrocadeFibreChannelNetworkingCommunity


  • 8.  Re: Unable to detect fiber devices on boot

    Posted 02-01-2016 08:04 AM

    what is the FOS level on the switch ?

     

    from command line

     

    "firmwareshow"

     

     


    #BrocadeFibreChannelNetworkingCommunity


  • 9.  Re: Unable to detect fiber devices on boot

    Posted 02-01-2016 08:33 AM


  • 10.  Re: Unable to detect fiber devices on boot

    Posted 02-01-2016 10:58 PM

    I see you have a Brocade 5000, fillword is not supported here, i was the opinion you have 8GB Switch.

     

    from CLI, "switchshow" command, did you see any WWN connected ?


    #BrocadeFibreChannelNetworkingCommunity


  • 11.  Re: Unable to detect fiber devices on boot

    Posted 02-02-2016 07:06 AM

    They all seem to be showing

     

    sw0:root> switchshow
    switchName: sw0
    switchType: 58.2
    switchState: Online
    switchMode: Native
    switchRole: Principal
    switchDomain: 1
    switchId: fffc01
    switchWwn: 10:00:00:05:1e:90:78:b0
    zoning: ON (localzoneconfig)
    switchBeacon: OFF
    FC Router: OFF
    FC Router BB Fabric ID: 1
    Address Mode: 0

    Index Port Address Media Speed State Proto
    ==============================================
    0 0 010000 id N4 Online FC F-Port 21:01:00:e0:8b:b2:81:d1
    1 1 010100 id N4 Online FC F-Port 50:01:43:80:06:35:db:76
    2 2 010200 id N4 Online FC F-Port 50:06:0b:00:00:66:2e:32
    3 3 010300 id N4 No_Light FC
    4 4 010400 id N4 No_Light FC
    5 5 010500 id N4 No_Light FC
    6 6 010600 id N4 No_Light FC
    7 7 010700 id N4 No_Light FC
    8 8 010800 id N4 No_Light FC
    9 9 010900 id N4 No_Light FC
    10 10 010a00 id N4 No_Light FC
    11 11 010b00 id N4 No_Light FC
    12 12 010c00 id N4 No_Light FC
    13 13 010d00 id N4 No_Light FC
    14 14 010e00 id N4 No_Light FC
    15 15 010f00 id N4 No_Light FC
    16 16 011000 -- N4 No_Module FC (No POD License) Disabled
    17 17 011100 -- N4 No_Module FC (No POD License) Disabled
    18 18 011200 -- N4 No_Module FC (No POD License) Disabled
    19 19 011300 -- N4 No_Module FC (No POD License) Disabled
    20 20 011400 -- N4 No_Module FC (No POD License) Disabled
    21 21 011500 -- N4 No_Module FC (No POD License) Disabled
    22 22 011600 -- N4 No_Module FC (No POD License) Disabled
    23 23 011700 -- N4 No_Module FC (No POD License) Disabled
    24 24 011800 -- N4 No_Module FC (No POD License) Disabled
    25 25 011900 -- N4 No_Module FC (No POD License) Disabled
    26 26 011a00 -- N4 No_Module FC (No POD License) Disabled
    27 27 011b00 -- N4 No_Module FC (No POD License) Disabled
    28 28 011c00 -- N4 No_Module FC (No POD License) Disabled
    29 29 011d00 -- N4 No_Module FC (No POD License) Disabled
    30 30 011e00 -- N4 No_Module FC (No POD License) Disabled
    31 31 011f00 -- N4 No_Module FC (No POD License) Disabled


    #BrocadeFibreChannelNetworkingCommunity


  • 12.  Re: Unable to detect fiber devices on boot

    Posted 02-02-2016 07:23 AM

    well, the switch see all the HBA.

     

    I think the issue is related on HBA, you should review the HBA settings in freenas.


    #BrocadeFibreChannelNetworkingCommunity