Brocade Fibre Channel Networking Community

Expand all | Collapse all

Device In_Sync

Jump to Best Answer
  • 1.  Device In_Sync

    Posted 01-24-2019 05:48 AM

    Hey everyone. I have experience with networking but sort of new to fiber channel. We have Brocade 300 (type 71.2) switches . The storage devices we connect to it looks to be using L-Port (which I understand is arbitrated loop). This works great on the Brocade 300. We are looking at switch replacements since this switch is EOL. We are testing the G610 and from this doc (fos-820a-adminguide.pdf) it seems the switch does not support L-Port. 


    When I connect our device to the G610 the port lights are on but the device just sits at port status 'In_Sync' and never goes to 'Online' which is the state it was on the 300 switch (but also showed L-Port). From what I've read is that the state of in_sync means the fiber connection is good but the device isn't logged into the fabric on the switch. If that's the problem, does anyone have an idea on how to do that? 


    What I've done is created a zone with the WWN of the device but still a no go. Anyone with some ideas would be helpful.


  • 2.  Re: Device In_Sync

    Posted 01-24-2019 06:05 AM

    What do you mean by "When I connect our device to the G610 " ?  Do you mean the same device that was connected as L-port on the Brocade 300?   If yes,  what you experience (port In-sync but not online) is correct.  In-sync means the device is connected to the switch port at a certain speed with good signal synchronization.   Devices performing Loop port connections will be accessible on the G610, as the switch does support the arbitrated loop protocol. 


  • 3.  Re: Device In_Sync

    Posted 01-24-2019 06:28 AM

    Hey thanks for the quick reply!


    Yes I'm connecting the same exact device, moving it from the 300 to the G610 (power cycling and everything).


    I don't believe the G610 support L-port. According to the doc fos-820a-adminguide.pdf (page 33):


    FL_Ports are not supported on the BrocadeFC32-64, FC32-48, FC16-32, FC16-48, FC16-64, SX6, Brocade 6505,
    Brocade 6510, Brocade 6520, Brocade G610, Brocade G620, Brocade G630, or Brocade 7840 platforms.


    Also to confirm this I performed the same test on both the 300 and G610 switch. To isolate the test I performed a factory reset on both and disconnected all devices.


    Logged into the 300 GUI, edit'd port 0, set to locked L-port, configuration successfully saved.

    Tried from CLI (portcfglport 0 1) resulted in success


    Logged into the G610 GUI, edit'd port 0, set to locked L-port, configuration failed.

    Tried from CLI (portcfglport 0 1) resulted in: Port 0 is not capable of this setting


    So this leads me to believe that the brocade doc is correct, the G610 does not support arbitrated loop.


    So back to the 'In_Sync', what would cause the device not to go 'Online'? Is that some type of switch authentication (I'm comparing it to port security). It seems like the connection is good but something is preventing it from going Online. Sorry I'm nieve in this area.



  • 4.  Re: Device In_Sync

    Posted 01-24-2019 06:31 AM



    FL_ports/arrbitrated loop is not supported on fos 8 with 16Gb/32Gb devices


    Which storage are you connecting to the switch ? Are you really need L port ?





  • 5.  Re: Device In_Sync

    Posted 01-24-2019 07:14 AM

    Hey Marian,


    The device is a custom storage device we developed. The just of it is it has a host/client architecture (I'd guess that's HBA/Storage devices in SAN speak). They communicate over fiber channel. On the 300 switch this was identified as L-Port connection for both devices but obviously that's not possible now. I'm trying to figure out the technical details of the port state and to use F-Port. 


  • 6.  Re: Device In_Sync

    Posted 01-24-2019 07:19 AM



    if you would like skip L-port initialization lock port as G port. From G port only E-Port or F-Port will be available.



    Of course your device needs to support F-Port.


    If it will stuck again, please share output of command




  • 7.  Re: Device In_Sync
    Best Answer

    Posted 01-24-2019 08:46 AM

    The symptoms you describe indicate your "custom" device's fibre channel adapter is either

     a) only capable of doing arbitrated loop  (to imply its a very very old adapter)

     b) configured hard-set to arbitrated loop.  


    I recall older Qlogic and Emulex adapters can be hard set to: auto negotiate, loop or point-to-point.


    I would check your device's fc adapter configuration settings, if possible.   Assuming Qlogic or Emulex, there are

    add-on applications (command line and gui) that can read the fc adapter config.   Or possible you can break into

    the fc adapter settings during device boot-up.


    Lastly, the reason you see "In-sync" but not "Online" is because the physical layer link negotiation between the adapter and G610

    is successful. However, the upper fibre channel layer for establishing fabric login to the G610 is failing because the G610 will not accept FLOGI using arbitrated loop.   Loop login is much different protocol vs. point-to-point login.



  • 8.  Re: Device In_Sync

    Posted 01-24-2019 09:01 AM

    i saw devices which was logged as L-port but it dont have any devices in loop (for exaplme fc tape drives) in mostly cases if the device is auto negotiate G-Port lock sloved problem to force port as F-port.


  • 9.  Re: Device In_Sync

    Posted 01-25-2019 05:29 AM

    I want to thank @Douglas Tocci and Marian.


    The issue for us was that the fc adapter was indeed hard coded to arbitrated loop mode. We switched it to point-2-point and the device came up Online as expected.


    Again thanks for the tehcnical info.