Brocade Fibre Channel Networking Community

Expand all | Collapse all

Brocade Silkworm 2400 connection to JBOD

  • 1.  Brocade Silkworm 2400 connection to JBOD

    Posted 04-08-2013 05:10 AM

    Hi

    I am new to brocade, any idea how to configure brocade 2400 silkworm in FabricLoop mode. i.e. I have Netapp 2Gig Disk shelf with 6 disks. Brocade port0 is connected to Server HBA and it comes as F port but i cannot bring up Jbod link. Any idea which command is need to bring up the FL link.

    Thanks

    Muhammad


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-08-2013 08:06 AM

    WOW, 10 Years nostalgic.

    Honestly, as fair as i remember - is long time ago -  LOOP was in FOS 2.6 - a Additional License.

    Secong 2400 is 1Gb switch, if the JBOD work with fixed 2Gb, and cannot auto-negotiated to 1Gb you cannot connect to.


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-08-2013 08:14 AM

    Right,

    It is bit old but good enough to do interop mode with Cisco MDS 9222i. You are right, I have switched JBOD to 1Gig speed, so are my HBA. HBA works fine but have issue with Loop.

    Here is output from Brocade:

    BROCADE:admin> fabricshow

    Switch ID   Worldwide Name           Enet IP Addr    FC IP Addr      Name

    -------------------------------------------------------------------------

      1: fffc01 10:00:00:60:69:20:1f:59  172.16.3.221    0.0.0.0        >"BROCADE"

      2: fffc02 20:32:00:0d:ec:0f:d5:01  172.16.3.151    0.0.0.0         "MDS1"

    The Fabric has 2 switches


    Any thoughts??



    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-08-2013 08:21 AM

    post the licenseshow from brocade please


    #BrocadeFibreChannelNetworkingCommunity


  • 5.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-08-2013 08:34 AM

    Here is license report:

    BROCADE:admin> licenseshow

    cSbeddzSdddTcfeH:

        Fabric license

    cbSeRedbQdcTfSr:

        Web license

        Zoning license

        SES license

    Rdybecy9cSSezcfQ:

        QuickLoop license

    bQz99zebQzfR0MBY:

        Web license

        Zoning license

        SES license

        QuickLoop license

        Fabric license

        Remote Switch license

        Remote Fabric license

        Extended Fabric license

        Entry Fabric license

        Fabric Watch license

        Release v2.2 license

    BROCADE:admin>


    #BrocadeFibreChannelNetworkingCommunity


  • 6.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-08-2013 08:41 AM

    from license output show ok, check in command reference 2.6 if you find one, is probable you have to made some settings in  the switch.

    I don't at the moment thin on the hand, i believe in command "configure" you should be able to set LOOP Features.


    #BrocadeFibreChannelNetworkingCommunity


  • 7.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-08-2013 09:21 AM

    Here is the output from Port where JBOD is connected:

    BROCADE:admin> portshow 2

    portFlags: 0xc0020041    PRESENT U_PORT LED CFG_L_PORT DISABLE_EPORT

    portType:  3.1

    portState: 2    Offline 

    portPhys:  6    In_Sync 

    portScn:   0            

    portRegs:  0x80010000

    portData:  0x102f8290

    portId:    011200

    portWwn:   20:02:00:60:69:20:1f:59

    portWwn of the device(s) connected:

            None

    Distance:  normal

    Speed:     1Gbps  

    Interrupts:   72         Link_failure: 0          Frjt:         0         

    Unknown:      76         Loss_of_sync: 2          Fbsy:         0         

    Lli:          34         Loss_of_sig:  2         

    Proc_rqrd:    0          Protocol_err: 0         

    Timed_out:    0          Invalid_word: 0         

    Rx_flushed:   0          Invalid_crc:  0         

    Tx_unavail:   0          Delim_err:    0         

    Free_buffer:  0          Address_err:  0         

    Overrun:      0          Lr_in:        0         

    Suspended:    0          Lr_out:       0         

    Parity_err:   0          Ols_in:       0         

                             Ols_out:      0         

    BROCADE:admin>

    I see solid orange light on the port.


    #BrocadeFibreChannelNetworkingCommunity


  • 8.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-08-2013 10:06 AM

    command "portcfglport port_number 1" must be set to enable L_Port


    #BrocadeFibreChannelNetworkingCommunity


  • 9.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-08-2013 11:30 AM

    I tired this command,

    ROCADE:admin> portcfglport

    Ports:   0   1   2   3   4   5   6   7 

            --------------------------------

    Lock     -   -   YES -   -   -   -   -  

    Private  -   YES YES -   -   -   -   -  

    BROCADE:admin>

    As you can see it is setup for lport but still i dont see the drives.


    #BrocadeFibreChannelNetworkingCommunity


  • 10.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-08-2013 12:01 PM

    try again with follow step.

    disconnect the cable from that port you want to configure

    command "portdisable Port_number"

    command "portcfglport Port_number 1" Note 1 is the operand to set L_Port enable

    enable the port back with command "portenable Port_number"

    plug the cable and wait for a couple of second.

    verify with command "nsshow" you should see all attached device.


    #BrocadeFibreChannelNetworkingCommunity


  • 11.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-09-2013 09:37 AM

    Hi

    I tried the above commands, but still no luck

    BROCADE:admin> portshow 2

    portFlags: 0xc0020041    PRESENT U_PORT LED CFG_L_PORT DISABLE_EPORT

    portType:  3.1

    portState: 2    Offline 

    portPhys:  6    In_Sync 

    portScn:   0            

    portRegs:  0x80010000

    portData:  0x102f8290

    portId:    011200

    portWwn:   20:02:00:60:69:20:1f:59

    portWwn of the device(s) connected:

            None

    Distance:  normal

    Speed:     1Gbps  

    Interrupts:   3856       Link_failure: 0          Frjt:         0         

    Unknown:      2157       Loss_of_sync: 38         Fbsy:         0         

    Lli:          3001       Loss_of_sig:  7         

    Proc_rqrd:    3          Protocol_err: 0         

    Timed_out:    0          Invalid_word: 156       

    Rx_flushed:   0          Invalid_crc:  14        

    Tx_unavail:   0          Delim_err:    0         

    Free_buffer:  0          Address_err:  3         

    Overrun:      0          Lr_in:        0         

    Suspended:    0          Lr_out:       0         

    Parity_err:   0          Ols_in:       0         

                             Ols_out:      1673      

    BROCADE:admin>

    Also,

    BROCADE:admin> nsshow

    {

    Type Pid    COS     PortName                NodeName                 TTL(sec)

    N    011000;      3;21:02:00:e0:8b:4e:bc:b3;20:02:00:e0:8b:4e:bc:b3; na

        FC4s: FCP

        NodeSymb: "QLA2344 FW:v3.03.25 DVR:v9.1.7.18"

        Fabric Port Name: 20:00:00:60:69:20:1f:59

    The Local Name Server has 1 entry }

    BROCADE:admin>

    Any other idea??


    #BrocadeFibreChannelNetworkingCommunity


  • 12.  Re: Brocade Silkworm 2400 connection to JBOD

    Posted 04-10-2013 04:19 AM

    Hi,

    Command portcfglport has the following parameters:

    Usage: portCfgLport PortNumber  <0 | 1>

    You could try to configure all the different possibilities to see if any of them makes the device to get online. Try, on port 2, to configure a Public Loop instead of  a private one, for example.

    BROCADE:admin>portcfglport 2 1 1 <-- private Loop

    BROCADE:admin>portcfglport 2 1 0 <-- public Loop

    rgds


    #BrocadeFibreChannelNetworkingCommunity