Brocade Fibre Channel Networking Community

Expand all | Collapse all

Virtual Fabric Disable Problem...

  • 1.  Virtual Fabric Disable Problem...

    Posted 05-05-2015 05:43 PM

    Hello All,

     

    I have a DCX I'm trying to disable Virtual Fabric feature on but it appears to tell me I have not delted the default switch yet.

     


    XXX_Lab_DCX-4s:FID128:admin> fosconfig --show
    FC Routing service: disabled
    iSCSI service: Service not supported on this Platform
    iSNS client service: Service not supported on this Platform
    Virtual Fabric: enabled
    Ethernet Switch Service: disabled
    XXX_Lab_DCX-4s:FID128:admin> fosconfig --disable vf
    WARNING: This is a disruptive operation that requires a reboot to take effect.
    Would you like to continue [Y/N]: y
    Please delete all but the default switch before disabling Virtual Fabric.
    XXX_lab_DCX-4s:FID128:admin>

     

    When I look at the followin g I have moved all port to the FID 128 which is the default switch id, so there is nothing left to be changed or moved. Is ther something further I need to do in order to remove the feature and delete the default switch?

     

    I tried to run this command te delete (128) which I assume is the default switch - lscfg --delete 128 -force

     

    But then I get this error message:

     

    TRC_Lab_DCX-4s:FID128:admin> lscfg --delete 128 -force
    lscfg: Unable to delete the default switch.
    FID: 128

     

    Created switches: 128(ds) 2
    Slot 1 2 3 4 5 6 7 8
    -------------------------------------------------------
    Port
    0 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    1 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    2 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    3 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    4 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    5 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    6 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    7 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    8 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    9 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    10 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    11 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    12 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    13 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    14 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    15 | 128 | 128 | 128 | | | 128 | 128 | 128 |
    16 | 128 | | | | | | 128 | 128 |
    17 | 128 | | | | | | 128 | 128 |
    18 | 128 | | | | | | 128 | 128 |
    19 | 128 | | | | | | 128 | 128 |
    20 | 128 | | | | | | 128 | 128 |
    21 | 128 | | | | | | 128 | 128 |
    22 | 128 | | | | | | 128 | 128 |
    23 | 128 | | | | | | 128 | 128 |
    24 | 128 | | | | | | 128 | 128 |
    25 | 128 | | | | | | 128 | 128 |
    26 | 128 | | | | | | 128 | 128 |
    27 | 128 | | | | | | 128 | 128 |
    28 | 128 | | | | | | 128 | 128 |
    29 | 128 | | | | | | 128 | 128 |
    30 | 128 | | | | | | 128 | 128 |
    31 | 128 | | | | | | 128 | 128 |
    32 | 128 | | | | | | | |
    33 | 128 | | | | | | | |
    34 | 128 | | | | | | | |
    35 | 128 | | | | | | | |
    36 | 128 | | | | | | | |
    37 | 128 | | | | | | | |
    38 | 128 | | | | | | | |
    39 | 128 | | | | | | | |
    40 | 128 | | | | | | | |
    41 | 128 | | | | | | | |
    42 | 128 | | | | | | | |
    43 | 128 | | | | | | | |
    44 | 128 | | | | | | | |
    45 | 128 | | | | | | | |
    46 | 128 | | | | | | | |
    47 | 128 | | | | | | | |
    48 | | | | | | | | |
    49 | | | | | | | | |
    50 | | | | | | | | |
    51 | | | | | | | | |
    52 | | | | | | | | |
    53 | | | | | | | | |
    54 | | | | | | | | |
    55 | | | | | | | | |
    56 | | | | | | | | |
    57 | | | | | | | | |
    58 | | | | | | | | |
    59 | | | | | | | | |
    60 | | | | | | | | |
    61 | | | | | | | | |
    62 | | | | | | | | |
    63 | | | | | | | | |


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: Virtual Fabric Disable Problem...

    Posted 05-07-2015 01:17 AM

    Hi,

     

    you can not delete the default switch.

    If you want to disable virtual fabric you have to disable the feature.

     

    You have to perform:

     

    fosconfig --disable vf

     

    Be careful: Switch will reboot.


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: Virtual Fabric Disable Problem...

    Posted 05-07-2015 02:10 PM

    Ralf,

     

    I did try and disable the feature as you can seee from my post. It still ask me to delete the default switch.

     

    XXX_Lab_DCX-4s:FID128:admin> fosconfig --disable vf
    WARNING: This is a disruptive operation that requires a reboot to take effect.
    Would you like to continue [Y/N]: y
    Please delete all but the default switch before disabling Virtual Fabric.


    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: Virtual Fabric Disable Problem...

    Posted 05-07-2015 03:05 PM

    Erm... "Please delete all but the default switch before disabling Virtual Fabric." means "delete ALL switches MINUS the default switch"...


    #BrocadeFibreChannelNetworkingCommunity


  • 5.  Re: Virtual Fabric Disable Problem...

    Posted 05-07-2015 05:33 PM

    There is nothing but the defailt switch (FID128) left. I only tried delteing that just in case, obviously it failed. 

     

    Still, the feature won't allow me to disable.


    #BrocadeFibreChannelNetworkingCommunity


  • 6.  Re: Virtual Fabric Disable Problem...

    Posted 05-07-2015 11:57 PM

    Did you delete the base switch, too? If yes and it still doesn't work, better open a case with support.


    #BrocadeFibreChannelNetworkingCommunity


  • 7.  Re: Virtual Fabric Disable Problem...

    Posted 05-08-2015 01:51 AM

    Hmm... checked your output again... no bs in lscfg --show...


    #BrocadeFibreChannelNetworkingCommunity


  • 8.  Re: Virtual Fabric Disable Problem...

    Posted 05-08-2015 01:53 AM

    But if your lscfg --show still looks like above, you should delete the logical switch 2.


    #BrocadeFibreChannelNetworkingCommunity


  • 9.  Re: Virtual Fabric Disable Problem...

    Posted 05-08-2015 04:07 PM

    There is no other logical switch to remove. If you notice it's just the base switch.

     

    TRC_Lab_DCX-4s:FID128:admin> switchshow
    switchName: XXX_Lab_DCX-4s
    switchType: 77.3
    switchState: Online
    switchMode: Native
    switchRole: Principal
    switchDomain: 1
    switchId: fffc01
    switchWwn: XXXXXX
    zoning: OFF
    switchBeacon: OFF
    FC Router: OFF
    Allow XISL Use: OFF
    LS Attributes: [FID: 128, Base Switch: No, Default Switch: Yes, Address Mode 0] -------- >

     

    I honestly think it has to do with the ports configurations on the switch that are still configured, particularly the VE ports I have, even though they are offline.

     

    204 8 12 01cc00 -- -- Offline VE
    205 8 13 01cd00 -- -- Offline VE
    206 8 14 01ce00 -- -- Offline VE
    207 8 15 01cf00 -- -- Offline VE
    208 8 16 01d000 -- -- Offline VE
    209 8 17 01d100 -- -- Offline VE
    210 8 18 01d200 -- -- Offline VE
    211 8 19 01d300 -- -- Offline VE
    212 8 20 01d400 -- -- Offline VE
    213 8 21 01d500 -- -- Offline VE
    214 8 22 01d600 -- -- Offline VE
    215 8 23 01d700 -- -- Offline VE
    216 8 24 01d800 -- -- Offline VE
    217 8 25 01d900 -- -- Offline VE
    218 8 26 01da00 -- -- Offline VE
    219 8 27 01db00 -- -- Offline VE
    220 8 28 01dc00 -- -- Offline VE
    221 8 29 01dd00 -- -- Offline VE
    222 8 30 01de00 -- -- Offline VE
    223 8 31 01df00 -- -- Offline VE

     

     


    #BrocadeFibreChannelNetworkingCommunity


  • 10.  Re: Virtual Fabric Disable Problem...

    Posted 05-09-2015 05:54 AM

    Your output says "Created switches: 128(ds) 2" - you don't think it could have something to do with the logical switch 2 being listed directly right after 128, the default switch?


    #BrocadeFibreChannelNetworkingCommunity


  • 11.  Re: Virtual Fabric Disable Problem...

    Posted 05-09-2015 07:37 AM

    Eric,

     

    it show to me, as you have already configured port in the Virtual Fabric.

     

    The problem is, before you can delete the VF, you must FIRST remove/move all the Port from those VF to the Default Logical Switch, otherwise you cannot delete the configured VF.


    #BrocadeFibreChannelNetworkingCommunity


  • 12.  Re: Virtual Fabric Disable Problem...

    Posted 05-10-2015 06:10 PM

    Seb is right. There is still a LS 2 in the switch which should be deleted first. Unless you've hit some sort of bug you should be able to do a "setcontext 2" and if that succeeds you know you still have a logical switch with FID 2 even if that one doesn;t have any ports assigned to it.

     

    Go back to LS 128 (setcontext 128)

    Remove LS 2 (lscfg --delete 2)

    Disable VF (fosconfig --disable vf).

     

    I've never been able to find a good justification to disable the VF logic in a switch so you may want to enlighten me a bit here. Why do you want to disable this??

     

     


    #BrocadeFibreChannelNetworkingCommunity


  • 13.  Re: Virtual Fabric Disable Problem...

    Posted 05-10-2015 11:18 PM

    From FOS Command Reference Manuals, if Port are configured in the VF

     

    operands --delete

     

    Deletes a logical switch with the specified fabric ID. The specified logical switch
    must exist and no ports should be configured on this partition. You must remove
    all ports from the logical switch before deleting the logical switch instance. Use the
    lscfg --config command to remove the ports.


    #BrocadeFibreChannelNetworkingCommunity


  • 14.  Re: Virtual Fabric Disable Problem...

    Posted 05-11-2015 10:20 AM

    Thanks Erwin, you suggestion worked, appreciate your help. 

     

    Antonio, yuo mentioned if I had removed all ports from the logical switch and the answer to that is "yes". 

     

    But Erwin's steps solved my problem.

     

     


    #BrocadeFibreChannelNetworkingCommunity