Brocade Fibre Channel Networking Community

Expand all | Collapse all

Cascading HP 8/32 to Brocade 6510 switches

  • 1.  Cascading HP 8/32 to Brocade 6510 switches

    Posted 04-24-2017 11:03 PM

    Hi

    The customer currently have:

    2 x 8 Gbps 32 ports switches with FOS v6.4.1 and
    2 x 8 Gbps 32 ports switches with FOS v5.3.1.

    They have purchased new 16 Gbps 6510 switches and I need to cascade them together. Is there a need to upgrade their FOS to the same version just so that the servers connected to their old switches and access the 3PAR array that is connected to the new switch? How many stages of upgrade do I need to go through if I want to put all of them to 7.4.X?

    Thanks in advance.


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: Cascading HP 8/32 to Brocade 6510 switches

    Posted 04-25-2017 01:13 AM

    Hi,

     

    the new 6510 requires FOS from 7.0, and current target path (TP) is at 7.4 - was updated in April

     

    https://www.brocade.com/content/dam/common/documents/content-types/target-path-selection-guide/brocade-fos-target-path.pdf

     

    You cannot mix the FOS 5.3 switch with FOS 7.4, so these need to be upgraded to at least 6.x, I would put them on the same version as the other FOS 6.4 switches, at least. Or all switch on TP, 7.4.1e

     

    FOS 5.3 -> FOS 6.0.1a -> FOS 6.1.2c -> FOS 6.2.2g -> FOS 6.3.2e -> FOS 6.4.1h -> FOS 7.0.2e -> FOS 7.1.1c  -> FOS 7.2.1g -> FOS 7.3.1e  -> FOS 7.4.1e

     

    If you can take disruptive upgrades, then you can take two steps - for example skipping 7.2 and 6.3

     

    Note

    • Upgrading to Fabric OS v6.2.2 is only allowed from Fabric OS v6.1.0 or later

    • 7.3.1e release notes say: Disruptive upgrade to FOS v7.3.1e from FOS v7.1 is supported.

    • Notice that for FOS 7.4.1e - Migrating from FOS v7.2 (7.4.1e RN)
      • Any 8G or 16G platform operating at FOS v7.2.x must be upgraded to FOS v7.3.x before upgrading to FOS v7.4.1e.
      • Disruptive upgrade to FOS v7.4.1e from FOS v7.2 is not supported

     


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: Cascading HP 8/32 to Brocade 6510 switches

    Posted 04-25-2017 01:30 AM
    Hi there,
    Please could you let me know the switch models in question.

    FOS v5.x Is not supported so there is no ineroprability between 5.x and 7.4x - any working connection would be unsupported.

    FOS 6.1e is the oldest FOS version that is included in the releases notes for v7.4.

    The upgrade options would depend on the switches being used.

    kind regards
    Rick
    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: Cascading HP 8/32 to Brocade 6510 switches

    Posted 04-25-2017 09:11 PM

    Thanks Martin and Rick for responding.

     

    I've confirmed that the customer's old switches are Brocade SilkWorm 4100. All 4 of them. In HP terms, it should be 4/32 instead of 8/32 I have incorrectly written in the subject heading.


    #BrocadeFibreChannelNetworkingCommunity


  • 5.  Re: Cascading HP 8/32 to Brocade 6510 switches

    Posted 04-25-2017 11:12 PM

    I stand corrected. The 2 switches that are having FOS v v5.3.1 are Brocade SilkWorm 5000. Those two that have FOS v6.4.1 are Brocade SilkWorm 4100. 


    @yew-hoong.chia wrote:

    Thanks Martin and Rick for responding.

     

    I've confirmed that the customer's old switches are Brocade SilkWorm 4100. All 4 of them. In HP terms, it should be 4/32 instead of 8/32 I have incorrectly written in the subject heading.


     


    #BrocadeFibreChannelNetworkingCommunity


  • 6.  Re: Cascading HP 8/32 to Brocade 6510 switches

    Posted 04-26-2017 02:23 AM

    Hi,

    thanks for the info,
    As the switches are 4100, the highest FOS version they can run is FOS v6.4.3h.  So I believe this should be your target for the 4100s and this will connect with your 6510 running 7.4x.

     

    kind regards

    Rick Stephens


    #BrocadeFibreChannelNetworkingCommunity


  • 7.  Re: Cascading HP 8/32 to Brocade 6510 switches

    Posted 04-26-2017 06:24 PM

    Hi Rick

     

    Does that meant that for both of the following:

     

    FOS v5.3.1 in Brocade SilkWorm 5000.

    FOS v6.4.1 in Brocade SilkWorm 4100

     

    I just need to upgrade both to FOS v6.4.3h(as it is the highest FOS version these 4Gb/s switches can run) and I will have a supported ISL connection to the 6510 running 7.4.x?

     

    Thanks.


    #BrocadeFibreChannelNetworkingCommunity


  • 8.  Re: Cascading HP 8/32 to Brocade 6510 switches

    Posted 04-26-2017 11:53 PM

    Hello,

     

    yes, that's correct. You need to upgrade both devices to FOS 6.4.3h to build an ISL between them and your 6510.

     

    AG


    #BrocadeFibreChannelNetworkingCommunity