Brocade Fibre Channel Networking Community

Expand all | Collapse all

Device Name not showing on SAN switch.

Jump to Best Answer
  • 1.  Device Name not showing on SAN switch.

    Posted 07-15-2015 08:54 AM

    Hi,

     

    I am new to using Brocade SAN switches so I'm not sure how to troubleshoot an issue that we have.

     

    We have a new HP C7000 with BL460 blades which are all on the very latest HP firmware including the VC's and OA's. We are also using the HP ESXi 5.5 image with the latest reccomended driver for the FC connectivity. Our Brocade SLKWRM 300 SAN switch is running the 7.3.1 firmware version. The issue that we have is that some of the WWN's display the Device Name but some don't. The ones that show up ok show the manufacturer Emulex with other information and the WWN but some of them only display the WWN.

     

    Could anyone assist with this please?

     

    Thanks,

     

    Graham


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: Device Name not showing on SAN switch.

    Posted 07-15-2015 01:01 PM

    try first with the command "nodefind" and/or "nsshow" is probable a BUG in vmware or vmware drivers


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: Device Name not showing on SAN switch.

    Posted 07-16-2015 12:42 AM

    general windows servers will add their hostname to the wwn, this is a driver thingy

    its looks like this

    NodeSymb: [52] "Emulex LPe1205-HP FV2.01A4  DV10.2.261.4 "serverhostname"

     

    whereas 

     

    linux or aix servers dont do that

    you could try to name the HBA in the bios, if the hba supports that.

     

    otherwise this information is redundant and not necessary to run the SAN


    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: Device Name not showing on SAN switch.

    Posted 07-16-2015 01:43 AM

    Hi Guys,

     

    Thanks for the posts so far.

     

    I ran the command nodefind followed by the WWN and I got the same information on one of the WWN's show shows the device name but with the following differences.

     

    Device type: NPIV Unknown(initiator/target)

    SCR 0x00000000

     

    And on the ones that displays all the information it had another paremeter as below.

     

    FC4s: FCP

     

    The WWN that doesn't show the device name doesn't get detected by the SAN. I have manually entered the WWN into the SAN when trying to add the host but it says the paths are disconnected. The strange thing is that all of the hosts are running the same firmware and driver versions but some show the device name and some don't. The ones that do show the device name can be seen by the SAN.

     

    Thanks


    #BrocadeFibreChannelNetworkingCommunity


  • 5.  Re: Device Name not showing on SAN switch.

    Posted 07-16-2015 02:27 AM

    are all ports the same, i mean one host per connection or are there more host via npiv connected`?


    #BrocadeFibreChannelNetworkingCommunity


  • 6.  Re: Device Name not showing on SAN switch.

    Posted 07-16-2015 03:22 AM

    We use a blade system so there are multiple hosts per port. I had a look at the on the name server tab an it shows NPIV on the same line as the WWN?


    #BrocadeFibreChannelNetworkingCommunity


  • 7.  Re: Device Name not showing on SAN switch.

    Posted 07-22-2015 04:39 AM

    I have found when I use one uplink port from our C7000 to the switch it works but not when I use 2. Any ideas? I have disabled one connection and tested and everything worked ok so I disabled the 2nd and enabled the 1st connection again and still fine. When I had both connections enabled that's when I got the issue again.


    #BrocadeFibreChannelNetworkingCommunity


  • 8.  Re: Device Name not showing on SAN switch.
    Best Answer

    Posted 07-27-2015 08:46 AM

    Hi,

     

    The issue is now fixed. We had to downgrade the firmware as advised by HP.

     

    Environment
    FACT:HP ProLiant BL460c Gen9 Server
    FACT:HP FlexFabric 20Gb 2-port 650M Adapter
    FACT:HP FlexFabric 20Gb 2-port 650FLB Adapter
    Questions/Symptoms
    SYMPTOM: Storage path will disappear after the Firmware upgrade to 10.5.65.21
    SYMPTOM: Problem is seen with VIrtual Connect Manager and OneView enviornments
    SYMPTOM: Storage path may disappear after 650FLB Firmware upgrade to 10.5.65.21
    SYMPTOM:P roblem is seen with Virtual Connect FLexfabric 10/24 and 20/40 modules
     
    Upgrading with latest firmware (10.5.65.21) on 650 FLB may cause the path to the storage to disappear. This issue may occur when using the latest SPP Version 2015.06.0.
    Cause
    CAUSE: This issue only occurs because of the 650FLB firmware version 10.5.65.21
    Answer/Solution
    FIX: This issue is currently under investigation
    As Workaround downgrade the firmware to 10.2.477.23 using (SPP) Version 2015.04.0 Or Reduce the uplink to 1 per Virtual connect SAN fabric or OneView Fibre Channel Uplink set.

     


    #BrocadeFibreChannelNetworkingCommunity