Brocade Fibre Channel Networking Community

Expand all | Collapse all

Unable to enable root account X6 director

  • 1.  Unable to enable root account X6 director

    Posted 03-04-2019 04:45 AM

    Hey,

     

    I have a X6 director running FOS v8.2.1a.

     

    1. I log in as admin

    then I do:

     

    rootaccess –set all

    >Operation not supported on this platform

     

    userconfig –change root –e yes

    >root cannot be enabled on this platform

     

    What now? I cannot enable root to use it!

     

    Thanks

     

    Nigel

     


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: Unable to enable root account X6 director

    Posted 03-04-2019 06:27 AM

     

    1) Are you performing the rootaccess --set all command using the general mgmt IP of the X-6 ?

       

     

    2) Search of most recent Brocade Release Notes did not find a defect describing your problem. 

          Maybe try doing a CP failover, then re-attempt the rootaccess --set all command.

     

    3) Do you get any output from this command? :    userconfig --show root 

     

    4) This might require opening an SR with Brocade.


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: Unable to enable root account X6 director

    Posted 03-04-2019 07:18 AM

    Hi,

     

    I am logging into the management IP of the switch,

     

    See below:

     

    login as: admin
    admin@XXXXXXXXX's password:
    XXXXXXXXXXXX:FID128:admin> firmwareshow
    Slot Name       Appl     Primary/Secondary Versions               Status
    --------------------------------------------------------------------------
      1  CP0        FOS      v8.2.1a                                  ACTIVE *
                             v8.2.1a
      2  CP1        FOS      v8.2.1a                                  STANDBY
                             v8.2.1a
    XXXXXXXXXXXX:FID128:admin> userconfig --show root

    Account name: root
    Description: root
    Enabled: No
    Password Last Change Date: Wed Jun 13 2018 (UTC)
    Password Expiration Date: Not Applicable (UTC)
    Locked: No
    Home LF Role: root
    Role-LF List: root: 1-128
    Chassis Role: root
    Home LF: 128
    Day Time Access: N/A
    XXXXXXXXXXXX:FID128:admin> userconfig --change root -e yes
    root cannot be enabled in this platform
    XXXXXXXXXXXX:FID128:admin> rootaccess --set all
    Operation not supported in this platform
    XXXXXXXXXXXX:FID128:admin>


    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: Unable to enable root account X6 director

    Posted 03-04-2019 08:37 AM

    FOS v8.2.1a is brand new. Possibly there is a bug(?) regarding root access enabling.

     

    I did notice in FOS v8.2.1a this:

     

    "FOS 8.2.1 adds the -force option to the rootAccess command to bypass the interactive prompt of the command execution."

     

    Maybe start over by setting rootaccess --set none   then  rootaccess --set all -f 


    #BrocadeFibreChannelNetworkingCommunity


  • 5.  Re: Unable to enable root account X6 director

    Posted 03-04-2019 08:53 AM

    @willsm 

     

    the problem solution is in the output, the root account is current set to disable

     

    I've marked in Red

     

    XXXXXXXXXXXX:FID128:admin> userconfig --show root

    Account name: root
    Description: root
    Enabled: No

     

    bevor you can set the root account to access, must be first to enable

     

    simple execute the follow command

     

    userconfig --change root -e yes

     

    and then

     

    rootaccess --set all

     

    optional with the operand -f

     

     


    #BrocadeFibreChannelNetworkingCommunity


  • 6.  Re: Unable to enable root account X6 director

    Posted 03-04-2019 09:14 AM

    Antonio,

    This user tried to set rootaccess to all but it states the operation is not supported.

     

    The user posted this entry shown above:

     

    XXXXXXXXXXXX:FID128:admin> rootaccess --set all
    Operation not supported in this platform
    XXXXXXXXXXXX:FID128:admin>


    #BrocadeFibreChannelNetworkingCommunity


  • 7.  Re: Unable to enable root account X6 director

    Posted 03-04-2019 11:58 PM

    Hello guys,

     

    is the switch from Brocade ? 

     

    I've found one nice note in Admin guide FOS 8.2.0

     

    NOTE
    Not all systems ship with root accounts. If your system does not
    have a root account, you will not be able to enable it.

    #BrocadeFibreChannelNetworkingCommunity


  • 8.  Re: Unable to enable root account X6 director

    Posted 03-05-2019 05:40 AM

    Good question, Marian.   Who is the supplier of the X-6 ?   Brocade, EMC, IBM, other?....If you dont know the answer please

    run command chassisshow and look at the last few lines of output, it should indicate which company supplied the switch.

     

    That said, if all else fails I would suggest a CP failover then retry enabling root account.


    #BrocadeFibreChannelNetworkingCommunity


  • 9.  Re: Unable to enable root account X6 director

    Posted 03-19-2019 10:02 AM

    The switch is Huawei.

     

    Apparently its had its root account disabled permeanently from when it was built for security reasons.

     

    So nothing I can do apparently.


    #BrocadeFibreChannelNetworkingCommunity