Brocade Fibre Channel Networking Community

Expand all | Collapse all

FCR lost problem

  • 1.  FCR lost problem

    Posted 01-19-2018 03:28 AM

    Our FCR function has already been running normally for 2.5 months, but today we just power down and on it, then it cannot work !!

    SNS1:admin> fcrxlateconfig
    ImportedFid ExportedFid Domain OwnerDid XlateWWN
    100 101 200 0000a0 N/A
    101 100 200 0000a0 N/A

    Persist XD state: Enabled


  • 2.  Re: FCR lost problem

    Posted 01-19-2018 03:33 PM

    It's been a while I haven't been logged on a router, but it looks like an (almost) normal fcrxlateconfig output :-) Could you provide more details about the problem? what are the symptoms?


  • 3.  Re: FCR lost problem

    Posted 01-19-2018 04:21 PM

    The symptom is that the column value of xlateWWN are all N/A! And we also cannot see the fcr_xd_ information  from the output of fabricshow !!


    SNS5192_1:admin> fabricshow
    Switch ID Worldwide Name Enet IP Addr FC IP Addr Name
    2: fffc02 10:00:c4:f5:7c:ca:2e:c4 >"SNS5192_1"



  • 4.  Re: FCR lost problem

    Posted 01-19-2018 04:50 PM

    Good point for n/a. I assume the fabricshow output is from your edge fabric's switch? Any messages logged on your router at the moment of power on? Why did you reboot it?


    At your place I would start with step by step checking all the configuration parameters, the same as you did while enabling fcr.


  • 5.  Re: FCR lost problem

    Posted 01-20-2018 12:01 AM
      |   view attached

    We just need transform the UPS equipments in our computer room!  And before this,  the FCR  was good!
    Now I send the corresponding supportshows to you!  The configuration itself should be still all right!



    zip   1.04MB 1 version

  • 6.  Re: FCR lost problem

    Posted 01-20-2018 05:16 AM



    firstly: calm down, I'm just trying to help. For this I need to understand where the problem is and know a little bit a configuration. So, I took a quick look at supportshow and I assume that the fcr service is running and is working. The switch SNS5192_1 is your bb router, the only one in bb fabric, right?  It should be connected to SNS5192_2, fid 100 (edge fabric) and SNS1, fid 101 (another edge fabric)? Am I right? The problem is not in fcr service itself, the problem is that your LD links, ports 88&89 are down. I saw in the command history taht you've been grepping the output by E, so maybe you have also a couple of E links down in you're bb fabric.


    My questions are: How many routers in BB fabric? What porterrshow on 88 & 89 is saying? Please make also sfpshow on that two ports.


    What is saying the raslog on your adge switch (fid 101)? To which ports you're ld where connected and what is saying porterrshow? We need to know the reason why that two ports went offline.




  • 7.  Re: FCR lost problem

    Posted 01-20-2018 07:58 PM

    Thanks a lot !


    Yes, you are almost right.  The switch SNS5192_1 is our sole BB fabric router with FID 101, and It is connected to SNS5192_2 with fid 100 (edge fabric) !
    But the ports 88&89 LD link are just another IFL trunking for cold redundant not being used at ordinary times, that means we are only using the ports 216&217 for the actual  IFL trunking !


    Pls, why do you think the value N/A of XlateWWN is good ?


  • 8.  Re: FCR lost problem

    Posted 01-21-2018 10:18 AM

    Sorry for the delay. For n/a value: I just remember that I saw the "n/a" on a perfectly fonctionning router in my environ, but as I said: it's been a while, I may be wrong :-) Any possibility to get supportshow from SNS5192_2? What is fcrfabricshow saying from SNS5192_1?


  • 9.  Re: FCR lost problem

    Posted 01-21-2018 06:49 PM
      |   view attached

    It's just possible that I  omit the supportshow of SNS5192_2 ! Now I send it to you !



    zip   1.20MB 1 version

  • 10.  Re: FCR lost problem

    Posted 01-24-2018 11:50 AM

    Hi liuyl,


    sorry for my disparition, but I'm quite busy and it won't change ;-) So, the only thing I see that's may be the source of the problem are the same xlate domain ID's. Have you tried to delete the domain ID's and then set them one more time with fcrxlateconfig? I would make a removal and then fcrxlateconfig 100 101 101 // fcrxlateconfig 101 100 100.


    You have also (but I don't really know if it makes a part of the problem) the "rests" of your fcr config on edge switch. But the removal would imply some downtime, I think.


    Anyway, let's try with fcrxlateconfig and let me know if it worked.


  • 11.  Re: FCR lost problem

    Posted 01-26-2018 06:18 PM

    Sorry for my delay! A few days ago, we just turned on some ignored machine systems those belong to their corresponding LSAN Zone, then the FCR became normal & good!
    But I still somewhat do not understand why the xlateWWNs must need all the entities of their corresponding LSAN systems' WWNs to activate in spite of themselves virtuality!


    > fcrxlateconfig
    ImportedFid ExportedFid  Domain    OwnerDid         XlateWWN
       100      101          200       0000a0    5c:4f:57:cc:a2:fe:4f:23
       101      100          200       0000a0    5c:4f:57:cc:a2:fe:4f:24

    Persist XD state: Enabled


  • 12.  Re: FCR lost problem

    Posted 01-27-2018 11:36 AM

    Thank you for your message and... good to hear all's fine!!!