Brocade Fibre Channel Networking Community

Expand all | Collapse all

disable the default portname configuration

Jump to Best Answer
  • 1.  disable the default portname configuration

    Posted 08-08-2014 03:38 AM

    Hi there,

     

    I get the in subject mentioned failure when trying to set the portname to "". When searching for a way to disable the default portname configuration, I did not find something helpful.

    With "configure" I can't set this value.

     

    Has someone a hint for me?


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: disable the default portname configuration

    Posted 08-08-2014 07:09 AM

    From the Command reference manual.. portname ....

     

    The port name is a character string up to 128 characters, including spaces and characters, and excluding commas (,), semicolons ( ; ), backlashes (\), and the at sign (@). To erase a port name, specify this operand as an empty string in double-quotation marks. If the

    name includes spaces it must be included in double quotation marks. This operand is optional; if omitted, the current port name is displayed. Some characters require a qualifier or double quotation marks when used with a bash shell; for example, enter a single quotation mark as \', enter an exclamation mark as \!, or enter a pipe (|) as "|".

     

     


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: disable the default portname configuration

    Posted 08-08-2014 08:19 AM

    Hi nathan,

     

    I enter the following command:

    portname 20 -n ""

     But when I do this on our Blade SAN Switches with 7.2.0a I get a failure message:

    Assigning portname to NULL is not allowed. To set the portname to NULL, please disable the default portname configuration.

    So I think I use the right syntax, also because when using the same command on a 5300 with 6.4.2b the command works fine.

    So I would like to follow the recommendation, but I don't find a way to disable the default portname configuration as mentioned.


    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: disable the default portname configuration
    Best Answer

    Posted 08-12-2014 09:58 PM

    You have to disable the switch first:

     

    Sydney_ILAB_DCX-4S_LS42:FID42:admin> configure
    
    Configure...
    
      Fabric parameters (yes, y, no, n): [no] y
    
        Domain: (1..239) [106] 
     Enable a 256 Area Limit
     (0 = No, 
      1 = Zero Based Area Assignment, 
      2 = Port Based Area Assignment): (0..2) [0] 
        WWN Based persistent PID (yes, y, no, n): [no] 
        F-Port Device Update Mode: (on, off): [off] 
        Allow XISL Use (yes, y, no, n): [yes] 
        R_A_TOV: (4000..120000) [10000] 
        E_D_TOV: (1000..5000) [2000] 
        WAN_TOV: (0..30000) [0] 
        MAX_HOPS: (7..19) [7] 
        Data field size: (256..2112) [2112] 
        Sequence Level Switching: (0..1) [0] 
        Disable Device Probing: (0..1) [0] 
        Suppress Class F Traffic: (0..1) [0] 
        Per-frame Route Priority: (0..1) [0] 
        Long Distance Fabric: (0..1) [0] 
        BB credit: (1..27) [16] 
        Disable FID Check (yes, y, no, n): [no] 
        Insistent Domain ID Mode (yes, y, no, n): [no] 
        Disable Default PortName (yes, y, no, n): [no]   <<<<<<<<<<<<
        Display FDMI Host Name (yes, y, no, n): [no] 
        Edge Hold Time(Low(80ms), Medium(220ms), High(500ms): (80..500) [220] 

     Without disabling the switch it will not show up.

     

    this box runs FOS 7.3.0 BTW.

     

    Cheers,

    Erwin


    #BrocadeFibreChannelNetworkingCommunity


  • 5.  Re: disable the default portname configuration

    Posted 08-13-2014 02:07 AM

    Thank you for your help.

    I will then schedule this for the next maintenance like next year or so ;)


    #BrocadeFibreChannelNetworkingCommunity