Brocade Fibre Channel Networking Community

Expand all | Collapse all

D-Port traffic test fails on new DWDM links with "Local port error(s): GENERIC"

Jump to Best Answer
  • 1.  D-Port traffic test fails on new DWDM links with "Local port error(s): GENERIC"

    Posted 02-18-2019 02:31 AM

    Hello,

     

    we are extending 2 existing fabrics via DWDM links (16G)

    adding new X6-8 Directors to existing 8510-8 cores

     

    the DWDM links negotiate to N16 fine and extend the fabrics to the new switches

    now to verify the links we use the D-Port feature,

     

    configured the ports with

    portdisable

    portcfgdport –enable –dwdm

    portcfgpersistentenable

     

    portdporttest –start

     

     

    Anyway the link traffic test continuously fails with “Local port error(s):   GENERIC” (see below)

    In the –detail output we see 1m frames tx and rx and no errors apart from 1 loss of signal.

    Behaviour is the same on all 4 links we test.

     

    Version 8510-8 is v7.4.1.e

    Version X6-8 is v8.0.2c

     

    Any hints on why the link traffic test fails?

    Thanks in advance

    Joachim

     

     

    portdporttest --show 9/6

    D-Port Information:

    ===================

    Slot:                           9

    Port:                           6

    Remote WWNN:                   10:00:00:27:f8:e7:a9:b5

    Remote port index:             70

    Mode:                           Manual

    No. of test frames:             1 Million

    Test frame size:               1024 Bytes

    FEC (enabled/option/active):   Yes/No/No

    CR (enabled/option/active):     Yes/No/No

    Start time:                     Mon Feb 18 11:12:11 2019

    End time:                       Mon Feb 18 11:13:10 2019

    Status:                         FAILED

    ================================================================================

    Test                   Start time     Result         EST(HH:MM:SS)   Comments

    ================================================================================

    Electrical loopback     11:12:14       PASSED         --------       ----------

    Optical loopback       --------       SKIPPED         --------       ----------

    Link traffic test       11:12:29       FAILED         --------       ----------

    ================================================================================

    Roundtrip link latency:         unknown

    Egress power:                   Tx: -1.5 dBm, Rx: -3.6 dBm, Diff: 2.1 dBm (Loss is within tolerable limit)

    Ingress power:                 Rx: -2.0 dBm, Tx: -2.2 dBm, Diff: 0.0 dBm (No Loss)

     

    Failure report:

    Local port error(s):   GENERIC


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: D-Port traffic test fails on new DWDM links with "Local port error(s): GENERIC"

    Posted 02-20-2019 01:45 AM

    Hello,

     

    could you clear counters, run test and share output of portstatsshow and porterrshow?

     


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: D-Port traffic test fails on new DWDM links with "Local port error(s): GENERIC"
    Best Answer

    Posted 02-25-2019 06:36 AM

    Hi all,

     

    for the records: the test went fine as soon as I used the -time Option instead of relying on the default (1 mio frames)

     

    like:

     

    portdporttest --start -time 00:10

    portdporttest --show

     

     

    Status:                         PASSED

    ================================================================================

    Test                    Start time      Result          EST(HH:MM:SS)   Comments

    ================================================================================

    Electrical loopback     07:36:27        PASSED          --------        ----------

    Optical loopback        --------        SKIPPED         --------        ----------

    Link traffic test       07:36:46        PASSED          --------        ----------

     

    Bye

    Joachim


    #BrocadeFibreChannelNetworkingCommunity