Brocade Fibre Channel Networking Community

Expand all | Collapse all

WebTools GUI not starting

  • 1.  WebTools GUI not starting

    Posted 04-03-2013 06:32 AM
      |   view attached

    Have IBM BCH with Brocade SAN Modules installed in the Chassis. When trying to log into WebTools GUI I get a Java exception error after authenticating and GUI loading process locks at 19%. I have used IEv8, Mozilla 19 with Java 7u17 and Java 6u43 but receive the same error. Could anyone provide a potential solution to this issue?


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: WebTools GUI not starting

    Posted 04-03-2013 06:39 AM

    http services is hang.

    here the solutions.


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: WebTools GUI not starting

    Posted 04-03-2013 07:46 AM
      |   view attached

    No change after recommended changes referenced by your article. See Java exception error attached.


    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: WebTools GUI not starting

    Posted 04-03-2013 08:28 AM

    Is the switch behind by a Firewall ?

    if yes, disable for short time and test if working or not.


    #BrocadeFibreChannelNetworkingCommunity


  • 5.  Re: WebTools GUI not starting

    Posted 04-03-2013 08:50 AM

    No, there are no firewalls between me and the Brocade SAN Modules.


    #BrocadeFibreChannelNetworkingCommunity


  • 6.  Re: WebTools GUI not starting

    Posted 04-03-2013 09:46 AM

    have you executed the command from my first post, as admin or root ?

    you must login with root credential and not as admin.

    /fabos/libexec/webdconfigure


    #BrocadeFibreChannelNetworkingCommunity


  • 7.  Re: WebTools GUI not starting

    Posted 04-03-2013 11:04 AM


    Yes I have executed the "hareboot" command as root on the switch I made changes to and the settings were except for the two  (HTTP Attributes and HTTP Restart) were set correctly.


    #BrocadeFibreChannelNetworkingCommunity


  • 8.  Re: WebTools GUI not starting

    Posted 04-03-2013 11:15 AM

    I believe we have some confusion

    Login as root and then:

    Brocade4100:root> /fabos/libexec/webdconfigure 
    HTTP attributes (yes, y, no, n): y     set to y or yes
    HTTP Restart (yes, y, no, n): y        set to y or yes
    HTTP enabled (yes, y, no, n):         must be set to yes also enable.
    ErrorLog Enabled (yes, y, no, n):   
    AccessLog Enabled (yes, y, no, n):   
    SSLLog Enabled (yes, y, no, n):   
    HTTP Port: (1..60000)   
    Secure HTTP Port: (1..60000)   
    HTTP IsAlive Check Enabled (yes, y, no, n):     must be set to yes
    HTTP Max HeapSize: (256..1024)   
    webtools attributes (yes, y, no, n):   
    cal attributes (yes, y, no, n):  

    log as root and try "hareboot"


    #BrocadeFibreChannelNetworkingCommunity


  • 9.  Re: WebTools GUI not starting

    Posted 04-03-2013 11:29 AM

    I was logged in as root when I ran the "/fabos/libexec/webdconfigure" command. It would not work otherwise. After that I ran the "hareboot" command and there was no change in accessing the switch through WebTools.


    #BrocadeFibreChannelNetworkingCommunity


  • 10.  Re: WebTools GUI not starting

    Posted 04-03-2013 10:56 PM

    Hi,

    did you try it from a another PC?

    Regards

    Ralf


    #BrocadeFibreChannelNetworkingCommunity


  • 11.  Re: WebTools GUI not starting

    Posted 04-05-2013 01:42 PM

    Hi sjcarter,

    if restarting the web services do not help as recommended by techhelp 24, please check how many versions of java have you installed.

    also check what is the supported java version for your switch and FW and leave only one version. all old java versions you'd better delete.


    #BrocadeFibreChannelNetworkingCommunity


  • 12.  Re: WebTools GUI not starting

    Posted 07-08-2014 07:55 AM

    Hello,

     

    I had this same problem and IBM/Broace told me the same thing, to reinstall JAVA. For me it turned out to be a DNS issue. Instead of going to the IP do an NSLOOKUP on the windows command line for that IP and use that FQDN to access the switch. Worked for me.


    #BrocadeFibreChannelNetworkingCommunity