Brocade Fibre Channel Networking Community

Expand all | Collapse all

Cannot find resource to help answer this.

  • 1.  Cannot find resource to help answer this.

    Posted 05-20-2015 01:51 PM

    I have a customer that gets an error whenever they add a new Zone.

     

    "Configuring a Zone Consisting of WWN and Domain, Port Index Zone Members is not recommended in FICON environment."

     

    I've done as much Tae-Kwon-Googling as i can handle. Any thoughts?


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: Cannot find resource to help answer this.

    Posted 05-20-2015 02:43 PM

    It seems they try to do mixed zoning - mixing WWPN- and Domain,Port-Zoning is not a good idea and especially not with FICON. With mixed zoning, the switch will do so called "session based hard zoning" instead of real hard zoning.

    In real "hard zoning" the nameserver will only tell the device about the devices it's zoned too. If the device sends a frame to a device it's not zoned with, the frame will be dropped.

    In "session based hard zoning" it will get the same info from the name server but if it decides to send a frame to another address, the frame will reach the destination with one exception: the PLOGI. The ("end-to-end"-)PLOGI is usually the start of a conversation between 2 devices. It starts the session. The ASIC operating a port in session based hard zoning will catch that PLOGI, check if the source id and destination id belong to devices zoned with each other. If that's not the case, it will drop it. Everybody expects the devices to not do communicate with each other then. A mainframe on the other hand gets its addresses from the path definitions in its iocds and therefore doesn't depend on the switch's nameserver.

    So if you do mixed zoning in a FICON environment and make a mistake while building the iocds, the mainframe can send all sorts of frames (but PLOGIs) without being blocked by the zoning.


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: Cannot find resource to help answer this.

    Posted 05-21-2015 06:53 AM

    Sebastian,

    Thank you for the quick response. The customer does not have any mainframes of any sort. The error apparantly, "showed up one day.." and nothing has been changed. what is the best way to go about disabling FICON?


    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: Cannot find resource to help answer this.

    Posted 05-21-2015 02:56 PM

    Hi @nvandeguchte,

     

    See the instructions here on enabling or disabling FICON helps.


    #BrocadeFibreChannelNetworkingCommunity


  • 5.  Re: Cannot find resource to help answer this.

    Posted 05-25-2015 10:25 PM

    You probably have fms mode enabled on one of the switches in the fabric. Check the output of ficoncupshow on each of them. Where did you get this/these switches from? This does NOT turn on by itself. Someone must have made some change somewhere.


    #BrocadeFibreChannelNetworkingCommunity