Brocade Fibre Channel Networking Community

Expand all | Collapse all

IPFC access

  • 1.  IPFC access

    Posted 09-06-2014 04:21 AM

    Hello guys


    First disclaimer: I've fu...ed up, I know :)

    I was playing with Brocade switches on not-yet-producton environment. I was creating virtual switches and everything was fine until seting up IP addresses. Long story short, I've changed main IP on the switch and have been cut off from it without possibility to login.

    Situation is now like this:

    - I have fabric with 2 switches with FOS 7.1.1b on two different locations

    - I have three virtual switches on each switch: FID 126 where all devices are connected, FID 127 Base for xISL and default with all ports disabled

    - on good (let's call it switch A for a time being) switch I have one Eth IP configured (with x.x.x.80), IPFC for FID 126 is .82, and for 127 is .81

    - on "bad" switch (B) I have Eth IP configured as .41, IPFC for 126 is .42, and on Base switch IPFC is This is basicly what I get from fabricshow

    - I've tried to login from A to B using ssh and IPFC for FID 126 but with no luck - after executing the command nothing happening, no errors, no output at all, I need to CtrlC to get back to normal command line.



    Do you have any idea how to fix it? Thanks to all gods, FC activity isn't disrupted, so I won't be executed on Monday on sight ;) Yes, you can write I'm moron to do something like this, I've already figured it out ;)


    Thanks in advance for any help.


  • 2.  Re: IPFC access

    Posted 09-07-2014 12:04 AM



    can you please explain a bit precise ?


    Q.: do you try to connect from Base Switch from Fabric_A to LS= Logical Switch in Fabric_B ?


  • 3.  Re: IPFC access

    Posted 09-07-2014 02:56 AM

    No no, I'm talking about only one fabric, second one is ok and doesn't even need to be mentioned. I have two fabrics, each of them contains two switches. 


    What I tried to do is login from FID126 in Switch A (from fabric 2) to FID 126 in Switch B (also from fabric 2). I logged into Switch A that is working properly using root account, set context to FID 126, and just executed "ssh


    Switches are configured this way: I have all F_Ports in FID126, E_Ports of xISL in FID127 (Base), and unused ports are in default and persistent disabled. I couldn't log anywhere from default FID, because it's not using xISL, so even a fabricshow (executed from DEFAULT FID) doesn't show any additional switches in this fabric. I can see other Switch only from FID126 and 127. But only 126 have configured IPFC.


    I hope I was more precise this time :)


  • 4.  Re: IPFC access

    Posted 09-08-2014 12:27 AM



    Are the IPFC IPs in FID 126 of both switchs in the same subnet? If switch_A FID 126 IP is in a different subnet that Switch_B FID 126 IP, modify it so that both are in the same subnet. Once done, you should be able to connect via IPFC from one switch to the other one. 







  • 5.  Re: IPFC access

    Posted 09-08-2014 03:51 AM

    Well, IP is set correctly I didn't make any mistake there, I can't be sure about netmask (since I cannot login and check), but it should be ok also.


    Is this possible, that it's just a malfunction of the switch, specificly it's eth module? May it just froze or something during changing IP (it probably needs to be restarted during that procedure, so maybe it hung during restart)?


  • 6.  Re: IPFC access

    Posted 09-08-2014 04:02 AM



    have you check if the IP and/or SSH/SSL - is probable - is behind by any Firewall ?




  • 7.  Re: IPFC access

    Posted 09-08-2014 04:17 AM

    Well it is, but that wouldn't explain, why it stop working just after IP change. I was using .40, .41 and .42 IP before change and it works fine. I was logged in using .42 IP (.40 was main IP then), and after changing .40 to .41 I got disconnected, and couldn't established connection again with any IP. Here is output from fabricshow from another switch in this fabric:


    Switch ID   Worldwide Name           Enet IP Addr    FC IP Addr      Name
     31: fffc1f  xx:xx:xx:xx:xx:xx:f8:d3    >"B48030"
     71: fffc47 xx:xx:xx:xx:xx:xx:01:02     "B48070" 


    As you can see, nothing out of ordinary here. If we rule out malfunction, everything should be ok there.


    Moreover, even if it's problem with firewall, why can't I login using IPFC from another switch? Am I wrong or should that use FC connection and bypass ethernet?


  • 8.  Re: IPFC access

    Posted 09-08-2014 04:35 AM

    the problem why bevore made change work, and now is not,  can have more reason.


    are the Switches with FID 126 and 127 Native Base Switches ? Is possible you have set the FID on LS Switches ?


    see note below, otherwise I would suggest to review the "ipaddrset" command


    Use the -ls option with appropriate arguments to set or delete the IPv4 Fibre Channel address and prefix for the IPFC interface of a logical switch. In a Virtual Fabric environment, each logical fabric is represented by a separate IPFC network interface. Each of these network interfaces can be assigned a unique IPv4 FC address and prefix. The logical switches that make up a logical fabric are identified by the fabric ID (FID) that is assigned to each of the logical switch instances.




    When setting the IPFC interface of a switch that is not in Virtual Fabric mode, use the -ls option with
    FID 128. FID 128 identifies the switch when Virtual Fabrics are disabled.


    additional try follow,


    with command "ipaddrset --clear" you can remove all IP Address set on Interface and the add again


  • 9.  Re: IPFC access

    Posted 09-08-2014 05:17 AM

    What I did is execute ipaddrset without any argument. Interactive configurato starts, and while trying to just hit enter to leave IP as it was, I accidently hit right mouse button and paste .41 IP that was in stored in clipboard :) Yes, I'm a moron, I've mentioned it at the begining ;)


    Anyway, I cannot use any of your solution, because I cannot log into the switch, so I cannot perform any of commands you suggested. I think I won't avoid calling the technician to go there and fix it manualy.





  • 10.  Re: IPFC access

    Posted 09-08-2014 06:02 AM



    -->> I cannot perform any of commands you suggested.


    you can connect to the switch trough the Serial Console - IOIOI - , this is independent from net management Port.




  • 11.  Re: IPFC access

    Posted 09-08-2014 02:37 PM
    Well, I can't, but that's a different story (I'm like 1000 miles from switch :) ). Anyway, whole poin was to diagnose what's happened and if possible, fix it myself. I know for some time now (from your replies and discussions with others) that easy way is not an option here, technician will be on site tomorrow. So thanks guys for help (and patient ;) )

    But, can anyone tell me what's happened and why it doesn't work? Because I just can't figure it out. Just for educational purpose :) Most popular opinion is that address conflict occured, but I'm not exactly convinced. Thanks in advance