Brocade Fibre Channel Networking Community

Expand all | Collapse all

FCIP TUnnel creation - -b and -B parameter

  • 1.  FCIP TUnnel creation - -b and -B parameter

    Posted 01-17-2018 03:57 AM

    Good day

     

    Can someone tell me why when i create a FCIP tunnel, it asks for a -b and -B parameter when AE is not even licensed?

     

    FOS version 7.4.1c on a 7800 series FCIP switch - i have tried creating a tunnel without this parameter, just tried specifying a 0 after the comand, but it will not create

     

    so i end up having to specify -b 1000000 -B 1000000

     

    here is what i tried initially -

    - portcfg fciptunnel 16 create --remote-ip 1.1.1.1 --local-ip 2.2.2.2 0   - the 0 at the end i thought represented a no commit rate, use what is available - did not work

     

    i had to issue

    - portcfg fciptunnel 16 create --remote-ip 1.1.1.1 --local-ip 2.2.2.2 -b 1000000 -B 1000000 to be able to create the tunnel - worked

     

    by specifying the -b and -B to the same setting without AE licensed, is this the same as an uncommited rate?

     

    thanks


    #BrocadeFibreChannelNetworkingCommunity


  • 2.  Re: FCIP TUnnel creation - -b and -B parameter

    Posted 01-19-2018 08:13 AM

    The -b and -B parameters are the upper and lower boundaries of the ARL backoff algoritm. They are used to automatically adjust the bandwidth demand and rate limit the FCIP bandwidth depending on load. They are required parameters. 

     

    See the FCIP guide for further information on ARL and how to configure.


    #BrocadeFibreChannelNetworkingCommunity


  • 3.  Re: FCIP TUnnel creation - -b and -B parameter

    Posted 01-25-2018 11:14 AM

    I guess i am wondering if Advanced Extension License is NOT licensed here, then the -b and -B parameters are not needed, but i cannot create a tunnel without specifying these parameters.

     

    I know with the AE license activated, ARL is one of the features that comes with that license. Seeing that these switches do not have Advanced Extension, i was just more or less wondering how a tunnel can be created without specifying a set commit rate, ie just create the tunnel to use the full Gb link available to it.

     

    thanks


    #BrocadeFibreChannelNetworkingCommunity


  • 4.  Re: FCIP TUnnel creation - -b and -B parameter

    Posted 08-03-2018 10:26 AM

    Hi....I am training on two pods, and one pod seems to have problems bringing up the FCIP tunnels. I tried to troubleshoot but not sure exactly the best way at this time. I attached to the IPS module and looked at the fcip fsm but couldn't make out exactly what was going on. If anyone has any ideas how to drill down to see what may be happening let me know. 


    #BrocadeFibreChannelNetworkingCommunity