The Water Cooler

Expand all | Collapse all

More woes around "thank you for submitting your message"

  • 1.  More woes around "thank you for submitting your message"

    Posted 03-31-2020 05:31 AM
    ​Hi.

    This is not the biggest issue as there is a workaround, but it's another bit in HigherLogic that's really quite anoying. Maybe the vendor can be made to do something about it.

    As @Michael A. Lowry pointed out earlier, after posting, the URL has "&SuccessMsg=Thank+you+for+submitting+your+message." attached it it. After I post, one often times may want to send the URL with ones answer included to a colleague or client. When I send the "thank you" URL, that gives odd results. One can not even click on the post title to get back to the "regular" thread view. One needs, as far as I can see, navigate back to, e.g. the Water Cooler thread list, open the thread again, and only then can I copy the URL proper.

    Would be splendid if that could be eased.

    Thanks!


    ------------------------------
    These contain very good advise on asking questions and describing supposed bugs (no, you do not need to go to StackExchange for Automic questions, but yes, the parts on asking detailed, useful questions ARE usually relevant):

    http://www.catb.org/~esr/faqs/smart-questions.html

    https://www.chiark.greenend.org.uk/~sgtatham/bugs.html

    I will not respond to PM asking for help unless there's an actual reason to keep the discussion off of the public forums.
    ------------------------------


  • 2.  RE: More woes around "thank you for submitting your message"

    Posted 03-31-2020 06:14 AM
    Edited by Michael Lowry 03-31-2020 06:15 AM
    Oh god the URLs are such a mess. The documentation site is another example.

    Here's the (somewhat) clean URL to a particular documentation page:
    https://docs.automic.com/documentation/webhelp/english/ALL/components/DOCU/12.3/Automic%20Automation%20Guides/help.htm#Script/Reference/PUT_PROCESS_LINE.htm

    Here's the URL of the same page if you navigate to it via the table of contents sidebar:
    https://docs.automic.com/documentation/webhelp/english/ALL/components/DOCU/12.3/Automic%20Automation%20Guides/help.htm#Script/Reference/PUT_PROCESS_LINE.htm%3FTocPath%3DReference%7CAutomation%2520Engine%2520Script%2520Reference%7CScript%2520Elements%2520Ordered%2520by%2520Purpose%7CData%2520Sequences%7C_____17

    Why this info is encoded in the URL, I cannot fathom. It's not stuff that belongs there. Put it in a cookie, or store it just for the session.

    Making matters worse, the URL in the address bar is often not even updated when one navigates via the TOC. So if you copy the link, you are often copying the link of the first page your visited, not the page you're currently viewing.


  • 3.  RE: More woes around "thank you for submitting your message"

    Posted 03-31-2020 07:18 AM
    Edited by Carsten Schmitz 03-31-2020 07:22 AM
    Why this info is encoded in the URL, I cannot fathom. It's not stuff that belongs there

    Annecdote time:

    A company I worked for developed a web app and it encoded certain images and other binary data as part of the URL. I once debugged an issue with it where an URL had four gigabytes of data encoded into it, to which our head developer merely pointed out (correctly) that the RFC allows it, and also: why not?

    I rest my case.

    (n.b. just if that wasn't clear, I think this is an absolutely silly idea)

    (n.n.b. while the RFC allows it, there are things known as "browsers" for which I can certify that they don't like 4GB in the URL, or already the few megabytes this would entail in most "regular" cases. However, due to the magic of modular task assignment, our head developer almost exclusively used curl for working on that part, and iirc curl even handled a giganormous URL without any issues).




    ------------------------------
    These contain very good advise on asking questions and describing supposed bugs (no, you do not need to go to StackExchange for Automic questions, but yes, the parts on asking detailed, useful questions ARE usually relevant):

    http://www.catb.org/~esr/faqs/smart-questions.html

    https://www.chiark.greenend.org.uk/~sgtatham/bugs.html

    I will not respond to PM asking for help unless there's an actual reason to keep the discussion off of the public forums.
    ------------------------------



  • 4.  RE: More woes around "thank you for submitting your message"

    Posted 04-22-2020 06:45 AM
    Edited by Michael Lowry 04-22-2020 06:49 AM
    Check out this link.


  • 5.  RE: More woes around "thank you for submitting your message"

    Posted 04-22-2020 07:08 AM
    ​Good thing I am in the office all alone, I laughed waaaaaaaay to hard at this :D

    ------------------------------
    # signature.sh --verbose=[true|false]
    # no configurables beyond this point, only signature

    Does using the slide show widget for posting individual images spread Corona? Don't take the risk, use the "insert image" button in the editor!

    Did you know? I will NOT respond to PM asking for help unless there's an actual reason to keep the discussion off of the public forums!

    "Efficient Solutions Monthly Magazine" says: These contain very good advise on asking good questions. No, you do not need StackExchange for Automic, but asking questions the right way never hurts:

    http://www.catb.org/~esr/faqs/smart-questions.html

    https://www.chiark.greenend.org.uk/~sgtatham/bugs.html
    ------------------------------



  • 6.  RE: More woes around "thank you for submitting your message"

    Posted 04-22-2020 07:37 AM
    Edited by Carsten Schmitz 04-22-2020 07:37 AM
    Hm, when you put simple HTML tags, URL escaped, into it, it is not parsed. That's okay.

    Put an URL-encoded​ img tag into it, it generates a 404.
    Put an URL-encoded img tag with a syntax error, it generates an Internal Server Error.

    Which would indicate that this is not just escaping, but seemingly parsing HTML entities on the server?

    I am rather glad I am not responsible for coding this and I can see absolutely no way how that could possibly go wrong.

    ------------------------------
    # signature.sh --verbose=[true|false]
    # no configurables beyond this point, only signature

    Does using the slide show widget for posting individual images spread Corona? Don't take the risk, use the "insert image" button in the editor!

    Did you know? I will NOT respond to PM asking for help unless there's an actual reason to keep the discussion off of the public forums!

    "Efficient Solutions Monthly Magazine" says: These contain very good advise on asking good questions. No, you do not need StackExchange for Automic, but asking questions the right way never hurts:

    http://www.catb.org/~esr/faqs/smart-questions.html

    https://www.chiark.greenend.org.uk/~sgtatham/bugs.html
    ------------------------------



  • 7.  RE: More woes around "thank you for submitting your message"

    Posted 3 days ago
    Edited by Michael Lowry 2 days ago
    This problem still exists.