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Chapter 1: Project Scheduling 

Considerations 

Introduction 

The paper provides the software architect, software developer, software engineer, system 

administrator, and support technician with the information necessary to select a project 

scheduling tool to use with CA ClarityTM PPM. Both Open Workbench (OWB) and Microsoft® 

Office Project (Microsoft Project) integrate with CA Clarity PPM, but there are tradeoffs 

involved with selecting one scheduling tool over another.  

 

Generally speaking, Open Workbench is best suited if you staff projects based upon the 

total estimated work across all project tasks. In other words Open Workbench is best used 

with “effort driven” project scheduling. Microsoft Project is best suited if you use “time-

boxed” projects where task durations are well understood or determined by dependencies 

between tasks. Both have advantages and disadvantages based upon your scheduling 

objectives. 

Understanding Your PPM Maturity Level 

Before you start thinking about which project scheduling tool you should use, you must first 

consider your company‟s Project and Portfolio Management (PPM) maturity level. A high 

level of PPM sophistication is not required to benefit from using CA Clarity PPM and 

OWB/Microsoft Project in the short term. In fact, it can be advantageous if you have little 

PPM knowledge and you are willing to adopt some of the basic CA Clarity PPM and 

OWB/Microsoft Project out-of-the-box functionality. Conversely, if you already have well 

established PPM practices, you will find adopting CA Clarity PPM and OWB/Microsoft Project 

to be relatively straight forward because CA Clarity PPM follows industry PPM best practices. 

As we know from experience, however, most companies fall somewhere in between these 

two extremes.  

Because CA Clarity PPM can be tailored to meet a variety of PPM maturity levels, you need 

to honestly evaluate where you are in your PPM journey. Be careful not to assume that 

CA Clarity PPM, in conjunction with OWB/Microsoft Project, will rectify training or 

organizational shortcomings. In situations like these, CA Clarity PPM implementations can 

point out knowledge and proficiency gaps, which can prompt you to consider what needs to 

be done to bring your organization in line with PPM best practices.  

Scheduling Tool Considerations 

When deciding which scheduling tool to use with CA Clarity PPM, you must weigh a variety 

of options. Consider the following general questions when deciding which scheduling tool to 

select and deploy: 

■ How proficient are your project managers with scheduling tools? 
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■ Do the project managers already rely on Microsoft Project? 

■ Which of the scheduling tools‟ functional features best suit your objectives? 

■ How do you currently manage your project schedules; are project assignments effort-

driven or task-driven? 

■ How do you plan to capture resource effort, through the scheduling tool or through 

CA Clarity PPM timesheets?  

■ Are you aware that you will need to deploy updated versions of Schedule Connect and 

OWB clients for each CA Clarity PPM upgrade? 
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Chapter 2: Feature Comparison 

Comparisons and Procedures  

This chapter compares and contrasts various features in OWB and Microsoft Project.        

For in-depth information on Microsoft Project, please visit the Microsoft website at: 

http://office.microsoft.com. 

Using Baselines 

Baselines can be used in both OWB and Microsoft Project, but Microsoft Project does have 

some baseline functional limitations.  

Open Workbench 

■ CA Clarity PPM allows OWB to save complete project baselines, baselines of groups of 

tasks, and individual task level baselines. You can manage baselines from Tools > 

Baselines.  

Microsoft Project 

■ Only complete project baselines should be saved from Microsoft Project to CA Clarity 

PPM. This can be confusing to some users because Microsoft Project, by itself, does 

allow task -level baselines.  

Note: Partial baselines do save to CA Clarity PPM but CA does not support this 

technique at this time. 

■ Also, if a project has an embedded subproject and you baseline the project, then the 

subproject is not baselined. You can baseline the subproject separately by opening the 

subproject in Microsoft Project or CA Clarity PPM. 

Loading Patterns and Work Contours 

A resource‟s work can be distributed across a project task in different ways based upon the 

availability of that resource. For instance, if a resource was committed to outside activities 

at the beginning of a project, it may make sense to allocate a smaller portion of that 

resource‟s time at the beginning of a project task. Likewise, as the resource‟s availability 

increases later on, then more effort can be given to accomplishing the task.  

This technique of varying the amount of work across a task is referred to in OWB as a 

Loading Pattern and in Microsoft Project it is referred to as Work Contour, and is defined as 

follows in both products: 

 

http://office.microsoft.com/
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OWB – 
Loading 

Patterns 

Microsoft Project 
– Work Contours 

Definition 

Fixed Contour Work effort distribution is user-defined 

Uniform Flat Work effort is evenly distributed in a task 

Front (Default)  Front Work efforts peaks at the beginning of a task 

Back Back Work effort peaks toward the end of a task 

Contour No Equivalent  Work effort is distributed as evenly as possible 
based upon unused resource allocation.   

 

Open Workbench 

■ OWB types, although fewer in number, offer more accurate results over Microsoft 

Project. (Microsoft Project has several more contours not listed here. Check the 

Microsoft website for further details.) OWB‟s behavior in placing resource work within a 

task‟s duration is more fluid and accurate than that of Microsoft Project. 

 

Microsoft Project 

■ Microsoft Project offers a wide diversity of “Work Contours” (for example, Front, Back, 

Bell, Double Peak, Turtle, and so forth), but as soon as these are introduced, task 

durations are likely to be extended leading to periods of resource underutilization. An 

extended overall schedule of suboptimal resource utilization is therefore likely. 

Attempting to model real-world usage patterns (some at front, some at back) is 

impractical due to the negative impacts these work contours have on the overall 

schedule. Typical user response to this difficulty is to assign only one resource per task 

and introduce new tasks to model the desired resource usage patterns, which 

introduces more complexity. 

 
Notes:  

The default loading pattern is “Front” in OWB and Clarity PPM and should be changed 

as required. 

Use the Flat work contour in Microsoft Project to increase the speed it takes for the 

.mpp file to open.  

Keep in mind that using anything other than the default (flat) loading pattern in 

Microsoft Project is highly likely to INCREASE task duration and produce underutilized 

resource periods. 

Recurring Tasks 

Scheduling recurring tasks, such as status meetings, can be created in an automated 

fashion in Microsoft project. But recurring tasks must be created manually in OWB and 

CA Clarity PPM.  
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Open Workbench 

■ Although OWB does not have a “recurring task” functionality built in, you can create 

repeating tasks in OWB by using a “fixed loading pattern.” Set the loading pattern for 

the resource on the task to Fixed and change your view by timescaling the Assignment 

ETC (Estimate To Complete). Then locate the cell for the date when the work will take 

place, and enter the amount of work effort required by each resource on each specific 

day. 

Microsoft Project 

■ The Microsoft Project recurring task functionality is supported in CA Clarity PPM. Go to 

Insert > Recurring Task to open the recurring task dialog box in Microsoft Project. The 

recurring task appears as a summary task in CA Clarity PPM. Each master task holds 

multiple subtasks, with each subtask representing a recurring event from Microsoft 

Project. 

Effects of Resource Scheduling on Duration 

Project managers must understand what effect resource scheduling changes will have on 

their schedule‟s duration. Without actively managing resources, task durations can exceed 

their deadlines and project commitments can be missed. OWB and Microsoft Project have 

slight variations in how you can control task duration. 

Open Workbench 

■ OWB allows for a granular level of control over resource scheduling. You can lengthen 

or shorten overall task duration by modifying a resource‟s “availability” or “% available 

per day. “ The resulting task duration change is actually held in check by OWB. You can 

also control task duration by setting the task duration to Fixed. 

Microsoft Project 

■ Microsoft Project acts differently from OWB in that recalculations occur whenever 

changes are made to resource availability. For the uninitiated, it can appear that the 

task duration is moving for no apparent reason. One way around this is to set the task 

type to Fixed duration.  
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Roles and Resource Replacement 

During the course of a project it may become necessary to replace a resource (typically a 

named person performing actual work) or a role (a generic description that acts as a place 

holder) against a task with other resources and roles. You can replace resources and roles 

across all tasks or against individual tasks in both OWB and Microsoft Project. 

Open Workbench 

■ When resources and roles are added to an OWB plan from CA Clarity PPM for the first 

time, the default allocation for both is set to 100%. Resource or role replacements on 

project tasks maintain the same maximum allocation percentages. For instance, if you 

replace John Doe, allocated at 75%, with Jane Smith, then Jane Smith will maintain the 

same maximum allocation of 75%. Use the “Transfer Assignments” functionality to 

swap assignments between resources and roles. 

Microsoft Project 

■ Microsoft Project behaves similarly to OWB. When resources and roles are added to a 

Microsoft Project plan from CA Clarity PPM for the first time, the default allocation for 

both is set to 100%. When replacing at the task level, resources and roles “inherit” the 

previous allocation value. Replacing resources and roles is slightly more complicated 

than in OWB, and is carried out by using the “Assign Resources” functionality. 

Creating Inter-project Dependencies 

In both OWB and Microsoft Project you can create external or internal dependencies 

between tasks that are in different projects. An external dependency occurs between two 

different projects that are not linked by a common master project. An internal dependency 

occurs between projects referenced from a common master project such as when you insert 

subproject tasks into a project. Both scheduling tools handle the mechanics differently. 

Open Workbench 

■ In OWB you can insert External Dependencies by drilling down into a project and 

selecting a specific task. 

 

To insert External Dependencies 

1. Right-click the task from a view that displays the list of tasks in the 

project (such as the Gantt Chart view) and select Insert External 

Dependency.  

The Open External Dependencies dialog box appears.  
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2. Select the project and then drill down to locate the task to insert.  

You cannot link to summary levels. 

3. Click Select to insert the selection into the project. 

By default, the external dependency is placed in the plan after the linked task, as a 

successor. It will be placed before the linked task if it is modified to be a 

predecessor. You can modify the dependency relationships of a task by editing its 

task properties.  

Microsoft Project 

■ To create External Dependencies in Microsoft Project you must manually enter the 

dependency relationship at the task level: 

 

To insert External Dependencies 

1. Open both files in Microsoft Project that you want to create the external 

dependency between. 

NOTE: You can only create external dependencies between two projects if 

both projects exist in CA Clarity PPM. 

2. Type the file name and task ID of the dependent task in the following 

format: [Project Name]\[Task ID]. For example, Configure OBS\30. 

Opening Master Projects 

Both OWB and Microsoft Project have the capability to open master projects from CA Clarity 

PPM, but both behave differently. 

Open Workbench 

■ All of a master project's subprojects are downloaded within the same OWB file. The 

OWB download process is quicker and more efficient than the Microsoft Project 

download process. 

Microsoft Project 

■ Opening a master project in Microsoft Project opens all associated subprojects within 

their own separate windows.  Additionally a collective resource pool file is also 

downloaded. Therefore the number of project files downloaded is one Master Project 

plus one or more subprojects, plus one resource pool, which may result in decreased 

download performance when compared to OWB for an equivalent operation. 
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Configuring Calendars 

CA Clarity PPM can be configured to create base calendars that are linked to resources and 

used across all projects.  Known as Base Calendars, they are downloaded each time you 

open a project in either OWB or Microsoft Project.  Base calendars define the general 

availability of a resource to work, based upon work days and holidays (non-workdays).  

Base calendars are centrally maintained in CA Clarity PPM and cannot be adjusted in OWB 

or Microsoft Project. If you enter the calendar information in either OWB or Microsoft 

Project and save the plan back to CA Clarity PPM, the calendar information will be lost. 

Schedule Calculation 

Open Workbench gives you a wider range of control over when you can recalculate 

schedules, while Microsoft Project typically re-calculates schedules automatically. 

Open Workbench 

■ With Autoschedule, you can chose to schedule the entire project or a group of project 

tasks that fall within a specific date range. The autoschedule calculation takes into 

account dependencies, date constraints, and resource availability. Resource usage is 

maximized to shorten task duration.  For example, if a resource has 80% availability, 

then the autoschedule function will use all 80% to shorten the duration of the task.  

Likewise, if a resource is over-allocated, then the task duration will lengthen.  The 

exception to this rule is if the task duration is fixed. Essentially, OWB will generate a 

project schedule with the shortest possible critical path.  

Microsoft Project 

■ A common observation of some CA Clarity PPM customers is that Microsoft Project 

appears to perform many actions without manual prompt or interaction. The complex 

relationship and interaction of project, resource, and task settings can produce an array 

of behaviors that may seem confusing to some. This is because Microsoft Project is 

typically set to calculate schedule changes automatically.  

Controlling when schedule calculations occur in Microsoft Project is accomplished by 

using the “Calculation Mode” under Tools > Options > Calculation. It is recommended 

that you keep this option set to automatic. Otherwise, you need to remember to 

manually recalculate the schedule before you save it to CA Clarity PPM. It is important 

to keep in mind that the Microsoft Project schedule is automatically recalculated each 

time it is downloaded from CA Clarity PPM, regardless of the value to which “Calculation 

Mode” is set. 

“Actuals Through Date” Tracking 

The “Actuals Through Date” is the dividing line between a resource‟s actual work that was 

accomplished in the past, and the remaining work which the resource will accomplish in the 

future. The Actuals Through Date is tracked differently in OWB and Microsoft Project and 

thus has slightly different implications in each tool. 
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Open Workbench 

■ OWB tracks the Actuals Through Date at the resource level. This means that each 

resource has its own Actuals Through Date, clearly indicating the cut-off point of past 

work. On tasks with actuals booked, remaining work is ALWAYS scheduled after the 

Actuals Through Date cut-off. 

 

Microsoft Project 

■ Microsoft Project does not track the Actuals Through Date at the resource level. 

Without this dividing line in place it is possible for users to schedule a resource‟s 

remaining work in the past. And if the project is stored in CA Clarity PPM, this can 

cause data continuity issues.  

Managing Pending Estimates 

On occasion, a team member may determine that the remaining work estimate is not 

sufficient to complete a task. For example, rather than two days of remaining work, a team 

member may feel there are another five days of work remaining to complete the task.  

To communicate this “Pending Estimate” back to the Project Manager, the team member 

can overwrite the Estimate to Complete (ETC) value on their timesheet with the new value. 

This proposed change in hours needs to be either approved or rejected by the project 

manager. This is done differently in OWB and Microsoft Project. OWB will let you accept or 

reject pending estimates “en masse” or by task. Microsoft Project will only allow you to 

accept or reject pending estimates on a task by task basis. 

Open Workbench 

■ Accept Pending Estimates 

To accept pending estimates for selected tasks 
 
1. Open the project and select the tasks for which you want to accept the estimates. 

Otherwise start with step 2. 
   
2. Select Tools > Pending Estimates.  

 
The Pending Estimates dialog box opens. 
 

3. Define the scope by selecting Project, View, or Selected Task(s), and then select 
Accept Pending Estimates. 

 
4. Click OK.   

 
The Pending Estimates are accepted and the Pending Estimates dialog box closes. 
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■ Reject Pending Estimates 

To reject pending estimates for selected tasks 
 
1. Open the project and select the tasks for which you want to reject the estimates. 

Otherwise start with step 2. 
 

2. Select Tools > Pending Estimates.  
 
The Pending Estimates dialog box opens. 

 
3. Define the scope by selecting Project, View, or Selected Task(s), and then select 

Reject Pending Estimates.  
 

4. Click OK.  
 
The Pending Estimates are rejected and the Pending Estimates dialog box closes. 

■ Partially Accept Pending Estimates 

To partially accept pending estimates for tasks 
 
1. Update the ETC value to reflect your opinion of how much work remains to be 

done. For example, if the current ETC is 20 and the Pending ETC is 30, you might 
decide that 25 is a better value; so set the ETC to 25. 
 

2. Select the tasks for which you have modified the ETC value. 

 
3. Select Tools > Pending Estimates.  

 
The Pending Estimates dialog box opens. 

 
4. Define the scope by selecting Selected Task(s), and then select Reject Pending 

Estimates.  
 

5. Click OK.  
 
The Pending Estimates are rejected and the Pending Estimates dialog box closes. In 
the example given in step 1, this will set the task ETC and Pending ETC to 25. 

 
 
Note 1: The Pending Estimates option is disabled if you are viewing a read-only copy of 
a project or if the track mode is not set to “Clarity”. 

 
Note 2: You are strongly advised to reject inappropriate Pending Estimate values. If 
you do not, they will remain on the timesheet and the resource will assume that they 
have been agreed upon. 
 

Microsoft Project 

CA Clarity PPM maps a timesheet‟s Pending Estimate field to Microsoft Project‟s „Number1‟ 

field (column). To view this field, open the Task Usage view in Microsoft Project, then add a 

column and select „Number1.‟ 

There are three possible values: 

1. 0 indicates a Summary task or a generic role assignment, or that the resource is 

suggesting there is no more work left to do on the task. 
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2. -1 indicates the ETC value on the timesheet has not been modified. 

3. A value other than -1 indicates that the value is the team member‟s suggested ETC 

from their timesheet.  

■ To Accept or Partially Accept Pending Estimates  

1. Update the current Remaining Work value (overtype the existing value) to either 

the value in the Number1 column or a more appropriate value. 

2. Set Number1 column to be -1 so that the new value in the Remaining Work column 

will display in the ETC column of the timesheet. 

■ To Reject Pending Estimates  

1. Set the Number1 field to -1. 

2. Leave the Remaining Work field untouched. 

Lookups 

Lookup fields display a drop-down list from which to choose an item. Lookups can be 

developed in CA Clarity PPM (via Clarity Studio) and then added to project-related objects 

(project, task, resource). Although this section does not describe the mapping process, it is 

helpful to know how lookups behave in both Open Workbench and Microsoft Project. 

Open Workbench 

■ OWB supports the CA Clarity PPM data model.  After custom lookups have been created 

in CA Clarity PPM and added to project related objects as attributes, these new 

attributes will automatically be available within OWB. Then the user will be able to 

make selections from the lookup‟s drop-down list from within the OWB environment. 

Microsoft Project 

■ Microsoft Project does not integrate as completely with CA Clarity PPM custom lookups 

on project-related object attributes. Although lookup attributes can be mapped from 

CA Clarity PPM to Microsoft Project, the options presented to the user will be different.  

For example, if you created a custom lookup in CA Clarity PPM with the options “Yes” 

and “No”, then these options would appear the same in the OWB drop-down list.  

Microsoft Project, on the other hand, will not display these “visible” options. It will 

instead display the “hidden” codes, which might be “0” and “1” for this sample lookup.  

In other words, the lookup attribute values are available in Microsoft in a less user-

friendly manner. 

Task Numbering 

Task numbering operates differently between OWB and Microsoft Project. OWB does not 

automate the creation and management of task numbers, while Microsoft Project 

automatically generates task numbering and maintains task hierarchy. 
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Open Workbench 

■ OWB does not auto-number the ID column field by default. Instead, it allows the 

Project Manager to manually number his/her tasks. However, you can create manual 

IDs, for example 1, 1.1, and so on. And OWB will assign alternative IDs if you type in a 

duplicate ID by mistake. For example, if you number a task ID as 1.2 when 1.2 already 

exists, then OWB will automatically renumber the task ID to 1.2-2.  

■ As an alternative you can use copy and paste to do batch numbering, which may be the 

preferred method from a user perspective. Here‟s how: 

 

To use copy and paste to do batch numbering 

1. Type a letter, such as T for Task, in the ID column of the first task.  

2. Do Ctrl+C or Edit Copy. 

3. Click and drag using the left mouse button to highlight the ID cells for a group of 

tasks and use Ctrl+V to paste the ID.  

 

This will generate a unique number extension after the T.  

4. Repeat until all tasks have been given an ID. 

5. Note that if you insert additional tasks, you must perform the same copy and paste 

process to continue generating unique numbers for the new tasks. 

Microsoft Project 

■ Microsoft Project Task numbering is generated in two ways. The Task ID column 

automatically generates a task number each time you create and populate a task. You 

can also use Microsoft Project‟s “outline number” column that indicates the exact 

position of a task in the outline. For example, a task with an outline number of 7.2 

indicates that it's the second subtask under the seventh top-level summary task. 

Microsoft Project has the added functionality that will automatically renumber columns 

if you insert tasks in between existing tasks. 

Shared Views 

Views are used in both OWB and Microsoft Project to arrange project data in a more 

relevant way for the user. OWB allows users to have access to both local views as well as 

shared enterprise-level views via a User View Library and a Corporate View Library. 

Microsoft Project only allows users access to local-level views. 

Open Workbench 

■ Enterprise views are stored in the Corporate View Library. This file can be stored in a 

shared location such as a read-only network drive. Users can map to the Corporate 

View Library via their OWB interface. The end result is access to a common list of views 

from anywhere in the enterprise. 
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To Create a Corporate View Library 

1. Copy the “Standard.rwl” library (and all of the .rwf, .rws, and .rwv files located in 
C:\Program Files\Open Workbench\Views\en) to a network location where you 
want the Corporate View Library to reside. (Assign read-only access rights as 
appropriate to the OWB users, and read and write access to the Corporate View 
Library administrator.) 
 

2. Rename the library to “Corporate View Library.rwl” or something similar. 

 
3. From OWB select Tools > Options.  

 
The Options dialog box appears. 
 

4. Click Locations.  
 
The Locations tab of the Options dialog box appears. 
 

5. As the Corporate Library administrator, you then assign the Corporate View 
Library.rwl file location specified in Step 2 as your User View Library location.  

 
This step provides you with the means to create, edit, and delete files that will 
comprise the Corporate View Library, network access rights permitting. 
 

6. Edit, create, or remove view, sort, and filter files that will comprise the Corporate 
View Library. 
 

7. On the Locations tab of the Options dialog box, remove the location assigned as a 
User View Library, and reassign it as the Corporate View Library. 

 
8. Ensure all OWB users reference the Corporate Library as their Corporate View 

Library. 

 

To Access the Corporate View Library 

1. Navigate to Tools > Options.  
 

2. Click the Locations tab. 

 
3. Click the Corporate View Library link.  

 
4. Click Browse and select the pre-determined network location  

(Corporate View Library.rwl). 
 

5. Click Open. 

Microsoft Project 

■ You cannot directly share Microsoft Project views across the enterprise. You can, 

however, share views across projects (within your instance of Microsoft Project) so that 

you do not have to recreate the same view for each project file. The following 

procedure shows how to share a view by copying it to the global.mpt file. 

To share a view by copying it to the global.mpt file 

1. On the Tools menu, click Organizer. 

2. Select the Views tab. 

3. Select the view that you created, and click Copy.  
 
The view will be copied to the Global.MPT file. 
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4. Click Close.  

■ You can create one or more views for a project, which are linked to that project. When 

you save the project to CA Clarity PPM and another user opens the project in their 

instance of Microsoft Project, the other user will see the views that you created. The 

other user can then save the project views to their global view list. 

Exporting and Sharing Data 

It is possible to transfer project data from Microsoft Project to OWB via XML files. 

Exchanging project data in the opposite direction does not exist at the time of this writing.  

Open Workbench 

■ OWB allows you to save project data in both .rmp and .xml file formats. Although 

exported .xml files cannot be opened in Microsoft Project, the file does make it possible 

to make custom integrations with other systems. 

■ Schedule data can also be cut and pasted from OWB into Microsoft Excel and vice 

versa. However, most of the formatting will be lost, including OWB color highlights, 

when this is done. 

Microsoft Project 

■ Microsoft Project makes it possible to export project data in a variety of formats. 

Besides .xml, project data can be saved in the following formats: .csv, .txt, .xls, .mdb, 

.html and .mpp. 

Macros 

A macro is used by Microsoft Project as part of the integration mechanism (Microsoft Project 

Interface) between Microsoft Project and CA Clarity PPM. There are some implications to 

take into account when using this macro. 

Open Workbench 

■ Macros are not used by OWB. 

Microsoft Project 

■ Because Microsoft Project uses macros you will want to make sure to select the proper 

macro security level. Having the setting set too high will prevent the macro from 

installing the Microsoft Project Interface. Another item to consider is that because the 

Microsoft Project Interface macro code is customizable, it can be thought of as 

extensible. An example of extensibility in this case would be modifying the macro code 

to check for certain task field values in Microsoft Project before saving the field values 

to CA Clarity PPM. 
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Chapter 3: Other Considerations 

Performance 

CA Clarity PPM integrates well with the OWB design and architecture. However, both OWB 

and Microsoft Project can encounter performance issues – especially when project files 

become large and complex. 

Use the following suggestions to increase Open Workbench performance. 

For Open Workbench (releases 7.5.1_FP02_Schedulers, 7.5.1 FP03 and greater) there is a 

registry option that allows the user to override OWB‟s default memory allocation behavior. 

The default behavior allows Java to allocate up to a maximum of 512 MB. This means on a 

265 MB machine OWB would allow Java to allocate up to 128 MB, whereas on a 2 GB 

machine the maximum allowed allocation would be 512 MB. 

The new feature allows the user to set the maximum allowed memory for Java.  

To set the maximum allowed memory for Java 

1. Find the registry key is: HKEY_LOCAL_MACHINE\SOFTWARE\Niku\Niku Workbench. 

 
2. The value to add or change is: 'JavaMemoryLimit' 

 

3. When adding the new value 'JavaMemoryLimit', it should be created as a DWORD and 
the value‟s unit is in megabytes. Thus a decimal value of 256 would allow allocation of 
up to 256 MB. 

 
4. When setting 'JavaMemoryLimit', you usually want to change the Base to be Decimal 

(not Hexadecimal) when setting the value. 

 
5. When overriding the default behavior with 'JavaMemoryLimit', OWB will no longer cap 

the maximum memory allocated to 512 MB.  

Note: If a user sets 'JavaMemoryLimit' to a value that cannot be honored, then you may 

see Open Workbench start up (flash) and immediately shutdown. 

Use the following suggestions to increase Microsoft Project performance. 

To increase Microsoft Project performance 

1. Increase the memory of the workstations to at least 512 MB, ideally 1 GB.  

 

Very large projects require a lot of memory for the plan to open in Microsoft Project. 

a. Go to the registry. Click on Start > Run and type in “regedit”. 
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b. Navigate to the 

HKEY_CURRENT_USER\SOFTWARE\Niku\Schedulers\MSPOptions. 

c. Right-click the MSPOptions folder and select New>String Value. 

d. Change the name to “JavaMemoryLimit. 

e. Change the value data to “256”. 

2. For long duration projects, review all task dates and 'bring in task finish dates' when 

appropriate, and review all long duration tasks to reduce the duration whenever 

possible. 

3. Review all assignments, especially for the over-allocated resources. You may have 

many over-allocated resources that are assigned at 100% for too many tasks. These 

assignments increase the time it will take to export the project. Therefore, remove all 

assignments that are not necessary. 

4. Use the Microsoft Project option for "flat loading patterns" on tasks. 

5. Remove unnecessary baselines. 

Using OWB and Microsoft Project Together 

It is possible to manage projects in the same client environment with both OWB and 

Microsoft Project, but it is not recommended. This practice is called “toggling.”   

It is strongly recommended that you stay with a specific scheduling tool for a particular 

project and not change. OWB and Microsoft Project operate in such different manners that 

issues usually arise that can introduce corrupted data into your project plan. If making both 

schedulers available in an organization clear rules should be set for when OWB applies and 

when Microsoft Project applies. 
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Chapter 4: Summary 

Summary 

 

The most critical tool for measuring project status and performance is a detailed project 

plan that is regularly maintained with actuals. Therefore, it is important that the project 

plan accurately reflects expected and actual results across the key constraints of scope, 

budget, and schedule. Due to the complexity involved with managing intertwined project 

tasks and resources, most projects require automated support from specialized project 

management tools such as Open Workbench and Microsoft Project.  

As described in this paper, many considerations must be taken into account when selecting 

a scheduling tool. Regardless of which scheduling tool you choose, it is important to keep 

your company‟s Project and Portfolio Management experience level in mind. No scheduling 

tool, no matter how sophisticated, will do your project scheduling for you. A thorough 

understanding in PPM concepts will go a long way in helping to evaluate the tradeoffs 

involved with selecting the best scheduling tool to meet your business needs.  
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