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1. About  
 

1.1. About this Guide 
 

This manual is intended for malware analysts and researchers who are utilizing the Blue Coat Systems Malware 
Analysis appliance (MA) solution and are interested in optimizing malware detection via the use of IntelliVM (iVM) 
profiles. It discusses detailed installation processes for Windows XP and Windows 7; other versions of Windows will 
follow very similar procedures. 

 

This manual assumes that the reader is well versed in network terminology and operations, and is familiar with 
malware in general and malware analysis in particular.  An understanding of Windows system events and network 
intrusion techniques is helpful as well. 

 

1.2. System Requirements 
 

The Malware Analysis appliance contains all of the necessary hardware, software, and connectivity needed to analyze 
malware in isolated or networked environments right out of the box using sophisticated iVM profiles that can be 
configured to mimic “typical” Windows systems or actual production configurations. 

 

Customizing iVM profiles is accomplished via Remote Desktop connections using built-in or easily accessible open-
source tools, connecting to publicly accessible websites for component downloads and updates. 

 

1.3. Help and Support 
 

We strongly recommend that you read this guide thoroughly before installing Malware Analysis appliance and 
attempting to configure iVM profiles, and that you use it as a reference during installation, configuration, and ongoing 
usage. 

 

In this guide, you will find instructions on how to install and configure iVM base profiles and how to customize these 
base images into highly-realistic approximations of production systems used within your organization. 

 

 

Support 

 

If you encounter any difficulty with the setup or usage of the Malware Analysis appliance in general, or the 
configuration or usage of iVM profiles in particular, please contact your Symantec sales representative or sales 
engineer, or visit our Support website at https://support.symantec.com/en_US/contact-support.html.  

 

  

https://support.symantec.com/en_US/contact-support.html
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2. IntelliVM Profiles 

2.1. IntelliVM Overview 
 

IntelliVM kernel technology monitors system events for signs of malicious behavior in a virtualized environment.  
Profiles can be customized to add flexibility to analyze non-traditional malware and to precisely mirror custom 
environments to detect advanced and targeted threats. 
 

Virtual machines (VMs) are software implementations of computer systems that execute programs just like physical 
machines, without putting real PCs at risk of malware infection.  By using VM profiles to mirror multiple environments, 
analysts can quickly spot anomalies and differences in behavior that unveil anti-analysis and other advanced malware 
evasion techniques.  VMs can easily be setup to match various Windows XP, Windows 7 (32-bit and 64-bit), and 
Windows 8 (64-bit) environments – such as patched and unpatched versions running alternate applications, browsers, 
and plugins – to quickly spot different malicious behaviors on multiple system types.  VMs easily revert to a known 
non-infected state for repeat testing. 
 

 
Figure 1– Available IntelliVM Profiles with Windows 7 set as the Default Profile 

2.2. Base Images 
 

Base images include complete Windows operating systems along with a number of preinstalled applications or 
components used to facilitate malware detection from various file types.  Base images do not run directly within 
Malware Analysis appliance. Instead, they are used to create profiles which actually run within the IntelliVM virtual 
machine framework. 

 

Four (4) base images presently ship with Malware Analysis appliance v4.2.8: 

• Windows XP, Service Pack 3 (32-bit) 
• Windows 7, Service Pack 1 (32-bit) 
• Windows 7, Service Pack 1 (64-bit) 
• Windows 8 (64-bit) 

Note Base images ship from the factory and can be modified or deleted by the customer.  Users 
cannot add new base images; however they can create an unlimited number of custom profiles 
derived from the existing base images. 
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2.3. Profiles 
 

Profiles are ready-to-run encapsulations of base images plus additional customizations designed to replicate 
particular Windows environments.  These customizations include commercial applications, custom applications, 
additional web browsers, and patches to components including applying Windows Updates to plug security 
vulnerabilities as they are released by Microsoft Customizing profiles allows the customer to run additional file types 
through the analysis process with each one running within its own native application. 

 

• Standard Profiles – Malware Analysis appliance ships with four (4) standard profiles: Windows XP SP3, 
Windows 7 SP1 32-bit, Windows 7 SP1 64-bit, and Windows 8 64-bit 

The preinstalled standard profiles are built from their respective base images. 
 

• Default Profile – The profile that runs “automatically” when no particular profile is specified. This profile often 
represents the most organization’s most prevalent configuration. Only one profile can be the default at a time.   
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3. Customizing VM Profiles  

3.1 Build a New Profile  
 

Administrative users can create, modify, or delete VM profiles at any time. Create VM profiles as needed to closely 
replicate production environments, or to test the behavior of malware across different configurations. 
 

Example: Analysis of potential malicious sample on Sales, Engineering, and Accounting workstations. 
 

• Sales Profile  Windows 7 (SP1), Microsoft Office 2010, Internet Explorer 10 
• Engineering Profile  Windows 7 (SP1), Microsoft Office 2007, Firefox 20 
• Accounting Profile  Windows XP (SP3), Microsoft Office 2003, Internet Explorer 9 

 

1. Log in to the web interface with Administrator credentials. 

2. Select Analysis Settings > IntelliVM Profiles. The IntelliVM Profiles page is displayed.  

 
Figure 2 - Intelli VM Profiles 

3. Click to access the Creating New IntelliVM Profile screen. 

 

Figure 3 – Creating New IntelliVM Profile 

 

 

Profile Name Enter a meaningful name for the profile. The name is mandatory. 
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Example: Sales Win 7  
 

 

Base Image Select the desired image, the ‘starting point’ for the new profile. This is mandatory. 
 

Example:   
 

 

Description List the contents of the profile in as much detail as desired. The description is optional. 
 

Example: Windows 7 (SP1) with Microsoft Office 2010 and Internet Explorer 10 
 

4. Click  to create the profile after entering all selections. The IntelliVM Profiles page is 
displayed again, with the new profile in the list. 

 
Figure 4 – IntelliVM Profiles List 

Note Before a profile has been built, you may click Edit Details to change the base image. After the profile 
has been built, you cannot change the base image. 

5. Click Build Profile. The Customize IntelliVM Profile: [Profile Name] page is displayed. 

 
Figure 5 – Customization and Build Page 

6. Click Start Customization.  

 
Figure 6 – Entering Customization Mode 

Several minutes will elapse while the profile is prepared for customization. 
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Caution While you are in customization mode, all processing in all IntelliVMs is suspended.  

 
Figure 7 – Manual Customization Message 

When the profile is ready for customization, the following message is displayed: To manually customize your profile you 
can connect via RDP to on port 3389/tcp. Default login credentials are "admin" with no password. 

Note Blue Coat recommends that you not close your browser while customizing a profile. 

7. On a Windows workstation, launch Remote Desktop Connection. The Remote Desktop Connection dialog is 
displayed.  

 

Figure 8 – Remote Desktop Connection Dialog 

8. Click Show Options. 
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Figure 9 – Expanded Remote Desktop Connection Dialog 

• For Computer, type the IP address of the Malware Analysis appliance and the port number in the following 
format: <ip_address>:3389. 

• For User name, type admin. 

• Click Connect, and then click OK. The desktop of the iVM is displayed. 

 

Windows Example 

 
1. Launch Remote Desktop Connection 
2. Enter the IP address for the Malware Analysis appliance 
3. Login to Windows on the Remote Desktop 

 
The virtual Windows Desktop inside of the selected 
Malware Analysis appliance IntelliVM appears. 

 

 

 

 

 

 

 

Remote Desktop Log On to Windows 
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3.2 Disable Automatic Update Checks 
Before adding any customizations, verify that the applications that are already installed on the iVM are not checking for 
updates automatically. This ensures a consistent, uninterrupted analysis state. Additionally, the device reverts back to its 
last built state after each analysis. Follow this process: 

1 From the Control Panel in the iVM, select Windows Update and verify that updates are not being installed 
automatically.  

 
Figure 10 — Windows Update Control 

2 Launch the Microsoft Silverlight Configuration dialog. 

 
Figure 3 — Silverlight Updates Dialog 

3 Click the Updates tab, and verify that Never check for updates is selected. 
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4 Launch the Adobe Reader, select Edit > Preferences, select Updater from the Categories list, and verify that Do not 
download or install updates automatically is selected. 

 
Figure 4 — Adobe Reader Preferences Dialog 

5 For any other non-Microsoft applications that are on the iVM or that you later install, verify that the automatic update 
checks are disabled. 

6 Do you want to further customize the iVM profile? 

Yes — Continue the procedure. No — Go to Finalize and Build the Profile. 
 

 

3.3 Application Installation 

Note The customer is responsible for obtaining the appropriate licenses for software that is installed on the 
iVMs. Contact the vendors of the respective software to obtain the proper license type for the iVMs. 

To transfer installation files to your iVM, use one of the following methods: 
• Use Remote Desktop Sharing. In the Remote Desktop Connection window, go to Options > Local 

Resources > More… > Local devices and resources. Select the location to map. 
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Figure 13 — Network 

Copy the files across as required. 

• From inside the iVM, map a shared network drive or folder. 

 
Figure 14 — Network Entities on the iVM  

• Connect to the Internet to download software from an Internet resource or vendor site. (This 
connection is made through the Backend interface.)  

Note To use a different proxy to access the Internet from inside the iVM, configure that proxy inside the 
iVM's Windows environment. 

o The tsclient entity is the workstation that is accessing the iVM via Remote Desktop. 

Install, license, and configure the applications to resemble a typical computing environment at your organization. 

Note  Your specific remote desktop client will determine which resources are available and the various 
methods that you can use to add software to a VM profile. Specific procedures are beyond the scope of 
this guide. 
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Blue Coat recommends using a shared drive or folder to add software to a VM profile. 
 

 

Shutting Down the Remote Connection 

 

Disconnect the connection to the virtual Windows system by clicking and selecting Disconnect. 

 

3.4 Finalize and Build the Profile 
When you have finished customizing the profile, you must finalize and build it. Building the profile involves packaging 
up the base image along with any modifications and additional software, and getting the profile ready to run tasks. 

 
1. Log out of the Remote Desktop session. 

2. Return to the Customize IntelliVM Profile: [Profile Name] page on the Web interface.  

3. Click  Build Profile.  

 
Figure 15 — Profile Building 

Several minutes will elapse while the profile is being built. 

4. When the profile has finished building, select Analysis Settings > IntelliVM Profiles to return to the 
IntelliVM Profiles page. 

 
Figure 16 — iVM List 

5. The new profile is ready for use. You may begin to send samples to the new profile, or you may select 
one of the following: 

• Edit Details — Return to the Creating New IntelliVM Profile page and change the description or 
name. (You cannot change the base image of an already-built profile.) 

• Customize Profile — Click to add further customizations to the iVM profile.  

• Delete Profile — Click to delete the profile. This action cannot be undone. 

• Set as Default — Click to make this profile your default profile.  
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3.5 Modifying Profiles 
You may modify two aspects of a profile: the iVM itself or the iVM's details. 

Note You cannot change the base image of an already-built profile. 

Select Analysis Settings > IntelliVM Profiles. 

 
Figure 17 — iVM List 

• To modify the details, click Edit Details. Edit either the profile name or its description, and then click 
Save Changes. 

 
Figure 18 — Editing Details 

• To modify a profile, click Customize Profile, and then follow the instructions in steps 0 through  to 
access the iVM through Remote Desktop. When you have finished the modifications, you must build 
the profile again. 

3.6 Deleting Profiles 
To delete a profile select Analysis Settings > IntelliVM Profiles. 

Caution Deleting a profile cannot be undone. If you do not intend to deactivate a particular base image, 
do not delete the last profile that is associated with that image. Deleting a profile that has tasks assigned 
to it will result in an IVM_Error when that task reaches the top of the queue. 
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4. Optimizing Profiles 

4.1. Standard Profiles 
 

Malware Analysis appliance ships with base images for Windows XP SP3 and Windows 7 SP1. Base images are 
“starting points” for customizing robust malware detection environments. Base images may be enhanced by the 
customer or the SE. 

 

Base image contents have been specially selected to provide a robust malware testbed. As such, the preinstalled 
component versions may not necessarily represent the latest versions available from their respective manufacturers. 

 

The standard Malware Analysis appliance IntelliVM base images include: 

• Compatibility Pack for the 2007 Office System 
• Microsoft Office Excel Viewer 
• Microsoft Office Word Viewer 2003 
• Microsoft PowerPoint Viewer 
• Python 2.7.6 
• Windows Internet Explorer 8 

 

Note  Due to temporary licensing restrictions, several necessary base image components are unable to ship 
from the factory preinstalled. We expect this situation to be resolved shortly. 

 
4.2. Enhanced Profiles 

 

Customize profiles to add the flexibility to analyze non-traditional malware, and to closely mirror custom environments 
to detect advanced and targeted threats. Enhancing the MALWARE ANALYSIS APPLIANCE IntelliVM base images 
will include adding the following components to the Windows XP SP3 and Windows 7 SP1. 

• Adobe Reader 
• Adobe Flash 
• Microsoft .NET Framework 3.5 SP1 
• Microsoft Silverlight 
• Java 
• Microsoft C++ Redistributable 2010 

Note Adding software beyond that which is provided by the base images may require proper third-
party licenses. 
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5. Enhance the Windows XP Profile 
 

The Malware Analysis Appliance comes with the following programs pre-installed. You may update them to the latest 
version if you wish to.  

This section is for your information. All steps are optional. 

The examples in this section reflect currently installed versions. 

Adding components to base images works the same way as adding software to a physical machine. The process is 
identical, consisting of downloading software from websites and negotiating installation dialogs. 
 

Step 1: Inside the Windows XP virtual machine on the Desktop, press the Start button and select Control Panel. 
 

 
Figure 19 – Windows XP Start Menu 

 

Step 2: Inside the Control Panel, click Add or Remove Programs. 
 

Step 3: Inside the Add or Remove Programs window, confirm that the following programs are currently installed. 
 

• Compatibility Pack for the 2007 Office System 
• Microsoft Office Excel Viewer 
• Microsoft Office Word Viewer 2003 
• Microsoft PowerPoint Viewer 
• Python 2.7.6 
• Windows Internet Explorer 8 

 

This configuration is the proper starting point for the Windows XP base image enhancement process. 

Note Please contact your technical representative if your base image configuration does not 
closely match Figure 20. 
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Figure 20 – Windows XP Add or Remove Programs displaying starting base image configuration 

 

Step 4: Click the Internet Explorer icon on the Windows XP Desktop to open the Web browser. 

 

Note Sections 4.1 through 4.6 all take place through the Internet Explorer Web browser interface. 

 

6.6 Adobe Reader  
 

Installing Adobe Reader is optional. 

 

Step 1: Download Adobe Reader from the following address and navigate the installer as required; decline the 
Optional Offer, and click Install Now. 
 

• http://get.adobe.com/reader/  
 

http://get.adobe.com/reader/


Malware Analysis Appliance | IntelliVM Profile Customization Guide                         Enhance the Windows XP Profile 

© 2017 Blue Coat Systems, Inc. 18 of 76 Updated 16 Jun 2017 

 
 

Step 2: When the installation is complete, run the Adobe Reader application from the Desktop and accept the 
End User License Agreement (EULA). The EULA appears automatically upon the first launch of the application. 
 

Note The IntelliVMs will be unable to utilize Adobe Reader properly until the EULA has been accepted. 

 

 
Figure 21 – The Adobe Reader End User License Agreement (EULA) 

Step 3: Turn off automatic updates. From the Edit menu, select Preferences. 

Note  Updates are valuable for improving security and beneficial for the malware detection process, however 
it is essential that the MALWARE ANALYSIS APPLIANCE system administrator apply all updates 
manually so as to maintain configuration control over the malware testbed at all times. If components 
were to be allowed to update themselves automatically at random intervals, then configuration control 
becomes impractical and the administrator is never quite sure what versions of which components are 
being used for malware testing. 

 

Launch Adobe Reader 
from the Windows XP 

Desktop 

Click here to 
accept the EULA 
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Figure 22 – Disabling automatic updates from the Preferences screen 

Note Additional Adobe Reader versions: https://get.adobe.com/uk/reader/otherversions/. 

6.7 Adobe Flash 
 

Installing Adobe Flash is optional. 

 

Step 1: Download Adobe Flash from the following address and navigate the installer as required; ; decline the 
Optional Offer, and click Install Now. 
 

http://get.adobe.com/flashplayer/  

Select this option 
to disable 

automatic updates 

Click here to 
commit the change 

https://get.adobe.com/uk/reader/otherversions/
http://get.adobe.com/flashplayer/
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Figure 23 – Internet Explorer Security Warning 

Step 2: If prompted to Update Flash Play Preferences during installation, select the following option: 

 

• Never check for updates (not recommended). 

 

 
Figure 24 – Update Flash Player Preferences 

 

 

Allow the Adobe 
Flash Player 

Installer to run 

 

Select this option to 
disable automatic updates 
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Note   Additional Adobe Flash versions: http://helpx.adobe.com/flash-player/kb/archived-flash-player-
versions.html.  

  

http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html
http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html
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6.8 Microsoft .NET Framework 3.5 SP1 
 

Step 1: Download Microsoft .NET Framework 3.5 SP1 from this address and navigate the installer as required. 
In Windows 7 .NET is part of the operating system and can be enabled under Programs and Features. 
 

http://www.microsoft.com/en-us/download/details.aspx?id=22 *  
 

 
Figure 25 – Installation is proceeding 

http://www.microsoft.com/en-us/download/details.aspx?id=22
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Figure 26 – Additional components being downloaded and installed 

 

 
Figure 27 – Setup Complete 

  

 

Click here to 
complete the 
installation 
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6.9 Microsoft Silverlight 
 

Step 1: Download Microsoft Silverlight from this address and navigate the installer as required. 

 

http://www.microsoft.com/silverlight/  

 

 
Figure 28 – Silverlight download complete and ready to run the installer 

 

 

When download 
completes, click 
here to run the 

installer 

http://www.microsoft.com/silverlight/
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Figure 29 – Beginning Silverlight installation 

 

 

 
Figure 30 – Disabling Microsoft Update 

 

Click 
here to 
proceed 

 

Click here to 
begin installation 

 

Uncheck this 
book to disable 

Microsoft Update 
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6.10 Java 
 

Installing Java is optional. 

 

Step 1: Download Java from the address below and navigate the installer as required. 
 

http://java.com/en/download/index.jsp  

 
 

 
Figure 31 – File Download Security Warning 

 

http://java.com/en/download/index.jsp
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Figure 32 – Java Installer Welcome screen 

 

 
Figure 33 – Decline the Free Brower Add-On 

 

 

 

Click here to 
run the Java 

installer 

 

Uncheck the 
box to decline 
the optional 

browser add-on 

 

Click here to 
continue the 
installation 
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Figure 34 – Disable the Java security prompts 

 

 
Figure 35 – Java installation successful 

 

Uncheck the 
box to disable 
Java security 

prompts 

 
Click here to 
complete the 
installation 

process 

 

Click here to 
continue the 
installation 
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Figure 36 – Configuring Java  

 

 
Figure 37 – Disabling Java updates 

 

Note Download older versions from this archive: http://www.oracle.com/technetwork/java/archive-
139210.html   

 

From the Windows XP Desktop, select: 
Start  Programs  Java  Configure Java 

 

Uncheck this 
box to disable 

automatic 
updates 

 

Click here to 
confirm stoppage 

of automatic 
security updates 

http://www.oracle.com/technetwork/java/archive-139210.html
http://www.oracle.com/technetwork/java/archive-139210.html
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6.11 Microsoft Visual C++ Redistributable 2010 
 

Step 1: Download Microsoft Visual C++ Redistributable 2010 from this address and navigate the installer. 
 

http://www.microsoft.com/en-us/download/details.aspx?id=5555 

 
 

 
Figure 38 – File Download Security Warning 

 

Click here to 
run the 

downloaded 
setup file 

http://www.microsoft.com/en-us/download/details.aspx?id=5555
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Figure 39 – Accepting the Microsoft Software License Terms 

 

 

 
Figure 40 – Installation Complete 

  

 

Check this 
box to accept 
the software 
license terms 

 

Click here 
install the 

application 

 

Click here to 
complete the 
installation 

process 
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6.12 Final Enhanced Windows XP Profile 
 

Return to the Add or Remove Programs window in the Windows XP Control Panel (see Section 5 – Enhancing 
the Windows XP Profile, Step 2) and confirm that the following programs are now installed. 
 

• Adobe Flash Player (optional) 
• Adobe Reader (optional) 
• Compatibility Pack for the 2007 Office System 
• Java (optional) 
• Microsoft .NET Framework 2.0 Service Pack 2 
• Microsoft .NET Framework 3.0 Service Pack 2 
• Microsoft .NET Framework 3.5 SP1 
• Microsoft Office Excel Viewer 
• Microsoft Office Word Viewer 2003 
• Microsoft PowerPoint Viewer 
• Microsoft Silverlight 
• Microsoft Visual C++ 2010 Redistributable 
• Python 2.7.6 
• Windows Internet Explorer 8 

 

This configuration is the proper ending point for the base profile enhancement process. 
 

Note  Please contact your technical representative if your base profile configuration does not closely match 
Figure 52. The versions do not need to be exactly the same as depicted below, as the vendors may post 
newer versions online.  
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Figure 41 – Ending configuration for the enhanced Windows XP base image 
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6. Enhance the Windows 7 Profile 
The Malware Analysis Appliance comes with the following programs pre-installed. You may update them to the latest 
version if you wish to.  

This section is for your information. All steps are optional. 

Microsoft Visual C++ runtime 2010 Redistributable is already included.  
 

Step 1: Inside the Windows 7 virtual machine on the Desktop, press the Start button and select Control Panel. 
 

 
Figure 42 – Windows 7 Start Menu 

 

Step 2: Inside the Control Panel, click Programs and Features.  

Step 3: Inside the Programs and Features window, confirm that the following programs are currently installed. 
 

• Compatibility Pack for the 2007 Office System 
• Microsoft Office Excel Viewer 
• Microsoft Office Word Viewer 2003 
• Microsoft PowerPoint Viewer 
• Python 2.7.6 

 

This configuration is the proper starting point for the Windows 7 base image enhancement process. 
 

Note Please contact your technical representative if your base image configuration does not closely match 
Figure 43. 
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Figure43 – Windows 7 Programs and Features displaying starting base image configuration 

 

Step 4: Verify that Internet Explorer is installed and activated by clicking Turn Windows features on or off. 

Click OK if you needed to turn Internet Explorer on, or click Cancel if it was already activated. 

 
Figure 44 

Step 5: Click the Internet Explorer icon on the Windows 7 Taskbar to open the Web browser. 
 

Note Sections 6.1 through 6.6 all take place through the Internet Explorer Web browser interface.  

 

Step 5 

Step 4 
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6.13 Adobe Reader 
 

Installing Adobe Reader is optional. 

Step 1: Download Adobe Reader from the following address and navigate the installer as required; decline the 
Optional Offer, and click Install Now. 
 

http://get.adobe.com/reader/  
 

 

Figure 45 – Accepting the Adobe Reader End User License Agreement 

Step 2: When the installation is complete, run the Adobe Reader application from the Desktop and accept the 
End User License Agreement (EULA). The EULA appears automatically upon the first launch of the application. 

 

Note The IntelliVMs will be unable to utilize Adobe Reader properly until the EULA has been accepted. 

 

Step 3: Turn off automatic updates. From the Edit menu, select Preferences. 

 

Note Updates are valuable for improving security and beneficial for the malware detection process, however 
it is essential that the MALWARE ANALYSIS APPLIANCE system administrator apply all updates 
manually so as to maintain configuration control over the malware testbed at all times. If components 
were to be allowed to update themselves automatically at random intervals, then configuration control 

Launch Adobe Reader 
from the Windows 7 

Desktop 

Click here to 
accept the EULA 

http://get.adobe.com/reader/
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becomes impractical and the administrator is never quite sure what versions of which components are 
being used for malware testing. 

 

 
Figure 46 – Opening the Preferences screen 

Select 
Preferences from 

the Edit Menu 
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Figure 47 – Disabling automatic updates from the Preferences screen 

 

Note Additional Adobe Reader versions: https://get.adobe.com/uk/reader/otherversions/. 

  

Select this option 
to disable 

automatic updates 
Click here to 

commit the change 

https://get.adobe.com/uk/reader/otherversions/
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6.14 Adobe Flash 
 

Installing Adobe Flash is optional. 

Step 1: Download Adobe Flash from the following address and navigate the installer as required; decline the 
Optional Offer, and click Install Now. 

 

http://get.adobe.com/flashplayer/  

 

 

Figure 48 – Retrieving Adobe Flash Player Installer 

Step 2: If prompted to Update Flash Play Preferences during installation, select the following option: 
 

• Never check for updates (not recommended). 
 

http://get.adobe.com/flashplayer/
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Figure 49 – Update Flash Player Preferences 

 

 

Figure 50 – Installing Adobe Flash Player 

Note  Additional Adobe Flash versions: http://helpx.adobe.com/flash-player/kb/archived-flash-player-
versions.html.  

 

 

 

Select this option to 
disable automatic updates 

http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html
http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html
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6.15 Microsoft .NET Framework 3.5 SP1 
On Windows 7 .NET is part of the operating system and can be enabled under Programs and Features. 

Note EMET requires .NET 4.5. Install the correct version for your applications. 

 
Figure 51 – Turning on Microsoft .NET Framework 3.5.1 or 4 from the Windows Features checklist 

  

 

Click here to display 
the Windows 

Features checklist 
 

Check the box for 
Microsoft .NET 

Framework 3.5.1/4 

 Click OK to 
commit the 

change 
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6.16 Microsoft Silverlight 
 

Step 1: Download Microsoft Silverlight from this address and navigate the installer as required. 

http://www.microsoft.com/silverlight/  

 

 
Figure 52 – Preparing to install Silverlight 

 

 

Click here to 
begin installation 

http://www.microsoft.com/silverlight/
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Figure 53 – Disabling automatic Microsoft Updates 

6.17 Java 
 

Installing Java is optional. 

Step 1: Download Java from the address below and navigate to the installer as required. 

 

http://java.com/en/download/index.jsp  

 

 

Click 
here to 
proceed 

 

Uncheck this 
book to disable 

Microsoft Update 

http://java.com/en/download/index.jsp
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Figure 54 – Installing Java 

 
Figure 55 – Configuring Java 

 

 

From the Windows 7 Desktop, select: 
Start  All Programs  Java  Configure Java 
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Figure 56 – Disabling automatic Java updates 

Note  Download older versions from this archive: http://www.oracle.com/technetwork/java/archive-
139210.html  

 

  

 

Uncheck the 
box to disable 

automatic 
updates  

Click here to 
confirm that 

automatic updates 
will be disabled 

http://www.oracle.com/technetwork/java/archive-139210.html
http://www.oracle.com/technetwork/java/archive-139210.html
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6.6 Detect Unknown Exploits with EMET 
In the Malware Analysis appliance, the Microsoft® Enhanced Mitigation Experience Toolkit (EMET) detects unknown 
exploits. For the InteliVM to be able to collect EMET events, EMET must be installed in a Windows 7 or 8 profile, and 
properly configured. This feature is strongly recommended, but optional. 

Note Blue Coat recommends that you first deploy EMET on a new profile to verify that it works as expected.  

Step 1: Create a new Windows 7 (or Windows 8) profile. EMET is not supported on Windows XP. 

Step 2: Customize the profile, then log on using RDP.  

Step 3: Download and install .NET Framework 4.5 on the iVM profile.  

Note For EMET to work with Internet Explorer 10 on Windows 8, Microsoft KB 2790907 or a more recent 
version of the Compatibility Update for Windows 8 must be installed.  

Step 4: Download EMET 5.5 and the user-guide PDF from Microsoft at: 
https://download.microsoft.com/download/8/E/E/8EEFD9FC-46B1-4A8B-9B5D-13B4365F8CA0/EMET%20Setup.msi , 
and begin the installation.  

Step 5: On the EMET Configuration Wizard page, select Use Recommended Settings, and click Finish.  

 
Figure 57 – EMET Wizard  

 

Step 6: Configure the EMET service to start automatically with no delay. Follow these steps: 

1. Click Start, and search for services.msc. 

2. Right click the service name, and select Properties.  

https://download.microsoft.com/download/8/E/E/8EEFD9FC-46B1-4A8B-9B5D-13B4365F8CA0/EMET%20Setup.msi
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3. Change the Startup Type to Automatic. 

 
Figure 58 – Set Startup Type to Automatic 

 

The following optional steps further enhance the EMET configuration. 

A: Open the EMET GUI and configure it.  

1. Uncheck the Early Warning option on the Enhanced Mitigation Experience Toolkit window, if you don’t want 
information related to an exploitation attempt to be sent to Microsoft through the standard Windows Error 
Reporting channel. 

 
Figure 59 – Deselect Early Warning 
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2. Click Apps in the upper menu bar to open the configuration window. 

3. Set your Stop on Exploit preference. 

 
Figure 60 – Configure Stop on exploit  

 

• By default EMET is set to the Default Action Stop on exploit. This is the recommended setting for 
maximizing detection. However, this may not give you all the details about the attack, including second stage 
malware information. Blue Coat recommends maintaining this choice for maximum detection and with simpler 
configurations. 

• For full attack information (and a minimal reduction in exploit detection), select Audit only. This will let the 
exploit continue as long as possible, only observing. This results in significantly more information about 
consecutive stages of the attack. 

4. Remove any applications you don’t want to monitor, if necessary. When the Use Recommended Settings 
selection is made during installation, EMET adds and configures a set of popular applications. Click Remove 
Selected when you have highlighted an application in order to remove it. 

5. If necessary, add a new application, highlight it in the list, and enable all mitigations for that application (unless 
otherwise advised). 

Note Some mitigations are not compatible with certain applications.  Blue Coat recommends referring 
to the following link to verify your settings, and then to deselect any incompatible mitigations: 
https://support.microsoft.com/kb/2909257. 

6. Click OK to return to the EMET Toolkit main window. 

 

https://support.microsoft.com/kb/2909257
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B: Start the configured applications, then click Refresh in the EMET GUI, and verify you see a green check mark in the 
Running EMET column. 

 
Figure 61 – EMET is running  

 
Step 7: Close all applications, close the remote desktop session, then build the profile. 
 
Step 8: Verify that EMET works by running samples which will trigger EMET. The following MD5 is for reference; Blue 
Coat is unable to provide the samples, as they are malicisous. They are available on VirusTotal. 

• C32AD4D6F6A00C85E6BD152852D5D09F (SimExecFlow, and StackPivot) 
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6.7 Final Enhanced Windows 7 Profile 
 

Return to the Add or Remove Programs window in the Windows 7 Control Panel (see Section 6 – Enhancing the 
Windows 7 Profile, Step 2) and confirm that the following programs are now installed. 
 

• Adobe Flash Player (optional) 
• Adobe Reader (optional) 
• Compatibility Pack for the 2007 Office System 
• Java (optional) 
• Microsoft Office Excel Viewer 
• Microsoft Office Word Viewer 2003 
• Microsoft PowerPoint Viewer 
• Microsoft Silverlight 
• Python 2.7.6 
• EMET 5.5 (strongly recommended, optional) 

 

This configuration is the proper ending point for the base profile enhancement process. 
 

Reminder: Microsoft .NET and Internet Explorer can be viewed from the Windows Features checklist in Windows 7. 
 

Note   Please contact your technical representative if your base profile configuration does not closely match 
Figure 62. The versions do not need to be exactly the same as depicted below, as the vendors may post 
newer versions online.  
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Figure 62 – Verifying the final enhanced Windows 7 base image
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7. Enhance the Windows 8 Profile 
The Malware Analysis Appliance comes with the following programs pre-installed. You may update them to the latest 
version if you wish to. User account control is disabled. 

This section is for your information. All steps are optional. 

Microsoft Visual C++ runtime 2010 Redistributable is already included. 

Flash is integrated with Internet Explorer in Windows 8. No separate install is available or required.  
 

Step 1: Inside the Windows 8 virtual machine on the Desktop, click Desktop; the basic desktop appears.  

Step 2: Navigate to the Control Panel. 

Step 3: Inside the Control Panel, click Programs and Features.  

Step 4: Inside the Programs and Features window, confirm that the following programs are currently installed. 
 

• Compatibility Pack for the 2007 Office System 
• Microsoft Office Excel Viewer 
• Microsoft Office Word Viewer 2003 
• Microsoft PowerPoint Viewer 
• Python 2.7.6 

 

This configuration is the proper starting point for the Windows 8 base image enhancement process. 
 

Note Please contact your technical representative if your base image configuration does not closely match 
Figure 63. 

 

 
Figure 63 – Windows 8 Programs and Features displaying starting base image configuration 

 

Step 4: Verify that Internet Explorer is installed and activated by clicking Turn Windows features on or off. 

Click OK if you needed to turn Internet Explorer on, or click Cancel if it was already activated. 
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Figure 64 Verify IE Is Installed 

Step 5: Click the Internet Explorer icon on the Windows 8 desktop or Taskbar to open the Web browser. 
 

Note Sections 7.1 through 7.5 all take place through the Internet Explorer Web browser interface.  

Step 4 
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6.8 Adobe Reader 
 

Installing Adobe Reader is optional. 

Step 1: Download Adobe Reader from the following address and navigate the installer as required; decline the 
Optional Offer, and click Install Now. 
 

http://get.adobe.com/reader/  
 

 

Figure 65 – Accept the Adobe Reader End User License Agreement 

Step 2: When the installation is complete, run the Adobe Reader application from the Desktop and accept the 
End User License Agreement (EULA). The EULA appears automatically upon the first launch of the application. 

 

Note The IntelliVMs will be unable to utilize Adobe Reader properly until the EULA has been accepted. 

 

Step 3: Turn off automatic updates. From the Edit menu, select Preferences. 

 

Note Updates are valuable for improving security and beneficial for the malware detection process, however 
it is essential that the MALWARE ANALYSIS APPLIANCE system administrator apply all updates 
manually so as to maintain configuration control over the malware testbed at all times. If components 
were to be allowed to update themselves automatically at random intervals, then configuration control 

Launch Adobe Reader 
from the Windows 8 

Desktop 

Click here to 
accept the EULA 

http://get.adobe.com/reader/
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becomes impractical and the administrator is never quite sure what versions of which components are 
being used for malware testing. 

 

 
Figure 66 – Opening the Preferences screen 

 
Figure 67 – Disabling automatic updates from the Preferences screen 

Select this option to 
disable automatic 

updates 

Select 
Preferences from 

the Edit Menu 
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Note Additional Adobe Reader versions: https://get.adobe.com/uk/reader/otherversions/.  

https://get.adobe.com/uk/reader/otherversions/
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6.9 Microsoft .NET Framework 3.5 SP1 
On Windows 8, .NET is part of the operating system and can be enabled under Programs and Features. 

Note EMET requires .NET 4.5. Install the correct version for your applications. 

 
Figure 68 – Turn on Microsoft .NET Framework 3.5.1 or 4 from the Windows Features checklist 

  

 

 

 Click OK to 
commit the 

change 

Check Microsoft 
.NET Framework 

3.5.1/4 

Click to display the 
Windows Features 

checklist 
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6.10 Microsoft Silverlight 
 

Step 1: Download Microsoft Silverlight from this address and navigate the installer as required. 

http://www.microsoft.com/silverlight/  

 

 
Figure 69 – Install Silverlight 

 

 

 

Important Note 

Disable the Silverlight auto update feature. See these documents for details: 

• https://www.microsoft.com/getsilverlight/resources/documentation/grouppolicysettings.aspx#AutomaticUpdate 
(HKEY_LOCAL_MACHINE\Software\Microsoft\Silverlight\UpdateMode = 2) 

• https://www.microsoft.com/getsilverlight/resources/documentation/grouppolicysettings.aspx#TrustedApplications 
(HKEY_LOCAL_MACHINE\Software\Microsoft\Silverlight\AllowInstallOfElevatedTrustApps = 1, 
HKEY_LOCAL_MACHINE\Software\Microsoft\Silverlight\AllowLaunchOfElevatedTrustApps = 1) 

 

 

 

 

 

 

 

 

 

 

 

Click here to 
begin installation 

http://www.microsoft.com/silverlight/
https://www.microsoft.com/getsilverlight/resources/documentation/grouppolicysettings.aspx#AutomaticUpdate
https://www.microsoft.com/getsilverlight/resources/documentation/grouppolicysettings.aspx#TrustedApplications
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6.11 Java 
 

Installing Java is optional. 

Step 1: Download Java from the address below and navigate to the installer as required. 

 

http://java.com/en/download/index.jsp  

   

Opt out of the Optional offer, and click Next. 

 

 
Figure 70 – Installing Java 

 

If you see the Uninstall out-of-date versions window, click Uninstall. The old version of Java will be uninstalled. 
Click Next when required. When the new version has been installed, you will see the Java Setup – Complete 
window. Click Close. 

Step 2: New Java icons appear on the programs area of the desktop now. Click Configure Java. 

 
Figure 71 – Select Configure Java   

 

On the Windows 8 
desktop, click  

Configure Java 

http://java.com/en/download/index.jsp
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Figure 72 – Disabling automatic Java updates 

Note  Download older versions from this archive: http://www.oracle.com/technetwork/java/archive-
139210.html  

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Uncheck the box to 
disable automatic 

updates 

Confirm 
automatic 

updates will 
be disabled. 

http://www.oracle.com/technetwork/java/archive-139210.html
http://www.oracle.com/technetwork/java/archive-139210.html
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6.12 Detect Unknown Exploits with EMET  
 

In the Malware Analysis appliance, the Microsoft® Enhanced Mitigation Experience Toolkit (EMET) detects unknown 
exploits. For the InteliVM to be able to collect EMET events, EMET must be installed in a Windows 7 or 8 profile, and 
properly configured. This feature is strongly recommended, but optional. 

Note Blue Coat recommends that you first deploy EMET on a new profile to verify that it works as expected.  

Step 1: Create a new Windows 8 profile. EMET is not supported on Windows XP. 

Step 2: Customize the profile, then log on using RDP.  

Step 3: Verify the .NET Framework 4.5 in installed on Windows; it is natively installed.  

Note For EMET to work with Internet Explorer 10 on Windows 8, Microsoft KB 2790907 or a more recent 
version of the Compatibility Update for Windows 8 must be installed.  

Step 4: Download EMET 5.5 and the user-guide PDF from Microsoft at: 
https://download.microsoft.com/download/8/E/E/8EEFD9FC-46B1-4A8B-9B5D-13B4365F8CA0/EMET%20Setup.msi , 
and begin the installation.  

Step 5: On the EMET Configuration Wizard page, select Use Recommended Settings, and click Finish.  

 
Figure 73 – EMET Wizard  

 

Step 6: Configure the EMET service to start automatically with no delay. Follow these steps: 

4. Click Start, and search for “services.mscaudit only. 

5. Right click the service name, and select Properties.  

https://download.microsoft.com/download/8/E/E/8EEFD9FC-46B1-4A8B-9B5D-13B4365F8CA0/EMET%20Setup.msi
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6. Change the Startup Type to Automatic. 

 
Figure 74 – Set Startup Type to Automatic 

 

The following optional steps further enhance the EMET configuration. 

A: Open the EMET GUI and configure it.  

7. Uncheck the Early Warning option on the Enhanced Mitigation Experience Toolkit window, if you don’t want 
information related to an exploitation attempt to be sent to Microsoft through the standard Windows Error 
Reporting channel. 

 
Figure 75 – Deselect Early Warning 
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8. Click Apps in the upper menu bar to open the configuration window. 

9. Set your Stop on Exploit preference. 

 
Figure 76 – Configure Stop on exploit  

 

• By default EMET is set to the Default Action Stop on exploit. This is the recommended setting for 
maximizing detection. However, this may not give you all the details about the attack, including second stage 
malware information. Blue Coat recommends maintaining this choice for maximum detection and with simpler 
configurations. 

• For full attack information (and a minimal reduction in exploit detection), select Audit only. This will let the 
exploit continue as long as possible, only observing. This results in significantly more information about 
consecutive stages of the attack. 

10. Remove any applications you don’t want to monitor, if necessary. When the Use Recommended Settings 
selection is made during installation, EMET adds and configures a set of popular applications. Click Remove 
Selected when you have highlighted an application in order to remove it. 

11. If necessary, add a new application, highlight it in the list, and enable all mitigations for that application (unless 
otherwise advised). 

Note Some mitigations are not compatible with certain applications.  Blue Coat recommends referring 
to the following link to verify your settings, and then to deselect any incompatible mitigations: 
https://support.microsoft.com/kb/2909257. 

12. Click OK to return to the EMET Toolkit main window. 

 

https://support.microsoft.com/kb/2909257
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B: Start the configured applications, then click Refresh in the EMET GUI, and verify you see a green check mark in the 
Running EMET column. 

 
Figure 77 – EMET is running  

 
Step 7: Close all applications, close the remote desktop session, then build the profile. 
 
Step 8: Verify that EMET works by running samples which will trigger EMET. The following MD5 is for reference; Blue 
Coat is unable to provide the samples, as they are malicisous. They are available on VirusTotal. 

• C32AD4D6F6A00C85E6BD152852D5D09F (SimExecFlow, and StackPivot) 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Malware Analysis Appliance | IntelliVM Profile Customization Guide                      Enhance the Windows 8 Profile 

© 2017 Blue Coat Systems, Inc. 65 of 76 Updated 16 Jun 2017 

6.13 Final Enhanced Windows 8 Profile 
 

Return to the Add or Remove Programs window in the Windows 7 Control Panel (see Section 7 – Enhancing the 
Windows 8 Profile, Step 2) and confirm that the following programs are now installed. 
 

• Adobe Flash Player (native in Windows 8) 
• Adobe Reader (optional) 
• Compatibility Pack for the 2007 Office System 
• Microsoft Office Excel Viewer 
• Microsoft Office Word Viewer 2003 
• Microsoft PowerPoint Viewer 
• Microsoft Silverlight 
• Python 2.7.6 
• EMET 5.5 (strongly recommended, optional) 

 

This configuration is the proper ending point for the base profile enhancement process. 
 

Note   Please contact your technical representative if your base profile configuration does not closely match 
Figure 78. The versions do not need to be exactly the same as depicted below, as the vendors may post 
newer versions online.  

 

 
Figure 78 – Verifying the final enhanced Windows 8 base image 
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8. Customize an Office 2010 Profile for Malware Detonation 
 

This section explains how to configure a custom Microsoft Office profile such that it detonates in the best possible way. 
This procedure is specific for Windows 7, but the principles apply to all versions of Windows. 

Note: This is a Windows 7 example. Other Windows installations will be similar.  

Avoid pitfalls by carefully following the procedures in this section: 

• Uninstall all Office Viewer applications. 
• Uninstall the Compatibility Pack for the 2007 Office system. 
• Start each program at least once to go through the initial configuration. 
• Auto-enable macro execution. 

 

Steps Overview 

These steps are performed from inside the iVM Profile on the Windows 7 virtual machine, using remote desktop protocol 
(RDP). Adjust the security settings for each program to maximize the attack surface. 

• Step 1: Configure Office 

• Step 2: Configure Word 

• Step 3: Configure MS Access 

• Step 4: Configure Excel 

• Step 5: Configure Publisher 

• Step 6: Configure PowerPoint 

• Step 7: Configure Outlook 

• Step 8: Configure Windows Media Player 

• Step 9: Configure Internet Explorer (v. 10+) 

• Step 10: Configure Enhanced Mitigation Experience Toolkit (EMET) 

 

Pre-Requisites 
• Office 2010 installed 

• EMET 5.5 installed 

 

Step 1: Configure Office 
1. Open Microsoft Word. The Activation Wizard begins. 
2. Follow the instructions to active Office. 
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3. Disable changes or updates. 

 
Figure 79 – Don’t Make Changes 
  

4. Close Word. 
 

Step 2: Configure Word 
1. Open Word. 
2. Navigate to File > Options > Trust Center > Trust Center Settings. 
3. Enable all macros and VBA developer access. 

 
Figure 80 – Trust Access  

 

4. On the Trust Center window, select File Block Settings, and deselect everything. 

5. On the Trust Center window, select Trusted Locations, and select Allow Trusted Locations on my network. 
• Add C:\Users\Admin.  

• Check Subfolders of this location are also trusted. 

 
Figure 81 – Subfolders  
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6. On the Trust Center window, select Protected View, deselect Enable Data Execution Prevention mode, and 

deselect everything else. 
7. On the Trust Center window, select Add-ins, and deselect Require Application Add-ins to be signed by Trusted 

Publisher. 
8. On the Trust Center window, select Trusted Documents, and check Allow documents on a network to be 

trusted. 
9. On the Trust Center window, select Privacy Options, and deselect Check Microsoft Office documents that are 

from or link to suspicious Web sites. 
10. Close Word. 
 

Step 3: Configure MS Access 
1. Open Access. 
2. Navigate to File > Options > Trust Center > Trust Center. 
3. Select ActiveX Settings, and  

• Tick Enable all controls without restrictions and without prompting. 
• Deselect Safe Mode. 

4. On the Trust Center window, select Macro Settings, and select Enable all macros. 

5. On the Trust Center window, select DEP Settings, and deselect Enable Data Execution Prevention Mode. 
6. On the Trust Center window, select Trusted Locations. 

• Add C:\Users\Admin.  
• Check Subfolders of this location are also trusted. 

 

 
Figure 82 – MS Access Subfolders 

 
7. On the Trust Center window, select Add-ins, and deselect Require Application Add-ins to be signed by Trusted 

Publisher. 
8. On the Trust Center window, select Trusted Documents, and check Allow documents on a network to be 

trusted. 
9. On the Trust Center window, select Privacy Options, and deselect Check Microsoft Office documents that are 

from or link to suspicious Web sites. 
10. Close Access. 
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Step 4: Configure Excel 
1. Open Excel. 
2. Navigate to File > Options > Trust Center > Trust Center. 
3. Select ActiveX Settings, and  

• Tick Enable all controls without restrictions and without prompting. 
• Deselect Safe Mode. 

4. On the Trust Center window, select Macro Settings: 

a. Select Enable all macros. 

b. Select Trust access to the VBA project object model. 

 
Figure 83 – Excel Macro Settings 
 

5. On the Trust Center window, select File Block Settings, and deselect everything. 
6. On the Trust Center window, select Trusted Locations: 

a. Add C:\Users\Admin.  
b. Check Subfolders of this location are also trusted. 

 

 
Figure 84 – Excel Trusted Locations 
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7. On the Trust Center window, select Add-ins, and deselect Require Application Add-ins to be signed by Trusted 
Publisher. 

8. On the Trust Center window, select Trusted Documents, and check Allow documents on a network to be 
trusted. 

9. On the Trust Center window, select Privacy Options, and deselect Check Microsoft Office documents that are 
from or link to suspicious Web sites. 

10. On the Trust Center window, select File Block Settings, and deselect all items in the File Type list. 
11. Close Excel. 
 

Step 5: Configure Publisher 
1. Open Publisher. 
2. Navigate to File > Options > Trust Center > Trust Center. 
3. On the Trust Center window, select Macro Settings, and select Enable all macros. 

 
Figure 85 – Publisher Macros 
 

4. On the Trust Center window, select DEP Settings, and deselect Enable Data Execution Prevention Mode. 
5. On the Trust Center window, select Add-ins, and deselect Require Application Add-ins to be signed by Trusted 

Publisher. 
6. Close Publisher. 

 

Step 6: Configure PowerPoint 
1. Open PowerPoint. 
2. Navigate to File > Options > Trust Center > Trust Center Settings. 
3. On the Trust Center window, select Macro Settings: 
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• Select Enable all macros. 

• Select Trust access to the VBA project object model. 

 
Figure 86 – PowerPoint Macros 
 

4. On the Trust Center window, select Protected View, and deselect everything. 
5. On the Trust Center window, select Trusted Locations, and select Allow Trusted Locations on my network. 

• Add C:\Users\Admin.  
• Check Subfolders of this location are also trusted. 

 
Figure 87 – PowerPoint Subfolders 
 

6. On the Trust Center window, select File Block Settings, and deselect everything. 
7. On the Trust Center window, select Add-ins, and deselect Require Application Add-ins to be signed by Trusted 

Publisher. 
8. On the Trust Center window, select Trusted Documents, and check Allow documents on a network to be 

trusted. 
9. On the Trust Center window, select Privacy Options, and deselect Check Microsoft Office documents that are 

from or link to suspicious Web sites. 
10. Close PowerPoint. 

 

Step 7: Configure Outlook 
1. Open Outlook. 
2. Proceed through the Startup wizard normally. Set up an email account or not as required. 
3. Navigate to File > Options > Trust Center > Trust Center Settings. 
4. On the Trust Center window, select Automatic Download, and deselect everything. 



Malware Analysis Appliance | IntelliVM Profile Customization Guide  Customize the Office 2010 Profile 

© 2017 Blue Coat Systems, Inc. 72 of 76 Updated 16 Jun 2017 

5. On the Trust Center window, select Macro Settings: 

 
Figure 88 – Excel Macros 
 

• Select Enable all macros. 

• Select Apply macros security settings to installed add-ons. 

6. On the Trust Center window, select Programmatic Access, and select Never warn me about suspicious activity. 
7. On the Trust Center window, select DEP Settings, and deselect Enable Data Execution Prevention Mode. 
8. Close Outlook. 
 

Step 8: Configure Windows Media Player 
1. Open Windows Media Player. 
2. Procced through the Startup wizard normally, using the recommend settings.  
3. Close Windows Media Player.  
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Step 9: Configure Internet Explorer (v. 10+) 
1. Open the computer Control Panel, and select Internet options. 
2. Set the Home page to about:blank. 

 
Figure 89 – IE Home Page 
 

3. Optional. You may enable items on the Internet Properties window. To do so, select Security > Internet Zone > 
Settings. The default settings should be fine. 

4. Click OK to save your settings, and close the Control Panel.  
 

Step 10: Configure Enhanced Mitigation Experience Toolkit (EMET) 
1. Open EMET. 
2. From Apps > Default action > Stop On Exploit, select from their locations on the hard disk/s: 

• Adobe Acrobat 
• All Office programs (six) 

• Windows Media Player 

• Internet Explorer 

3. On the on the Enhanced Mitigation Experience Toolkit window, click Apps to open the Application Configuration 
window, and enable all metrics for all programs. 

4. Close EMET and all other programs. 
5. Open EMET. 
6. Open two or three programs, and verify each shows as “Running EMET” on the EMET window under Running 

Processes.   
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Figure 90 – Programs Running EMET 
 

Step 11: Verify Installations 
1. Finalize and Build the Profile. 

2. Verify EMET works: 

• Get sample C32AD4D6F6A00C85E6BD152852D5D09F. 

• Submit the sample to the Malware Analysis appliance. 

• Verify that EMET results are shown in the task results. 

 
Figure 91 – Programs Running EMET 

 

3. Verify macros have been enabled, in Word, and elsewhere as required. 

• Get sample 4a132e0c7a110968d3aeac60c744b05a 

• Submit the sample to the Malware Analysis appliance. 
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• Verify that a batch file is written and that power shell commands are executed. 

 
Figure 92 – Executed Commands 

 

Related Documentation 
• Installing EMET; see Error! Reference source not found.. 

• Macro configuration in Microsoft Office: https://support.office.com/en-us/article/Enable-or-disable-macros-in-
Office-documents-7b4fdd2e-174f-47e2-9611-9efe4f860b12 

 

  

https://support.office.com/en-us/article/Enable-or-disable-macros-in-Office-documents-7b4fdd2e-174f-47e2-9611-9efe4f860b12
https://support.office.com/en-us/article/Enable-or-disable-macros-in-Office-documents-7b4fdd2e-174f-47e2-9611-9efe4f860b12
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