
Achieving Software License Compliance with EPM Solutions  

Description As a continuation of the standard demonstration and POC guidance 
provided in the prerequisite collateral, this Hands On Lab will cover the 
demonstration of various customer use cases for Asset Management 
Suite with a focus on Software License Management, Compliance and 
administrative functions and how they solve real world challenges. 

  

At the end of this lab, you 
should be able to 

 Demonstrate application metering policies and understand the 
various levels of tracking and control . 

 Confidently demonstrate or provide proof of concept services 
using software license compliance methodologies. 

 Demonstrate custom procedures like managing software 
product editions 

 Understand the Software Asset Management reports available  

  

Notes  A brief presentation will introduce this lab session and discuss 
key concepts. 

 Feel free to follow the lab using the instructions on the 
following pages. You can optionally perform this lab at your 
own pace. 

 Be sure to ask your instructor any questions you may have.  

 Thank you for coming to our lab session. 
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Software License Management 

The Symantec Management Console contains several portals that serve as landing pages or dashboards.  
When on the Software License Portal, AMS can track all the software licenses.  Conceptually, license 
compliance is a straightforward, simple concept, it serves the following functions:   

 Report on installed licenses 

 Keep track of what is purchased vs. what is installed. 

 Never install more than you buy. 

 Never buy more than you need. 

License compliance is a challenging endeavor, as there is no standard, industry-wide method for vendors 
to denote the presence of an application.  Software procurement is often de-centralized, making it 
difficult to know exactly what is purchased. 

In this lab we will present the Symantec Asset Management solution’s approach to software license 
compliance.  Upon completion of this lab you will understand how to create a license compliance 
calculation for a particular software title. 

Basic Terms 

 Software Catalog:  The Software Catalog is a centralized model of the software that is 
known in your organization, regardless of where the software is installed. The Software 
Catalog does not contain any software. Instead, it contains the data that describes the 
software. If a package is associated with the software, the Software Catalog also points 
to the source of the package file. 

 Example: The software catalog will hold information about installed software as 
well as yet-to-be-deployed applications/releases/patches. 

 Software Library:  The Software Library is the physical directory location of the package 
files that are associated with the software in the Software Catalog. Because the 
Software Library is a repository of the definitive, authorized versions of the packages, 
you should restrict access to the library to maintain its integrity. 

 Example: the MSI file for the installation of OpenProject would reside in the 
software library, and perhaps be used by Symantec Software Distribution to 
install the application on client computers. 

 Software Resource:  A software resource is the meta data that describes a specific 
instance of a software product. A software resource provides a common way to describe 
the software so that all software-related actions can identify it accurately. 

 Example: The data of all files installed when OpenProject is installed (dll’s, exe’s, 
etc.) represents a software resource.   

 Software Product: A grouping of one or more software resources. Use of the software 
product is optional in the Symantec Management Platform, but required for software 
license compliance. 

 Example: For example, you create a software product named Norton Internet 
Security 2008. Then you assign that product to separate software resources for 
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Norton Internet Security 2008 - English, Norton Internet Security 2008 - English 
SP1, Norton Internet Security 2008 -French, and so on. 

 Software Purchase: The record of the rights purchased for a particular software title.  
Purchases may reflect procurement events or organizational events. 

 Example: PO 12345 for 10 copies of Microsoft Visio, “purchase” of 500 copies of 
Microsoft Visio due to acquisition of company ABC, “purchase” of -500 copies of 
Microsoft Visio to reflect divesture  

 Software License:  A contract type within Symantec Asset Management used to relate 
software purchases to a software product. 

 Master License Agreement:  A parent-child relationship among software licenses. This 
agreement typically coincides with an actual agreement your company has.  

 Example: A Master License Agreement “Microsoft Win32 Applications” could 
have child software licenses “Microsoft Office”, “Microsoft Visio”, “Microsoft 
Visual Basic”, etc. 

 Virtual License Agreement:  A parent-child relationship among software licenses, not 
typically corresponding to an actual contractual agreement. 

 Example: My role is to manage AutoCAD and Great Plains within my company. 
“My Special Virtual Agreement” is a parent license with child software license 
for AutoCAD and Great Plains. 

Lab Exercise 1:  Application Metering and Control 

This section will demonstrate the monitoring of software utilization across the enterprise and the 
methods used to restrict what and by whom particular software can be run on a computer as a means of 
avoiding risks.  Inventory Solution provides the methods that allow you to perform the following tasks 
on your managed computers: 

• Track usage of the managed software at the software product, component, and version level 
by enabling the software-based usage tracking option. This task is the primary method to use for 
the majority of software products.  

• Meter the use and control the availability of applications by running predefined or custom 
application metering policies. The best practice is to use this task only if you need to meter start, 
stop, and denial events for applications at the file level. 

• Deny multiple applications from running by configuring the predefined Blacklisted Applications 
policy or running custom application metering policies. To track usage of managed software 
products, meter, and deny applications, you must have the Symantec Management Agent, 
Inventory Plug-in, and Application Metering Plug-in installed on target computers. 

Application metering plug-in Configuration 

To install a plug-in, you configure the policy that installs the plug-in on target computers. You select the 
group of computers on which the policy runs and when it runs. If you choose a group that contains a 
computer that already has the plug-in installed, the task is ignored on that computer. When the policy is 
enabled, any new computer that is a member of the target group automatically has the plug-in installed 
on it. 
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By default, no plug-in installation policies are enabled. If you install Inventory Solution for the first time, 
you must manually enable the policies to install the Inventory and Application Metering Plug-ins.  Before 
performing this task, you must install the Symantec Management Agent on target computers.  

Application Metering Policy Methods  

Method 1: Within the Software Product  

1. Make sure the DC, SMP, Win7 and SD7 Virtual Machines are powered on. 

2. Switch to the SMP virtual machine. 

3. Launch the Symantec Management Console by double-clicking the Symantec Management 
Console shortcut located on the desktop. The Symantec Management Console loads. 

4. Maximize the Symantec Management Console so that it fills the screen. 

5. Click Manage |Software from the main console menu.  The Software Management interface 
appears. 

6. Expand and select Deliverable Software > Software Products from the left pane. 

7. The FileZilla Client 3.3.5.1 managed product is displayed in the middle pane. 

8. Double Click the FileZilla Client 3.3.5.1 Software Product.  The product details are displayed. 

9. Select the “Meter / track usage” tab. 

Note: Notice that one executable has been dynamically assigned to the Software Product and another 
has not. In the real-world, this field could be left blank, and once a full inventory had been run on a 
system with the software installed (and the NS.Nightly task had been executed) the executable would 
dynamically be added.  For the sake of demonstration, we will manually make the executable 
associations. 

10. Select the FileZilla 3.3.5.1 win32 entry in the list of software and click the Add Program link next 
to it.  The Add Program interface displays. 

11. Notice how there are no software items in the listing.  This is because the software inventory 
policy has not run on the Win7 VM and it has not returned the information on FileZilla 3.3.5.1 
Win32. 

12. Type FileZilla in the Available Programs field and check the Show All Program Files box. 

13. You will notice that a few FileZilla entries appear. 

14. Select the FileZilla.exe version 3,3,5,1 entry and press the right arrow to insert it in the 
associated programs list. 
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Note: The files listed have been gathered from a cached .msi through the inventory process. If a cached 
.msi file is not available, you can mark the “Show all program files” checkbox, to display all files detected 
using the inventory process.   

15. Click OK.   The Add Program interface is closed. 

16. Verify that the selected executable is listed for both FileZilla entries. 

17. Check the Turn on metering checkbox.  The associated file(s) will be monitored to determine 
application usage.  

 

18. Notice the field at the bottom of the tab which indicates in which time frame a product must be 
used in order to be determined as used. The default time period is 90 days. 

Creating a Software License and Purchase from within the Software Product  

1. Select the Licenses tab. 

Notice that there is a check box for Licensable Product.  If the software application falls under a site 
type license or if there is no license required, then unchecking that box will not show the product as out 
of compliance. 

2. Mark the Licensable Product check box. 

3. Press the Add License Purchase button. 

4. Under the Software License section change the Name to LAB FileZilla Client 3.3.5.1 License. 

5. Select Per Installed computer. 

6. Enter 1500 in the Maintenance Renewal Cost field. 

7. Enter 150 in the Support Renewal Cost field. 

NOTE: This is the Software License Object. In Symantec Asset management Solution, the License Type 
and costs of the software purchases are dictated by a license object. If multiple licenses on a single 
product are created, the costs are summed. 

8. Change the software purchase name to LAB FileZilla Client 3.3.5.1 Purchase. 

9. Change the Date to September 30, 2014. 

10. Enter 10 in Quantity. 

11. Enter 50 in Total Cost. 
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12. Change the Accounting Code to Purchase Cost in the drop down list. 

 

13. Press Add 

14. Click OK.  The Software Product interface is closed. 

NOTE: This is the Purchase Object. In Symantec Asset Management Solution, the quantity of software 
purchases are dictated by a purchase object. If multiple purchases on a single product are created, the 
quantity is summed. 

After you save a software product with its associated software purchase and software license 
information, the ability to view and edit the full records of software license and software purchase 
within the Asset Management Suite pages become available. 
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Method 2: Creating an Application Metering Policy  

Inventory Solution lets you deny one or more applications from running by configuring the predefined 
Blacklisted Applications policy or creating custom Application Metering Policies. When you configure 
an application metering policy, you define the applications you want to deny by creating new or editing 
the existing application definitions.  

When you configure an application metering policy, you define the applications you want to meter by 
creating application definitions. You specify a list of application definitions for every application 
metering policy. When you define application definitions, you specify a set of definition details about 
the application. For each metering policy, you can have one or more applications defined. 

In our Lab scenario, we would like to prevent the execution of P2P File sharing software in our 
environment and be able to specifically deny the uTorrent application from running, record the denial 
events and bring up a warning to the user.  Utorrent has been previously installed on the Win7 Virtual 
Machine.  

1. Switch to the SMP virtual machine 

2. The following picture shows the file details that can be obtained by right clicking on the 
utorrent.exe file and choosing Properties. Notice that we can find product name, version and 
many other attributes that would allow us to pinpoint the specific software release. 

 

By knowing the file details, we can plan our metering policy to meter this application and ensure 
that monitoring or denial policies on the software are retained. 

3. Launch the Symantec Management Console by double-clicking the “Symantec Management 
Console” shortcut located on the desktop. The Symantec Management Console loads. 

4. Maximize the Symantec Management Console so that it fills the screen. 

5. Click Manage |Policies in the main console menu.  The Policy Management interface appears. 

6. Browse to the Software > Application Metering > Samples folder 

7. Right Click on the Samples folder and choose New > Application metering policy 

8. At the top of the right pane, change the policy Name, “New Application metering policy” to 
“uTorrent metering policy” 

9. On the policy page, on the Software tab, click the Add drop-down list. 
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10. Click Rule, the Add Application Rule dialog box opens.   

Note: The “Add > Rule” Option provides a “Rule tab” so you can manually create your own application 
definitions. The application definition detail fields are case-sensitive. This method is useful for defining 
the software applications that are not already installed on computers on your network. For example, 
you can deny applications such as games or P2P file-sharing programs before they are ever used. 

Note: The “Add > Software” method is useful to quickly include a known software application without 
manually configuring application definition details. However, the known application definition details 
may be too specific. For example, it is important to note that application definitions may be version-
specific, especially those using known software application details. If you use a known application from 
the Software drop-down menu, you may want to edit application definition details to meet your needs. 

In this case, the “Add > Software” method would not work to populate the details from inventory 
because uTorrent is installed to a hidden location in the user’s profile. 

11. Enter uTorrent Rule in the Definition Name field. 

12. Enter uTorrent.exe in the File Name field. 

 

Notice that there are other file attributes we can include on this page.  In our case, we only want 
to target any executable file named “uTorrent.exe”.  

If you wanted to meter a specific version of “utorrent.exe” you would fill in more fields to 
pinpoint the exact match.  

13. Click OK. 

14. Select the Options Tab. 

15. Notice the options available to you.   This setting provides the policy with the ability to apply 
combinations of the following: 

 Allow the uTorrent to run 

 Deny uTorrent from running 

 Deny uTorrent from running during a specified time 

 Record uTorrent usage events 
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When the Record usage events option is enabled, and a user of a managed computer starts or stops a 
metered application, an event is generated. When a user tries to use an application whose metering 
policy denies its use, a denial event is generated. Every start event has a stop event or becomes a denial 
event.  After the events are sent to the CMDB, you can generate reports to view this data 

In our case we would like to deny the application from running, record the denial events and bring up a 
warning to the user.    

16. Configure the options as follows: 

a. Select Deny from running. 

b. Select Record Usage Events , Deny , Daily. 

c. Mark Inform User. 

17. Scroll to the top of the policy, and click the Off button, and select On from the resulting menu. 

18. Under the Add Computer, group of computers or user section, select the Windows Computers 
with Application Metering Plug-in item. 

 

19. Press the Pencil (Edit) icon. 

20. Press the Update Results button to refresh the list. 

21. Press Cancel. 

22. Click Save Changes on the policy page. 

You have now created an Application Metering Policy that will record the application execution and 
denial events, not allow it to run, and will display a message to the user warning them of its use. 

23. Switch to the Win7 Virtual Machine. 

24. Double-click on the uTorrent application Icon on the desktop. 

25. Once it is opened, close the application using the menu option File > Exit as it may still be active 
in the tray. 

26. Open the Symantec Management Agent on the task bar by double-clicking it. 

27. Press the Update Configuration button at the top of the window. 

28. Press the Basic Inventory button. 

29. Close the Symantec Management Agent windows 

30. Run uTorrent by clicking the icon on the desktop 

31. Notice the behavior.  You should be denied from running the application 
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Lab Exercise 2: Software License Compliance Methodology 

In this exercise the Administrator has been instructed to account for all Microsoft SQL Server 2008 
installations and compare them with the purchased quantities to produce a compliance report for the 
accounting department.   

In order for software license compliance data to be calculated, there are 3 items that need to be 
associated with each other: 

 Software Product 

 Software License 

 Software Purchase 

The Administrator notices that there is a Software Product created for Microsoft SQL Server 2008 and it 
shows the installed endpoints, but there are no associated Software Licenses or Purchases. 

Review the Software Product 

1. Open the Console and navigate to Manage | Software. The Software Items appear on the 
Left and the details appear on the right. 

2. In the left pane, expand and select Favorites > Installed Products. 

3. In the middle pane, locate and select Microsoft SQL Server 2008.  The details for this 
software appear on the right  

4. Notice that the graph shows that Microsoft SQL Server 2008 is over deployed by 5 licenses 
and Active licenses is 0.    

 

5. Also Notice that there are 5 installations of Microsoft SQL Server 2008 clearly indicated 
below the graph in the Computers with Software installed section. 

6. This quick review of the details shows that the Microsoft SQL Server 2008 product does not 
have any licenses or purchases associated with it, and they need to be created before a 
complete compliance calculation can be performed. 
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Create a Software Purchase and License  

There are two ways to create a license and purchase for a Software product; through the Software 
License Portal and within the Software Product.   They are utilized in different ways: 

 If you simply need to create them and have basic information available, use the options within 

the Software Product  

 If you have detailed information about them, use the Software Licensing Portal and create them 

The Software Licensing Portal is accessed through Home | Service & Asset Management | Software 
Licensing.   

 

To create the Software Purchase, 
you would simply right click on 
Software Purchase and select 
Create Software License 

 

To create the Software License, 
you would simply right click on 
Software License and select 
Create Software License 

 

 

In this exercise, the Administrator has some basic information available to create the Purchase and 
License quickly within the Software Product itself. 

1. Double-click on the Microsoft SQL Server 2008 software product in the middle pane.  The 
Software Product window appears. 

2. Select the Licenses tab. 

3. Make sure the Licensable Product check box is marked. 

4. Press the Add License Purchase button.  The Add License Purchase window appears 

5. Notice that there is a Software License and Software Purchase section.  Also notice that it 
automatically enters names for them. 

6. Modify the following fields under Software License: 

a. Name:  LAB Microsoft SQL Server 2008 License 

b. Comments:  This is a SQL 2008 License 

c. Type: Per Installed Computer 

d. Maintenance Renewal Cost:  10000 

e. Support Renewal Cost:  2000 

7. Modify the following fields under Software Purchase: 

a. Name:  LAB Microsoft SQL Server 2008 Purchase 
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b. Description:  This is a SQL 2008 Purchase 

c. Date: Enter Today’s Date 

d. Quantity:  10 

e. Total Cost:  50000 

f. Accounting Code: Purchase Cost 

 

8. Press the Add button. 

9. Your Licenses tab should now contain the following information: 

 

10. Press the OK button to close the Software Product window. 

11. Double Click on the Microsoft SQL Server 2008 software product in the middle pane.  The 
Software Product window appears. 

12. Select the Licenses tab. 

13. Expand the LAB Microsoft SQL Server 2008 License item in the list. 
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14. Select the Lab Microsoft SQL Server 2008 Purchase item in the list. 

15. Press the Edit (Pencil) Icon next to the License red X 

16. Notice the Edit full software license contract and Edit full software license purchase links.  
These links allow you to go directly to the License and Purchase and edit the full details.  In 
this exercise we will show you where to go in the Software License Portal to edit the same 
details. 

17. Press Cancel to close the Add License Purchase window. 

18. Press OK to close the Software Product window. 

19. Select the Microsoft SQL Server 2008 software product in the middle pane.  Notice that the 
graph has changed the values for Total Licenses purchased and that the software is now 
under deployed by 5 licenses.   

 

20. The Administrator has now met the requirements of Software Compliance for this software 
product. 

Editing the Software License  

The Administrator has found that there are three (3) installations of Microsoft SQL Server 2008 installed 
in a secure lab on a remote site that does not have a Symantec Management Agent installed and does 
not participate in endpoint management inventory activities.  The three installations must be accounted 
for and entered into the LAB Microsoft SQL Server 2008 software license to ensure accuracy. 

1. Open the Console and navigate to Home | Service and Asset Management | Software 
Licensing. The Software Items appear on the left and the details appear on the right. 

2. In the left pane select the Software Licensing > Software License item. 

3. In the right pane, Enter LAB in the search field at the top right side.  You should see the LAB 
Microsoft SQL Server 2008 software license listed. 

4. Double-click on the LAB Microsoft SQL Server 2008 software license.  The Software License 
edit window will appear. 

5. Enter the following details to complete the Software License: 

a. Under Non-Inventoried Installs: 

i. Press the Add button. 

ii. Type 3 in the Count field. 

iii. Type Secure Lab Installs in the Description field. 



  15 of 35 

iv. Choose “In Use” from the Type field. 

v. Press the Assigned field, and press the ellipsis (…) button at the right. 

vi. Choose Brad Johnson from the user list, then press OK. 

 

b. Under Standard Contract Information: 

i. Description:  LAB Microsoft SQL 2008 License 

ii. Start Date:  9/7/2014 

iii. End Date:  9/7/2017 

iv. Status:  Active 

v. Approved:  Yes (Checked) 

c. Find Covered Software Product on the page.  Notice that the Software Product called 
Microsoft SQL Server 2008 is entered here – this is the association of Software License to 
Software Product. 

d. Find Software Purchases on the page.  Notice that the Software Purchase called LAB 
Microsoft SQL Server 2008 Purchase is entered here – this is the association of Software 
License to Software Purchase. 

e. Press OK to close the Software License. 

f. Return to the Software License console page and press the Run button at the top of the 
right pane. 

g. Notice that the information you entered appears in the list: 

 

 

 

 

 

Understanding “Borrowed” and “Donated” Software Licenses  

Some Licensing contracts such as Microsoft Enterprise or Select allow you to use licenses from the 
version below the one currently being sold.  These scenarios can be fulfilled by the following features in 
Asset Management Suite: 

 Borrowed: where a quantity of software licenses where a quantity of licenses have been 
borrowed from another software license. This is usually done to cover down-grade rights where 
a newer version license is used for an older version. 
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 Donated: where a quantity of licenses has been donated to another software license. This is 
usually done to cover down-grade rights where a newer version license is used for an older 
version. 

NOTE:  The software license compliance graphic in the enhanced views does not include non-
inventoried, borrowed, or upgraded licenses. It only shows the count of purchased licenses as compared 
to the count of software product installs detected in the environment. 

In this lab scenario the Administrator would like to “Borrow” 2 licenses from the Microsoft SQL Server 
2005 license and apply them to a Microsoft SQL Server 2008 license.  The administrator also notices that 
the Microsoft SQL Server 2005 software product does not have License details included. We will start by 
quickly filling in some information on the Microsoft SQL Server 2005 Software Product: 

1. Open the console and navigate to Manage | Software. 

2. In the left pane, select Favorites > Installed Products. 

3. Select the Microsoft SQL Server 2005 software product in the middle pane. 

4. Select the Manage Licenses button on the license usage report. 

 

This is yet another way you can quickly access software license information. 

5. Make sure the “Licensable Product” check box is selected. 

6. Press the Add License Purchase button.  The Add License Purchase window appears 

7. Modify the following fields under Software Purchase: 

a. Date: Enter Today’s Date 

b. Quantity:  8 

c. Total Cost:  25000 

d. Accounting Code: Purchase Cost 

 

8. Press the Add button 

9. Press the OK button to close the Software Product window. 

10. The report shows that you are using 6 out of the 8 available MS SQL Server 2005 licenses 
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11. We will start by taking a look at the Software Compliance report to determine the current 
status of MS SQL Server 2005 and 2008. 

12. In the Console, navigate to Home | Service and Asset Management | Software Licensing. 

13. In the left pane expand the Software Licensing > Service and Asset Management Reports > 
Contract Management > Software Licensing folder. 

14. Select the Software Product Licensing Compliance report.  The report will appear in the 
right pane.  This report will show all license compliance summaries in tabular form so you 
can readily see which titles are close to or beyond overages 

15. Enter Microsoft SQL in the search field and notice the results only list Microsoft SQL 
products 

 

 

 

 

 

 

 

16. Notice that the report does not show the latest results and only accounts for the 5 installed 
applications and not the 10 purchases or 3 non-inventoried installations for MS SQL Server 
2008, as well as the 8 MS SQL 2005 Server licenses you just added. 

You may notice from time to time that that the Purchased or Non-Inventoried count has not appeared 
in some of your compliance reports.  This is a result of the NS.Software Product Licensing Recalculation 
Schedule not being run after the creation of new software licenses or purchases.  This scheduled task is 
automatically run every night at 1:00AM by default, but we can initiate it to ensure that our totals are 
displayed in the next section of the lab. 

17. In Windows, Select  Start > Administrative Tools > Task Scheduler 

18. Locate the NS.Software Product Licensing Recalculation… task under the Task Scheduler 
Library Folder 
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19. Right Click on the task and choose Run 

20. Wait until it finishes processing. It should only take about a minute. (You can refresh the 
display to check.) 

21. Return to the Software Product Licensing Compliance report, and press the Run button on 
the right pane.  The report will appear in the right pane 

 

 

 

 

 

 

 

22. You will now notice that it shows the 10 purchased licenses, 5 installed licenses and 3 non-
inventoried licenses for a remainder of 2 available Microsoft SQL Server 2008 Licenses.  It 
also now includes the 8 purchased and 6 installed Microsoft SQL Server 2005 licenses with a 
remainder of 2 licenses available for use. 

23. We will now demonstrate the use of borrowed and donated licenses.   

24. In the left pane, select Software Licensing > oftware License. 

25. Enter Microsoft SQL in the search field in the right pane 

26. This should show the 2 Microsoft SQL Server licenses: 

 

27. Double-click on the Microsoft SQL Server 2008 license. 

28. Locate the Software License Sharing section of the page. 

29. Press the Add button.  The Select a Resource page appears. 

30. Select the Microsoft SQL Server 2005 License on the list and press OK. 

31. Enter 2 in the Number field to indicate that you are “Borrowing” 2 licenses. 
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32. Press the Apply button on the bottom of the page. 

33. Return to the Software License Sharing section of the page and select the Microsoft SQL 
Server 2005 entry. 

34. Press the Lookup button.  Notice that it opens the Microsoft SQL Server 2005 license for 
your review. 

35. Press OK on both of the Microsoft SQL Server licenses to close them. 

36. In Windows, Select  Start > Administrative Tools > Task Scheduler  

37. Locate the NS.Software Product Licensing Recalculation… task under the Task Scheduler 
Library Folder 

 

38. Right Click on the task and choose Run 

39. Wait until it finishes processing. It should only take about a minute. (You can refresh the 
display to check.) 

40. In the console, in the left pane, expand the Software Licensing > Service and Asset 
Management Reports > Contract Management > Software Licensing folder. 

41. Select the Software Product Licensing Compliance report.  The report will appear on the 
right pane.  This report will show all license compliance summaries in tabular form so you 
can readily see which titles are close to or beyond overages. 

42. Enter Microsoft SQL in the search field and notice the results only list Microsoft SQL 
products. 

43. Review the report and notice that the SQL 2008 license has 2 under the Borrowed column 
and the MS SQL 2005 license has 2 under the Donated column and that the compliance for 
both products has been adjusted: 
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44. Keep this report open for the next part of this lab. 

Viewing Additional Compliance Data for our Software License 

1. Right-click on the Microsoft SQL Server 2008 product in the report, and select Resource 
Manager. 

2. Select Summaries > Software Product License Summary from the top menu.  You will see a 
summary of our purchases, borrowed, donated and non-inventoried installs.   

 

Upgrading or Renewing a Software License 

In Asset Management Suite, software license contracts are linked to software products in the software 
catalog.  Software purchases are linked to the software license contract.  When you do an upgrade, you 
are going to be working with a different software product for the new version.  This then requires a new 
software contract and the software purchases that go with the new version of the software. 

So you don't lose your audit trail with the old version and purchases of that version of the software, you 
need to create a new software license for the new version of the software.  To assist you with the 
process of creating the new software license contract, AMS comes with a wizard which you can access 
through right-clicking on the software license for the old version of the application you are upgrading. 

When a software license expires, you can upgrade or renew it. Note that you can upgrade or renew a 
software license only once. After you upgrade or renew the software license, the context menu options 
Upgrade Software License and Renew Software License do not appear. 

You can renew a software license when the following conditions are met: 

 For the software license, under Contract Details, the Renewable option is checked. 

 The software license is not expired. 

 The software license is associated with a software purchase that has quantity data specified. 

In this exercise the Administrator has been asked to upgrade their Adobe Reader 9 licenses to newly 
purchased Adobe Reader 9.4 licenses.   
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1. Open the Symantec Management Console. 

2. Select Manage | Software in the main console menu. 

3. In the left pane, select Favorites > Installed Products. 

4. In the middle pane, double-click on the the Adobe Reader 9 software product. 

5. Select the Licenses tab. 

6. Mark the Licensable Product check box. 

7. Press the Add License Purchase button. 

8. Configure the Add License Purchase page with the following settings, but use today’s date: 

 

 

 

 

 

 

 

 

 

9. Press Add 

10. Click OK.  The Software Product interface is closed.  

11. The Administrator has just received a software purchase of 100 Adobe Reader 9.4 licenses.  This 
needs to be entered into the console.  

12. Open the Console and navigate to Home | Service and Asset Management | Software 
Licensing. The Software Items appear on the Left and the details appear on the right. 

13. On the left pane, right click on the Software Purchase item and select Create Software 
Purchase. 
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14. Configure the software purchase as seen below using today’s date: 

 

15. Press OK.  You are now prepared to upgrade the Adobe Reader 9 to 9.4 licenses.  

16. Go to Home|Service and Asset Management | Software Licensing from the main console menu 

17. Click Software License in the left pane 

18. In the right pane, right-click on the Adobe Reader 9, and then click Contract Functions > 
Upgrade Software License.  The Upgrade an existing software license page, 
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19. In the Upgrade an existing software license page, complete the following configuration using 
today’s date: 

 

20. Press  OK. 

21. Go to Home|Service and Asset Management | Software Licensing from the main console menu 

22. Click Software License in the left pane 

23. In the right pane, double click on the LAB Adobe Reader 9.4 License  

24. Scroll down to the  Former Software License section and notice that the Adobe Reader 9.4 
version is linked to the older version of Adobe Reader. 

 

25. Press Cancel when you finish reviewing. 

 

 

LAB Adobe Reader 9.4 License 
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Software with an expiration date is rare; usually applications have perpetual licenses for the version 
that was purchased.  Many customers use the expiration field for the date the maintenance is going 
to expire.  The renew software license right-click action is intended for renewing the software, not 
the maintenance.  

You might be able to use the renewal process and the wizard to record the maintenance renewal 
but it is very important to test that the compliance calculations are correct.  Symantec did not 
intend it to be used that way and no test cases were run on that scenario.   

The compliance report does not include software purchase quantities if the software license 
contract they are associated to is expired. 

The renewal wizard is the same as the upgrade wizard with one exception.  You do not link it to a 
new software product because the new software license contract the wizard is creating will be 
linked to the same software product as the original software license contract. 

In this exercise the Administrator has been asked to renew their Adobe Photoshop 7 licenses 

1. Go to Home|Service and Asset Management | Software Licensing from the main console menu 

2. Click Software License in the left pane 

3. In the right pane, right-click on the Adobe Photoshop 7 license, and then click Contract 
Functions > Renew Software License.  The Renew an existing software license page. 

4. In the Renew an existing software license page, Press the Create New Software Purchase link 

5. A new Software Purchase page appears – Configure with the following settings using today’s 
date: 

 

6. Press OK to complete the Software Purchase. 
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7. Return to the Renew an existing software license page complete the following configuration: 

 

8. Click OK to complete the renewal process. 

9. Click Software License in the left pane. 

10. In the right pane, click Run to refresh the report. 

11. In the right pane, double click on the LAB Adobe Photoshop 7 Renewal license. 

12. Scroll down to the  Former Software License section and notice that the Adobe PhotoShop 7.0 
Renewalis linked to the original Adobe Photoshop License.  

 

13. Press Cancel when you finish reviewing. 

Viewing Automation Policies related to License Compliance 

Automation policies are system-defined, or administrator-defined, sets of rules that govern the 
execution of automated actions. Examples of automated actions include running a report using the 
parameters that were obtained from the policy, sending an alert to the administrator, and executing a 
command or running a task on managed computers 

LAB Adobe PhotoShop 7 Renewal 
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Automation policies may be run on a schedule or triggered by Notification Server messages. The policy 
determines when an action should start, and who or what should be notified of the results. Automation 
policies are run on the Notification Server computer, so are not concerned with agent-related activity on 
managed computers. However, some automation policies may be triggered by messages which are 
generated by agent activity. 

In this scenario we will review the built-in Software Compliance automation policies 

3. In the console main menu, select  Manage | Automation Policies 

4. Select Software Product with license out of compliance in the left pane.   

The logic of this Policy can be simply explained by the following statement: 

 Run a query every week that lists all Software Products that are out of compliance. 

 Send an email to a specified user that contains the results of the query. 

5. Press the Test Automation Policy button on the left pane. 

6. Open Mozilla Thunderbird by clicking the icon on the desktop. 

7. Double-click on the email named “Software product with license out of compliance”. 

You should see the following results:  Notice that all of the Software Products are out of 
compliance in the list. 

 

8. In the console main menu, select  Manage | Automation Policies. 

9. Select Software Product with license within 10% of compliance.  This policy will send an 
email alert when the license is within 10% of being over. 

The logic of this Policy can be simply explained by the following statement: 

 Run a Query that lists all Software Products that are within 10% of compliance. 

 Send an Email to a specified user that contains the results of the Query. 

10. Press the Test Automation Policy button on the left pane. 

11. Return to  Mozilla Thunderbird, click Get Mail and then double-click on the email named 
“Software product with license within 10% of compliance” 

12. You should see the following results: Notice that your MS SQL Server 2005 Product appears 
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Lab Exercise 3: Managing Software Product Editions 

Many customers have asked how they can track multiple editions (Standard, Enterprise, Core, etc.,) of 
software products within the CMDB.  The inventory and software management solutions generally 
merge all editions into a single representative software product.  

By using the Targeted Software Inventory (TSI) function of Inventory Solution, you can identify and 
create products that can be attached to configured licenses to present compliance data in a consistent 
fashion.   Compliance data for the software installation can be reviewed holistically and contract and 
license key data associated with software installations can be recorded in a standardized way. 

In this exercise we will walk through the steps that can be taken to precisely locate and track true 
installations of Microsoft SQL Server 2008 R2 Enterprise Edition without using the Software Data 
Provider and Inventory Data Classes that only represent all editions of MS SQL Server 2008 into a single 
Software Product.   

With this software product item we can then apply software asset management associations to ensure 
the proper accounting of this specific version & edition of MS SQL Server.  This method can apply to any 
edition or version of software you wish to track and apply to software license compliance details. 

NOTE:  Be careful typing in this exercise – All items must be typed exactly as shown 

Create the Software Release You Wish To Track 

1. Switch to the SMP Virtual Machine 

2. Double click the Symantec Management Console Icon on the Desktop. 

3. Select Manage | Software from the Main Menu. 

4. In the left pane, select Favorites > Installed Products. 

5. Select Microsoft SQL Server 2008 in the middle pane.  Notice that it shows that a few 
computers have this installed, but there is no way of telling which installations are Datacenter, 
Enterprise, and Standard or even if it is an R2 version. 

6. Select Manage | Software Catalog in the main menu. 

7. Under the Newly discovered\undefined software pane, choose +ADD then select Software 
Release. 

8. Replace the Untitled name with Microsoft SQL Server 2008 R2 Enterprise Edition in the top left 
section. 

9. Under the Properties tab, type 10.51 in the Version field (Indicates 2008 R2 Version). 

10. Press the Browse link.  The Select Company window appears. 
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11. Type Microsoft in the search field on the right, select Microsoft, and press OK. 

 

12. Under the Rules tab, in the Detection Rule area, press the *New link.  The Create Rule window 
appears. 

13. Enter MSSQL2008R2ENT Reg Rule in the Name field. 

14. Press the + button and select Standard Rule > Registry Key Value.  The registry key value 
window opens. 

15. Enter the following values: 

a. Registry Key Path:   

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\Setup 

b. Registry Entry:  Version 

c. Registry value:   10.51. 

d. Match:  Substring 

16. Press OK. 

17. Press the + button and select Standard Rule > Registry Key Value.  The registry key value 
window appears. 

18. Enter the following values: 

a. Registry Key Path:   

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\Setup 

b. Registry Entry:  Edition 

c. Registry value:   Enterprise Edition 

d. Match:  Substring 

19. Press OK. 
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20. The completed rule should look like this: 

 

21. Press OK to close the Create Rule window. 

22. Press OK to close the Software Release window. 

23. Press Close to close the Software Catalog window.  

At this point, the Microsoft SQL Server 2008 R2 Enterprise Edition software release is not 
manageable within the Software Catalog.  A policy must be created and run on a system for the 
Detection Rule to apply. 

Create the Targeted Software Inventory Policy 

Targeted software inventory feature determines whether specific software is installed on managed 
computers. To find the software, it uses the software resource and detection rule information that is 
defined in the Software Catalog.  

1. Select Manage | Policies in the main menu. 

2. Expand the Discovery and Inventory Folder in the right pane. 

3. Right Click on the Targeted Software Inventory folder and choose New > Targeted Software 
Inventory.  It may take a few seconds to load. 

4. Name the policy Detection check for MSSQL2008R2ENT-TSI 

5. Press the Select Software button in the Software to inventory section. 

6. Enter Enterprise Edition in the search box in the left pane. 

7. Choose the Microsoft SQL Server 2008 R2 Enterprise Edition software from the left pane (This is 
the one you created), then press the Right arrow (>) to put it in the Right Pane. 
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8. Press OK. 

9. Expand the Schedule Section by pressing the Down Arrow at the right side of the section. 

10. Press the Add Schedule button and select scheduled time. 

11. Scroll to the Applied To section. 

12. Double-click on the Windows Computers with Inventory Plug-in entry. 

13. Press the Update Results button. 

14. Press Cancel. 

Because this is a Lab environment we will choose to keep the “Windows Computers with 
Inventory Plug-in” target.  The Detection Rule will run on all computers in your test 
environment.    

If this was a production environment then you may wish to delete the “Windows Computers 
with Inventory Plug-in” target and create a new target that may be appropriate to the scope of 
endpoints you wish this policy to run on (i.e., Windows Servers.)  

15. Enable the policy by scrolling to the top and selecting the OFF button in red and choosing ON.  It 
should turn green. 

16. Press Save Changes (At the bottom of the policy). 

17. We will now run a Policy Update to speed up the process…  In the Main Menu, select Settings > 
Notification Server > Resource Membership Update. 

18. Under Policy Update Schedule, Press the Run button on the right side.  You should see “Policy 
Update Schedule has Completed” at the top of the window when it completes. 

Execute the Targeted Software Inventory Policy 

1. Open the Symantec Management Agent on the task bar by double clicking it. 

2. From the top menu, press the Update Configuration button. 

3. Select the Task Status Tab.  You can press the “Check for Tasks” button if the policy has not run 
after the specified time. 
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4. Wait for the Targeted Software Inventory policy to execute successfully at the time you set.  You 
should see “Success – return code 1” if it completes sucessfully.  

 

NOTE: If it displays “Success – return code 0”, return to your Software Release detection rule 
and check the text in the detection rule entries, then run the Targeted Software Inventory again 
on a new scheduled time. 

5. Close the Symantec Management Agent Windows 

6. Switch to the SD7 VM. 

7. Repeat steps 1 – 5 on the SMP VM to complete the TSI process. Notice that policy returns 
“Success – return code 1” because the SMP VM has an installation of MS SQL Server 2008 
Server R2 Enterprise Edition also. 

8. Switch to the Win7 VM. 

9. Repeat steps 1 – 5 on the WIN7 VM to complete the TSI process.  You should see “Success – 
return code 0” because it does not have MS SQL Server installed. 

Manage the Newly Detected Software Component 

1. Switch to the SMP VM 

2. Select Manage | Software Catalog in the main menu. 

3. Under the Newly Discovered\undefined software pane, enter 2008 R2 Enterprise in the search 
field. 

4. You should now see your “Microsoft SQL Server 2008 R2 Enterprise Edition” software release.  
Select this entry 

5. Select the Right Arrow (>) beside the Managed Software Products pane.  The Software Product 
window appears. 

6. Select the Identify Inventory tab. 
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7. Under the Identify Inventory tab, delete the 10.51 text in the Version field, then retype 10.51 
back into the field – This will refresh the view and display 2 installations of Microsoft SQL Server 
R2 Enterprise in your environment (From SMP & SD7 Virtual Machines). 

 

This entry shows the number of endpoints with MS SQL 2008 Server R2 Enterprise Edition installed.  If 
this screen only shows 1 Installation then open the Symantec Management Agent on the SMP or SD7 
VM and press Update Configuration.   

8. Press OK. 

9. Press Close.  The software catalog is closed. 

10. In the console, choose Manage > Software 

11. Select Favorites > Installed Products in the left pane 

12. Select the newly created Microsoft SQL Server 2008 R2 Enterprise Edition product in the 
Installed Products Pane 

13. Notice that SMP and SD7 show up as installations in the right pane.  Now that you have a 
distinct Software Product created, you may now associate licenses, purchases, and other asset 
attributes to it like purchase orders and inclusion in master software agreements. 
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Lab Exercise 4 (OPTIONAL): Software Reporting  

This section will provide a brief walkthrough of the available Software reports and views available in the 
technologies covered in this lab.  It is very important that the Software License Recalculation Schedule 
and IT Analytics Cubes have been processed to get the most current results: 

Processing the ITA Cubes: 

1. From the Symantec Management Console, navigate to: Settings > Notification Server > IT Analytics 
Settings. 

2. Select Processing in the left pane. 

3. Press the New button on the right pane. 

4. Type Refresh Cubes in the Processing Task field 

5. Select the Application Metering, Assets, Computers, Installed Files, Installed Software, Software License 
Compliance and Software Purchases boxes. 

6. Press the Create Task button at the bottom of the page 

7. Make sure Refresh Cubes task is selected in the Processing Task: dropdown List and press Run Now. This 
may take a few minutes 

 

8. When the IT Analytics Process Viewer window shows “Processing trace completed.” At the top of the list, 
press Close 

 

 

 

Processing the Software License Recalculation Schedule: 

1. In Windows, Select  Start > Administrative Tools > Task Scheduler. 

2. Locate the NS.Software Product Licensing Recalculation… task under the Task Scheduler 
Library Folder. 

 

3. Right Click on the task and choose Run. 
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4. Wait until it finishes processing. It should only take about a minute.  (You can refresh the 
display to check.) 

Software Inventory and License Compliance Reporting 

You can view reports to get information about the actions that you perform in Software Management 
Solution. Predefined reports let you easily view and analyze your Software Management Solution data.  

The reports are grouped in folders by type in the Symantec Management Console. You can also create 
your own custom reports.  The following table describes the report types found in the Software 
Management Solution 

 

Exploring Commonly used Software Asset Management Reports 

1. Go to the SMP VM. 

2. Open the Symantec Management Console. 

3. Go to Reports | All Reports from the main console menu. 

4. In the left pane, browse to the Software Folder and expand it. 

5. Choose the Application Metering folder. 

6. Run any of the following reports to get an idea of the Application Metering reports available: 

Report Name Description 

Denial Events by Application 
This report gives a list of applications and the number of denials in the 
last 'N' days.  

Executable Usage 
Program file install and usage count from legacy Software Metering 
policies as well as new software-based usage tracking configuration.  

Metered software without a file association Gives a list of Metered software that is missing the file association 

Underutilized Software 
Identifies installed software that is not being used on computers with 
the Metering plug-in installed.  

7. Choose the Compliance folder 

  

    Report Categories Description

    Application Management  
Contains the reports that display information about the Windows Installer applications that are broken 

or that have inaccessible source paths.

    Application Metering  
Contains the reports that display information about the usage, denial and underutilization software in 

your environment.

    Compliance  
Contains the reports that display information about the compliance actions and the remediation actions 

that Managed Software Delivery performs.

    Data Providers  Provides a summary of the Data Providers and the status of the import process

    Delivery  

Contains the reports that display information about the status of the software downloads and 

executions.  If you migrated software delivery data from Software Delivery Solution 6.x, the new 

delivery reports contain data from both 6.x and 7.x.

    Portal  
Contains the reports that display the status of software requests that are made through the Software 

Portal.

    Virtualized Software Resources  
Contains the reports that display information about the actions (events) that have been performed on 

the virtual layers that are installed on client computers.
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8. Run any of the following reports to get an idea of the Compliance reports available to you: 

Report Name Description 

Software Compliance by Computer 
Displays Software Compliance information for all Managed Delivery Policies by 
Computer.  

Software Compliance by Managed 
Delivery Policy 

Displays Software Compliance information by Policy for Managed Delivery Policies.  

Software Compliance Detailed 
Summary 

Displays compliance status with respect to each computer for software installed via 
Managed Delivery policies.  

Software Compliance Remediation 
Summary 

Summarizes number of remediation attempts per software delivery policy.  

Software Compliance Status 
Displays software compliance status for managed delivery policies based upon a 
software resource  

Software Compliance Summary 
Summarizes aggregate compliance status of software installed via Managed Delivery 
policies.  

 

--- END OF LAB --- 

 

  


